Download it now!
Bug 95562 - Crash when printing a document with images (OpenGL)
Summary: Crash when printing a document with images (OpenGL)
Status: RESOLVED DUPLICATE of bug 94851
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
5.0.3.2 release
Hardware: x86-64 (AMD64) Windows (All)
: high critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
: 95786 95830 96309 (view as bug list)
Depends on:
Blocks: VCL-OpenGL
  Show dependency treegraph
 
Reported: 2015-11-04 09:28 UTC by Thomas Jacob
Modified: 2016-11-25 22:13 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
backtrace.txt created with WinDbg (X64) for Windows 10 (21.16 KB, text/plain)
2015-11-12 12:50 UTC, Thomas Jacob
Details
Screenshot LibreOffice -> View, No hardware acceleration (15.13 KB, image/png)
2015-11-16 09:25 UTC, Thomas Jacob
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Jacob 2015-11-04 09:28:15 UTC
LibreOffice (tested with Writer, Calc and Impress) 5.0.2.2 (x64) release and 5.0.3.2 (x64) release (not yet selectable above) crashes when printing a document with one or more images included. Documents without images are printing fine.

Crash occurs after clicking on "OK" in the print dialog box.

Deactivating OpenGL-Rendering as described here (https://bugs.documentfoundation.org/show_bug.cgi?id=94851#c13) seems to help, no more crash when printing documents with images.


Version: 5.0.3.2 (x64)
Build-ID: e5f16313668ac592c1bfb310f4390624e3dbfb75-GL

Windows 10 Pro 64-bit, Intel Core i5-3570, 16 GB RAM, AMD Radeon 7870 (with Catalyst 15.7.1)
Comment 1 Buovjaga 2015-11-12 10:12:38 UTC
A backtrace would help: https://wiki.documentfoundation.org/How_to_get_a_backtrace_with_WinDbg
Comment 2 Thomas Jacob 2015-11-12 12:50:58 UTC
Created attachment 120497 [details]
backtrace.txt created with WinDbg (X64) for Windows 10

There is an "ERROR: Symbol file could not be found. [...]" in the Exception Analysis, do I need a special Symbol File Path for x64 or what is the problem here?
However, maybe the backtrace.txt is OK?
Comment 3 Buovjaga 2015-11-12 12:59:02 UTC
(In reply to Thomas Jacob from comment #2)
> Created attachment 120497 [details]
> backtrace.txt created with WinDbg (X64) for Windows 10
> 
> There is an "ERROR: Symbol file could not be found. [...]" in the Exception
> Analysis, do I need a special Symbol File Path for x64 or what is the
> problem here?
> However, maybe the backtrace.txt is OK?

Yeah, there is always that one symbol message.. but the bt seems ok!
Comment 4 Buovjaga 2015-11-15 16:06:56 UTC
*** Bug 95786 has been marked as a duplicate of this bug. ***
Comment 5 Buovjaga 2015-11-15 16:07:14 UTC
Setting to NEW due to bug 95786
Comment 6 Buovjaga 2015-11-15 16:07:32 UTC
Prioritizing..
Comment 7 Buovjaga 2015-11-16 08:12:34 UTC
Thomas: what if you only disable hardware acceleration, but leave the Use OpenGL checkbox enabled?

I think we might have a duplicate in bug 95830
Comment 8 Thomas Jacob 2015-11-16 09:25:05 UTC
Created attachment 120567 [details]
Screenshot LibreOffice -> View, No hardware acceleration

I think hardware acceleration is already disabled ... look at my screenshot, the checkbox is not actionable. I have not changed the default configuration.
Comment 9 Buovjaga 2015-11-16 10:12:45 UTC
*** Bug 95830 has been marked as a duplicate of this bug. ***
Comment 10 Arfy 2015-11-19 19:58:13 UTC
I have the same problem, and Hardware accell is also greyed (and not set) in my option...
Comment 11 Buovjaga 2015-11-20 06:40:46 UTC
(In reply to Arfy from comment #10)
> I have the same problem, and Hardware accell is also greyed (and not set) in
> my option...

HW accel is automatically set, when OpenGL is set. That is why it is greyed out.
Comment 12 raal 2015-12-07 15:09:10 UTC
*** Bug 96309 has been marked as a duplicate of this bug. ***
Comment 13 Michael Meeks 2015-12-11 22:57:00 UTC
We've disabled GL by default for 5.0.x - so hopefully that nails things there =) Thanks for reporting ! this is a duplicate of 94851 - now also fixed, and being back-ported for 5.1.

*** This bug has been marked as a duplicate of bug 94851 ***
Comment 14 Michael Meeks 2016-11-25 22:13:34 UTC
*** Bug 94830 has been marked as a duplicate of this bug. ***