Download it now!
Bug 96257 - OPENGL: Cell border while dragging, column and row lines while changing their size are white not black with OpenGL enable.
Summary: OPENGL: Cell border while dragging, column and row lines while changing their...
Status: RESOLVED DUPLICATE of bug 96919
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.0.3.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.2.0
Keywords:
Depends on:
Blocks: VCL-OpenGL
  Show dependency treegraph
 
Reported: 2015-12-04 23:56 UTC by m.a.riosv
Modified: 2016-10-25 19:11 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description m.a.riosv 2015-12-04 23:56:39 UTC
Cell border while dragging, column and row lines while changing their size are white not black with OpenGL enable.
Comment 1 Tor Lillqvist 2015-12-14 13:14:54 UTC
Yep, I see what you mean. Can reproduce (in the 5.1 branch, presumably also in master, but I don't have a build at the moment).
Comment 2 Tor Lillqvist 2015-12-14 15:01:50 UTC
The call to the Win32 InvertRect() in WinSalGraphicsImpl::invert() in vcl/win/gdi/gdiimpl.cxx is fun. As far as I see, it has absolutely not effect at all. At least not for its use case when dragging column/row widths/heights as in this bug. (And when using OpenGL, it presumably can't be right at all to call such a GDI function directly?)
Comment 3 Tor Lillqvist 2015-12-14 15:05:04 UTC
(Ah, but it isn't called when using OpenGL, so at least that's fine.)
Comment 4 Tor Lillqvist 2015-12-14 15:27:17 UTC
Interesting that in the OpenGL case, a black line is (incorrectly) drawn in the column/row header area (but then a white line in the spreadsheet cell grid). I wonder if this is a good hint at what goes wrong.

(In the (correct) non-OpenGL case, nothing is draw in the headers.)
Comment 5 Tor Lillqvist 2015-12-15 12:31:16 UTC
What's especially entertaining here is that what the coe actually wants to do is to draw the line being dragged in "invert" ("xor") mode, but fails to do so both in the non-OpenGL (solid black) and OpenGL (solid white) case...
Comment 6 Commit Notification 2015-12-16 07:15:44 UTC
Tor Lillqvist committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ec8bc265050d86a749140c353360a78cce4e3fce

tdf#96257: Silly work-around to produce same result on OpenGL and non-OpenGL

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Michael Meeks 2016-01-06 13:48:48 UTC

*** This bug has been marked as a duplicate of bug 96919 ***