Download it now!
Bug 96919 - SetXORMode un-implemented ...
Summary: SetXORMode un-implemented ...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.1.0.1 rc
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.2.0 target:5.1.0.2
Keywords:
: 96257 (view as bug list)
Depends on:
Blocks: VCL-OpenGL
  Show dependency treegraph
 
Reported: 2016-01-06 10:07 UTC by Michael Meeks
Modified: 2016-10-25 19:11 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
test on Windows with OpenGL (45.46 KB, image/png)
2016-01-06 11:42 UTC, V Stuart Foote
Details
test on Windows no OpenGL (40.44 KB, image/png)
2016-01-06 11:43 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Meeks 2016-01-06 10:07:36 UTC
If you enter 1, 2, 3 into cells A1, A2, A3 - and select them.

Then by clicking the selected area you should be able to drag those around the sheet.

This should draw a double border in black to show where they will end up - but (it seems) that this doesn't work - annoyingly; we get some white border instead ;-)

Could be another 'invert' problem ? or some missing path in the GL code (?).
Comment 1 V Stuart Foote 2016-01-06 11:42:06 UTC
Created attachment 121745 [details]
test on Windows with OpenGL

@Michael, *

On Windows 10 Pro 64-bit ((10586) en-US with

Version: 5.2.0.0.alpha0+
Build ID: fe37d93a110cb9941c61fed0c71369a21a7d2765
CPU Threads: 8; OS Version: Windows 6.2; UI Render: GL; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-12-30_23:13:15
Locale: en-US (en_US)

The outline border of "destination" cells rather than a double black is receiving what looks to be a Gray 6 outline at 2, possibly 3 px.  With OpenGL disabled, do not see a difference even at 400%. Not sure if there is supposed to be a difference, at least on Windows 10
Comment 2 V Stuart Foote 2016-01-06 11:43:27 UTC
Created attachment 121746 [details]
test on Windows no OpenGL

no discernible difference between with and without OpenGL active
Comment 3 Tor Lillqvist 2016-01-06 11:54:47 UTC
V: See ec8bc265050d86a749140c353360a78cce4e3fce
Comment 4 Tor Lillqvist 2016-01-06 11:56:22 UTC
Related to (duplicate of?) bug #96257.
Comment 5 Michael Meeks 2016-01-06 13:24:04 UTC
Riight - so on Windows there is a workaround with Tor's commit =)
I believe that this is ultimately an artifact of XOR rendering not being implemented; but ... I wonder if we can get ROP_XOR and ROP_INERT fixed by just getting the glBlendMode set correctly.
Comment 6 Michael Meeks 2016-01-06 13:48:48 UTC
*** Bug 96257 has been marked as a duplicate of this bug. ***
Comment 7 Michael Meeks 2016-01-08 21:29:52 UTC
VclDemo test is here: https://gerrit.libreoffice.org/21274 pending CI coming back =)
Comment 8 Michael Meeks 2016-01-08 22:26:57 UTC
And implementation is here awaiting CI buildage:

https://gerrit.libreoffice.org/21282

Will push for -5-1 tomorrow (DV).
Comment 9 Commit Notification 2016-01-09 09:35:11 UTC
Michael Meeks committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2a5afa8394d4ef928c56c0b62e76984b1b87e8c8

tdf#96919 - vcldemo - implement XOR rendering test.

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2016-01-09 09:35:15 UTC
Michael Meeks committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c71de1458cebcd45b65cef3a182bf1092dc8ad80

tdf#96919 - vcl opengl: implement missing XOR mode.

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Michael Meeks 2016-01-09 09:41:45 UTC
Fixed; and a back-port for -5-1 awaits review here:
https://gerrit.libreoffice.org/21288
Comment 12 Commit Notification 2016-01-11 10:06:12 UTC
Michael Meeks committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1b2a60dbde98034125aa30551c12bcf0d1c420b8&h=libreoffice-5-1

tdf#96919 - vcl opengl: implement missing XOR mode.

It will be available in 5.1.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.