Bug 96263 - Formatting DOC version missing top part and splitted on two pages vs PDF
Summary: Formatting DOC version missing top part and splitted on two pages vs PDF
Status: RESOLVED DUPLICATE of bug 81263
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: interoperability
Keywords: bibisected, bisected, filter:doc, regression
Depends on:
Blocks:
 
Reported: 2015-12-05 08:06 UTC by Ari Latvala
Modified: 2016-09-24 14:33 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
PDF showing, how it should be (40.26 KB, image/png)
2015-12-05 08:06 UTC, Ari Latvala
Details
DOC version having extra blank page and missing top part (18.18 KB, image/png)
2015-12-05 08:07 UTC, Ari Latvala
Details
test file (51.00 KB, application/msword)
2015-12-07 12:44 UTC, raal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ari Latvala 2015-12-05 08:06:08 UTC
Created attachment 121034 [details]
PDF showing, how it should be

Using LibreOffice 5.0.4.1 on Windows 7 64-bit. 

DOC version of the document "Keltainen kortti-lomake" found fom http://www.kissaliitto.fi/lomakkeet/nayttely has extra blank page in the beginning and missing the top part of the document, when comparing to RTF or ODF versions available on the same site. Screenshots attached.
Comment 1 Ari Latvala 2015-12-05 08:07:57 UTC
Created attachment 121035 [details]
DOC version having extra blank page and missing top part

Extra blank page in the beginning on the DOC version and missing the top part of the document totally.
Comment 2 Joel Madero 2015-12-05 15:57:26 UTC
Tested:
Bodhi Moksha
LibreOffice 3.3 (no problem)
LibreOffice 5.0/5.2 (problem)

Marking as:
NEW (confirmed);
Minor - can slow down professional work but won't completely prevent it (you can delete the extra page).
Medium - regression 


Would be great to get a bibisect of this.
Comment 3 Ari Latvala 2015-12-05 16:50:46 UTC
Extra page may be minpr but that totally missing top part of the doc is worse.
Comment 4 raal 2015-12-07 12:43:01 UTC
bibisect-win32-5.0, oldest version contains bug too.
git checkout oldest: Version: 4.5.0.0.alpha0+
Build ID: 57d6b92b69a31260dea0d84fcd1fc5866ada7adb
Comment 5 raal 2015-12-07 12:44:08 UTC
Created attachment 121108 [details]
test file
Comment 6 Joel Madero 2015-12-13 02:13:35 UTC
61023f2c6c2d5a7c36b6a410b041e8aa397c59d8 is the first bad commit
commit 61023f2c6c2d5a7c36b6a410b041e8aa397c59d8
Author: Matthew Francis <mjay.francis@gmail.com>
Date:   Sat Mar 14 20:09:29 2015 +0800

    source-hash-3755c87d0426a499d4755e82d8fbc77caa240764
    
    commit 3755c87d0426a499d4755e82d8fbc77caa240764
    Author:     Miklos Vajna <vmiklos@collabora.co.uk>
    AuthorDate: Mon May 26 12:04:39 2014 +0200
    Commit:     Miklos Vajna <vmiklos@collabora.co.uk>
    CommitDate: Mon May 26 12:20:47 2014 +0200
    
        bnc#863018 WW8 import: fix upper margin of multi-page floating table
    
        A vert orient position was already handled in case a floating table was
        imported as a TextFrame, but in case we didn't do that, the vert orient
        position was simply lost.
    
        Fix this by importing it as the upper margin of the table (assuming that
        the position is relative from the anchor position).
    
        Change-Id: I3e96f3068605fd6313dfb3e55483e1bce6c063a5

:040000 040000 9ec9ec8666008daa3a9dace7c3fff4006ab86d58 27c0461e0ea1c6bc9ed7ce8c95a592f235439a87 M	opt


# bad: [cf6ea17155fabb2a120ba07c150735591ac861d7] source-hash-3f94c9e9ddfd807b449f3bb9b232cf2041fa12d2
# good: [fc71ac001f16209654d15ef8c1c4018aa55769f5] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
git bisect start 'latest' 'oldest'
# bad: [8cf60cc706948588e2f33a6d98b7c55d454e362a] source-hash-f340f0454627939f1830826fb5cc53a90e6c62a4
git bisect bad 8cf60cc706948588e2f33a6d98b7c55d454e362a
# bad: [d9885f526fc7a09cc8f9f8ee643af1b966be24bb] source-hash-d1465c64c6f64ad8dd25e40cdc69649b24b305ea
git bisect bad d9885f526fc7a09cc8f9f8ee643af1b966be24bb
# bad: [e3eab511ffbcd2e1e2c67e7a4fec162bb0b26b7a] source-hash-dc9cc46f3223aff3f85d3ce9696178a5f4d3d087
git bisect bad e3eab511ffbcd2e1e2c67e7a4fec162bb0b26b7a
# skip: [abcc1a4b07f3ef8bfeeed62b1902d8ba927e21d6] source-hash-aa48af57531851a16204381854f1ee19ebb63a6a
git bisect skip abcc1a4b07f3ef8bfeeed62b1902d8ba927e21d6
# bad: [e395392b476b31f4061480e3d80047699cb56261] source-hash-e1cee80e4cb18e506d4a5fe3d2f4d6403e8f2223
git bisect bad e395392b476b31f4061480e3d80047699cb56261
# bad: [c543d45de0a1547beccd682b19792413f3a72973] source-hash-2bc74417150dd4301d4b864b6c95942384eb5daf
git bisect bad c543d45de0a1547beccd682b19792413f3a72973
# good: [99dda1c2e60d8be755a7a68ffeba216a9ebe7131] source-hash-4cb41493edd162a83975e7b7604a3bf4ca43a578
git bisect good 99dda1c2e60d8be755a7a68ffeba216a9ebe7131
# good: [68e69f17f5cb684627af174dd4f16b8f4b400661] source-hash-1413d6bc9902a536c0c67f42d2cb16ea45174fe4
git bisect good 68e69f17f5cb684627af174dd4f16b8f4b400661
# good: [2395e3ac72f54d7bb25f2e6980f56d1683adb214] source-hash-c31f50f63872ccb1527dd661670cc7ab01fd6021
git bisect good 2395e3ac72f54d7bb25f2e6980f56d1683adb214
# good: [0ac2a9387d6b83b738fb40759c99d327b8811aaf] source-hash-bd7d32bf1ce15dfc08b029ec1c9ace0c53cab5b9
git bisect good 0ac2a9387d6b83b738fb40759c99d327b8811aaf
# good: [0f9666340340dd17dab878d6bc468ad4e15bccd6] source-hash-55029129aa92f7906bb8b91464fb74aa4d9e72e3
git bisect good 0f9666340340dd17dab878d6bc468ad4e15bccd6
# good: [347df710b3e03def48c7c89577e25bda0afb8ef7] source-hash-09c0a96eb3ea8d48e99ed50ae7d13d23f70a0c6c
git bisect good 347df710b3e03def48c7c89577e25bda0afb8ef7
# bad: [e27c95edf42cd783c077e5ffcf5e3d9faedf5492] source-hash-d8f958a201a8c6320684ad2e03fd15dfba818520
git bisect bad e27c95edf42cd783c077e5ffcf5e3d9faedf5492
# bad: [b3c24eccbe48e187bb085e4b120410f71d6c829d] source-hash-69d2fe6e57dd77b735234d139343b3a3faee165d
git bisect bad b3c24eccbe48e187bb085e4b120410f71d6c829d
# bad: [61023f2c6c2d5a7c36b6a410b041e8aa397c59d8] source-hash-3755c87d0426a499d4755e82d8fbc77caa240764
git bisect bad 61023f2c6c2d5a7c36b6a410b041e8aa397c59d8
# first bad commit: [61023f2c6c2d5a7c36b6a410b041e8aa397c59d8] source-hash-3755c87d0426a499d4755e82d8fbc77caa240764
Comment 7 Ari Latvala 2016-06-02 20:34:24 UTC
Document still splitted to several pages on LO 5.2 Beta 1 for Windows 7 SP1 64-bit
Comment 8 Aron Budea 2016-09-01 05:49:07 UTC
First bad commit verified, adding bisected keyword. Bug still present in v5.2.1.2. Readjusting severity to normal, as the header table in the document is missing.
Adding Miklos to CC, please take a look.
Comment 9 Aron Budea 2016-09-01 05:55:25 UTC
Adding 3 other bug reports as related, where bibisection points to the very same commit.
Comment 10 Aron Budea 2016-09-01 05:59:26 UTC
*** Bug 96277 has been marked as a duplicate of this bug. ***
Comment 11 Xisco Faulí 2016-09-24 14:33:15 UTC

*** This bug has been marked as a duplicate of bug 81263 ***