Download it now!
Bug 96297 - FILEOPEN: checkboxes too big on RTF vs PDF and DOC version causing incorrect layout
Summary: FILEOPEN: checkboxes too big on RTF vs PDF and DOC version causing incorrect ...
Status: RESOLVED DUPLICATE of bug 98321
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: interoperability
Keywords: filter:rtf
: 96264 (view as bug list)
Depends on:
Blocks: RTF DOC
  Show dependency treegraph
 
Reported: 2015-12-06 22:19 UTC by Ari Latvala
Modified: 2018-06-07 06:17 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
RTF version having too big checkboxes (157.23 KB, application/rtf)
2015-12-06 22:19 UTC, Ari Latvala
Details
PDF version showing the expected layout (26.87 KB, application/pdf)
2015-12-06 22:19 UTC, Ari Latvala
Details
DOC version of the document (61.50 KB, application/msword)
2015-12-06 22:20 UTC, Ari Latvala
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ari Latvala 2015-12-06 22:19:08 UTC
Created attachment 121086 [details]
RTF version having too big checkboxes

LibreOffice 5.0.4.1 running on Windows 7 64-bit system.

RTF version of the document "Astutussopimus" available at http://www.kissaliitto.fi/lomakkeet/kasvattaja showing bigger checkboxes than PDF and DOC version of the same document leading to incorrect layout. All 3 documents attached.
Comment 1 Ari Latvala 2015-12-06 22:19:35 UTC
Created attachment 121087 [details]
PDF version showing the expected layout
Comment 2 Ari Latvala 2015-12-06 22:20:17 UTC
Created attachment 121088 [details]
DOC version of the document
Comment 3 Ari Latvala 2015-12-06 22:21:12 UTC
Related to bug report 96264 of the different problems on DOC version.
Comment 4 Buovjaga 2015-12-08 10:06:03 UTC
Confirmed.

Win 7 Pro 64-bit Version: 5.2.0.0.alpha0+
Build ID: 81fa5340191baf8687f9c82f1f414f5afc86b529
Threads 4; Ver: Windows 6.1; Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-12-03_21:19:19
Locale: fi-FI (fi_FI)

LibreOffice 3.5.0rc3 
Build ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735
Comment 5 Ari Latvala 2016-06-02 20:21:01 UTC
Problem still exist on the latest LO 5.2 Beta 1 for Windows 7 SP1 64-bit
Comment 6 Yousuf Philips (jay) (retired) 2017-04-18 16:16:26 UTC
Size of checkboxes in .doc file look fine to me, but yes they are much to large in the RTF version.

Version: 5.4.0.0.alpha0+
Build ID: 04edc5c796c1b96e5228d0c1fcf73bcf52465b66
CPU threads: 2; OS: Linux 3.19; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-04-15_03:25:45
Locale: en-US (en_US.UTF-8); Calc: group
Comment 7 QA Administrators 2018-04-19 02:34:48 UTC Comment hidden (obsolete)
Comment 8 Ari Latvala 2018-04-26 18:12:15 UTC
Bug is still present on RTF version but not any more on DOC. RTF version has too big check boxes, DOC version then again adds extra page breaks but has correct check box size. Refer to bug 98321.

Version: 6.0.3.2 (x64)
Build ID: 8f48d515416608e3a835360314dac7e47fd0b821
CPU threads: 2; OS: Windows 10.0; UI render: default; 
Locale: fi-FI (fi_FI); Calc: group
Comment 9 Ari Latvala 2018-06-07 06:08:46 UTC
This bug is duplicate with Bug 98321 - FILEOPEN: RTF checkbox font type wrong and size too big.
Comment 10 Ari Latvala 2018-06-07 06:15:53 UTC
*** Bug 96264 has been marked as a duplicate of this bug. ***
Comment 11 Ari Latvala 2018-06-07 06:17:46 UTC
This is duplicate with bug 98321

*** This bug has been marked as a duplicate of bug 98321 ***