Bug 96337 - FORMATTING: When numbering paragraphs, the numbers occasionnally forget their style (bold)
Summary: FORMATTING: When numbering paragraphs, the numbers occasionnally forget their...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.0.5 release
Hardware: All Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2015-12-08 12:23 UTC by f5d505f9
Modified: 2020-05-15 15:44 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
test doc numbering style (861.55 KB, application/vnd.oasis.opendocument.text)
2015-12-08 12:23 UTC, f5d505f9
Details
test doc minimal (339.72 KB, application/vnd.oasis.opendocument.text)
2019-12-20 18:56 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description f5d505f9 2015-12-08 12:23:53 UTC
Created attachment 121138 [details]
test doc numbering style

My paragraph style numbers my paragraph. I have set the used number style to put the numbers in bold, but this is occasionnally 'forgotten' by the program. (I also use 'paragraph titles', which is just text at the beginning of the paragraph in bold to summarise it.)

How to reproduce most easily: open the attachment. Go somewhere in the text. Add a new paragraph by pushing on enter. This paragraph is numbered; the number should be in bold but often is not (repeat a few times if the bug does not appear). Typing in the paragraph often reminds Writer of the style; bolding the first characters has often the same result.

Technical information:

OS: Windows 10, also appeared in Windows 8 (both home edition).

LO: 5.0.3.2  (x64) (has been present since some time)
Build ID: e5f16313668ac592c1bfb310f4390624e3dbfb75
Locale: nl-BE (nl_BE)
Comment 1 f5d505f9 2015-12-13 09:08:38 UTC Comment hidden (obsolete)
Comment 2 f5d505f9 2015-12-22 13:05:26 UTC Comment hidden (obsolete)
Comment 3 Jean-Baptiste Faure 2016-01-08 08:39:11 UTC Comment hidden (obsolete)
Comment 4 Buovjaga 2016-01-11 08:12:15 UTC
(In reply to f5d505f9 from comment #2)
> Correction: I was a little bit too quick. The bug is still present, but
> somewhat less severe.

What do you mean? I tried 30 times, but the number was always bold.

Win 7 Pro 64-bit Version: 5.2.0.0.alpha0+
Build ID: 22e5170af74c635cf55d089f97946b6dc86f82ad
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-01-05_23:41:26
Locale: fi-FI (fi_FI)
Comment 5 FutureProject 2016-01-11 19:10:19 UTC
Windows 10 Pro, Version 1511 (OS Build 10586.36)
LibreOffice 5.0.4.2, Build ID 2b9802c1994aa0b7dc6079e128979269cf95bc78
Locale en_US

Can confirm described behaviour. Reproduced by: going to page 341, placing cursor 10 characters after footnote 1726 and pressing Enter repeatedly. Only the paragraph number next to the cursor will be bold. Example:

1. Set your cursor to the described position, press Enter, paragraph number 762 appears in bold next to the cursor.
2. Press Enter again, paragraph number 763 is in bold next to the cursor, 762 has lost its formatting.
3. Press Enter yet again, paragraph number 764 is in bold next to the cursor, 763 has lost its formatting.

The bold formatting did "come and go" when writing and deleting characters in those new paragraphs, although I could not discern any pattern.

Changing to NEW since I found it to be reliably reproduceable otherwise.
Comment 6 Jean-Baptiste Faure 2016-01-12 05:46:32 UTC
The numbering loses is bold attribute when the paragraph is empty. Type some text and the bold attribute comes back. In fact bold is not an attribute like the color, it is the variant of the font. You are using "Strong accentuation" as character style for the numbering style. If you change the character color in this character style, you can see that the color attribute is kept even when the paragraph is empty.

Not sure if it a bug.

Tested with LibreOffice 5.1.0.0.0+ built at home under Ubuntu 15.10 x86-64.

Best regards. JBF
Comment 7 Jean-Baptiste Faure 2016-01-12 05:55:56 UTC
Idem as comment #6 with LibreOffice 5.0.5.0.0+

Best regards. JBF
Comment 8 QA Administrators 2017-03-06 14:17:07 UTC Comment hidden (obsolete)
Comment 9 QA Administrators 2019-12-03 14:51:50 UTC Comment hidden (obsolete)
Comment 10 Timur 2019-12-20 18:56:00 UTC
Created attachment 156703 [details]
test doc minimal

With master 6.5+, ODT cannot be open at all. I'll report another regression.
Report is not clear, never say "go somewhere" but be precise instead.

For test, I add 2-pages ODT.
If we type enter in item 4., numbering is as expected bold, text regular.
If we type enter in item 5., numbering is not bold until text typed. 
Tested with reported LO 5.0 and LO 6.0. 
And that was a regression because worked fine in OO 3.3. and LO 4.4.
But no repro anymore with LO 6.3.3 and master 6.5+. So WFM.
Comment 11 Timur 2020-05-15 13:56:53 UTC
Bibisected with 62, fixed with: 

168c54c84fb9e5f7b673af39df970bd80359c9ad is the first *good* commit
commit 168c54c84fb9e5f7b673af39df970bd80359c9ad
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Fri Mar 22 12:50:08 2019 +0100

    source sha:6bbcf6e2839ef2747ec3677e5daa7a6ce118fd81
    Previous source sha:76848756909cb969b4689ebd2dd3b5fa27b0dc23

https://gerrit.libreoffice.org/plugins/gitiles/core/+/6bbcf6e2839ef2747ec3677e5daa7a6ce118fd81%5E!/

commit	6bbcf6e2839ef2747ec3677e5daa7a6ce118fd81	[log]
author	Miklos Vajna <vmiklos@collabora.com>	Mon Mar 18 21:40:15 2019 +0100
committer	Caolán McNamara <caolanm@redhat.com>	Fri Mar 22 12:24:58 2019 +0100
tree	b1454087b7da6c8a5b65f647cd572204aa0f9229
parent	76848756909cb969b4689ebd2dd3b5fa27b0dc23 [diff]

tdf#120548 sw ApplyParagraphMarkFormatToNumbering: fix handling of font color
Comment 12 Buovjaga 2020-05-15 15:44:55 UTC
Cool -> FIXED