Bug 129529 - Cannot open 819-pages ODT
Summary: Cannot open 819-pages ODT
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.8.2 release
Hardware: All All
: high major
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: target:7.0.0 target:6.4.2 target:6.3.6
Keywords: bibisected, bisected, filter:odt, regression
Depends on:
Blocks:
 
Reported: 2019-12-20 19:41 UTC by Timur
Modified: 2020-02-21 14:58 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
perf flamegraph (234.97 KB, application/x-bzip)
2019-12-21 15:55 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Timur 2019-12-20 19:41:23 UTC
Cannot open 819-pages ODT attachment 121138 [details] from bug 96337 in LO master 6.5+.

Note: additional perf issue because OO 3.3 took much less to open compared to LO 6.1 where worked (0:28 to 0:58 on my slow system).
Comment 1 MM 2019-12-20 20:31:15 UTC
Confirmed on mint 19.3 x64 with Version: 6.5.0.0.alpha0+
Build ID: 9e63d328691014bc97f6b66b708ed9dec53618e6
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-12-18_00:38:35
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 2 Oliver Brinzing 2019-12-21 10:10:39 UTC Comment hidden (obsolete)
Comment 3 Julien Nabet 2019-12-21 15:55:18 UTC
Created attachment 156719 [details]
perf flamegraph

On pc Debian x86-64 with master sources updated today + enable-symbols, it doesn't open after 20 secs (I didn't wait more).
Thought a Flamegraph may help to pinpoint the pb.
Comment 4 Xisco Faulí 2019-12-26 11:14:22 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=7e8b4756d95057f069467b34e7849f9354856578

author	Michael Stahl <Michael.Stahl@cib.de>	2018-09-17 11:26:01 +0200
committer	Michael Stahl <Michael.Stahl@cib.de>	2018-09-19 10:18:33 +0200
commit	7e8b4756d95057f069467b34e7849f9354856578 (patch)
tree	65e3065a6c5ff6e63dfc4e689b5e43a4ca04d41b
parent	ede29e57cd14946c8668ca7d2b84dbc3afa90fd5 (diff)
sw_redlinehide_2: disable layout-cache for now
Both reading & writing.

Bisected with: bibisect-linux64-6.2

Adding Cc: to Michael Stahl
Comment 5 Michael Stahl (CIB) 2020-02-19 18:25:54 UTC
the funny document has this in meta.xml

meta:page-count="819" meta:paragraph-count="302"

for which laycache.cxx:604

  mnMaxParaPerPage = nNdCount / nPgCount;

cunningly estimates a maximum of 0 paragraphs per page, and at that rate an infinite number of pages are required...
Comment 6 Commit Notification 2020-02-20 14:46:28 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/a9f2f4b4c9e1fa4e4c4a69517c31d0b8e2063f01

tdf#129529 sw_redlinehide: infinite loop in SwLayHelper::CheckInsert()

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Michael Stahl (CIB) 2020-02-20 17:45:06 UTC
i hope its fixed but its hard to tell with a debug build because it takes forever to open the document in any case
Comment 8 Xisco Faulí 2020-02-20 19:15:31 UTC
(In reply to Michael Stahl (CIB) from comment #7)
> i hope its fixed but its hard to tell with a debug build because it takes
> forever to open the document in any case

Yes, it's fixed in

Version: 7.0.0.0.alpha0+
Build ID: d7cab304e7dd22fd12443a1ee3b6a9c463bf9a3d
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

@Michael, thanks for fixing this issue!
Comment 9 Xisco Faulí 2020-02-20 19:19:10 UTC
(In reply to Timur from comment #0)
 additional perf issue because OO 3.3 took much less to open compared
> to LO 6.1 where worked (0:28 to 0:58 on my slow system).

@Timur, could you please report the performance issue in a follow-up report ?
Comment 10 Commit Notification 2020-02-20 19:22:09 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/fef72fe382d04068cc5480f682125411c54d5dc2

tdf#129529 sw_redlinehide: infinite loop in SwLayHelper::CheckInsert()

It will be available in 6.4.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2020-02-21 14:58:55 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/6ecad243cc17a6857a177b659c539f3be45a6ed1

tdf#129529 sw_redlinehide: infinite loop in SwLayHelper::CheckInsert()

It will be available in 6.3.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.