Bug Hunting Session
Bug 96456 - Old version Linux Libertine G and Linux Biolinum G fonts in Window installer
Summary: Old version Linux Libertine G and Linux Biolinum G fonts in Window installer
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 98024 (view as bug list)
Depends on:
Blocks: Fonts
  Show dependency treegraph
 
Reported: 2015-12-13 13:25 UTC by zorki
Modified: 2018-02-01 16:20 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Trouble with Linux Biolinum G version 1.1.0 (53.40 KB, application/pdf)
2015-12-13 13:25 UTC, zorki
Details

Note You need to log in before you can comment on or make changes to this bug.
Description zorki 2015-12-13 13:25:09 UTC
Created attachment 121256 [details]
Trouble with Linux Biolinum G version 1.1.0

In all version LibreOffice windows installer(including 5.0.3) Linux Libertine G has version 5.1.3, Linux Biolinum G - 1.1.0.

www.linuxlibertine.org has version 5.3.0 of Linux Libertine G and version 1.1.8 of Linux Biolinum G.

With old version (1.1.0) that present in LibreOffice installer Linux Biolinum G shows the terrible results for Cyrillic bold and bold italic variants. See attachment.

New version of Linux Biolinum G (1.1.8) don't have this problem.

Could you to upgrade these fonts in the installer to fix the problems with the Cyrillic?

Gentium Book Basic and Gentium Basic that come with Libreoffice Installer does not have a Cyrillic glyph.

But sil.org have beautiful Gentium Plus with Cyrillic and other Glyphs.
Comment 1 V Stuart Foote 2015-12-13 17:14:13 UTC
To New...

Seems reasonable to bundle the more complete fonts. 

Could we also upgrade to the more complete sil.org Gentium Book Basic and Gentium Basic?

And while we're at it, assuming SIL licensing is acceptable, I'd like to put in a plug for adding support for SMuFL and Unicode Music Symbols code pages with inclusion of the Barvua font.

=-ref-=
http://www.smufl.org/fonts/
Comment 2 Andras Timar 2015-12-13 17:42:59 UTC
Are you sure that fonts from www.linuxlibertine.org have the Graphite extensions? 

Let's CC the expert, Laszlo Nemeth.
Comment 3 V Stuart Foote 2015-12-13 19:00:55 UTC
(In reply to V Stuart Foote from comment #1)

> with inclusion of the Barvua font.
> 
> =-ref-=
> http://www.smufl.org/fonts/

s/Barvua/Bravura/
Comment 4 zorki 2015-12-13 22:01:52 UTC
(In reply to Andras Timar from comment #2)
> Are you sure that fonts from www.linuxlibertine.org have the Graphite
> extensions? 
> 
> Let's CC the expert, Laszlo Nemeth.

I don't now about the Graphite extensions. But the Graphite is not an idol. Linux Biolinum G v 1.1.0 is defective for cyrillic. See atachment. Expert opinion does not cancel the defect of the font.
Comment 5 Adolfo Jayme 2016-02-22 08:52:17 UTC
*** Bug 98024 has been marked as a duplicate of this bug. ***
Comment 6 Adolfo Jayme 2016-02-22 08:56:45 UTC
I don’t think the Graphite version of the Linux Libertine fonts are being actively developed. The fonts from www.linuxlibertine.org DO contain Cyrillic, but are also not in active development.

If we are to keep bundling the Graphite Libertine fonts, any new development on these should be based off the most recent fork of the upstream fonts: https://github.com/khaledhosny/libertinus
Comment 7 Adolfo Jayme 2016-02-22 09:00:26 UTC
In the end we should be supporting selectable OpenType features, and then we could stop bundling the Graphite fonts. See https://github.com/khaledhosny/libertinus/issues/6
Comment 8 QA Administrators 2017-10-23 13:58:53 UTC Comment hidden (obsolete)
Comment 9 Khaled Hosny 2018-02-01 16:20:19 UTC
Linux Libertine G and Linux Biolinum G are forked from Linux Libertine and Linux Biolinum fonts with Graphite support, their upstream is https://numbertext.org/linux/ and not http://www.linuxlibertine.org/. The latest versions of the Linux Libertine G and Linux Biolinum G are what is already bundled with LibreOffice and there are no newer upstream releases.