Download it now!
Bug 96550 - change color of icons on toolbar in Writer when activated OpenGL
Summary: change color of icons on toolbar in Writer when activated OpenGL
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
5.1.0.1 rc
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: noRepro:Windows:5.2.0alpha0+ noRepo:L...
Keywords:
Depends on:
Blocks: VCL-OpenGL
  Show dependency treegraph
 
Reported: 2015-12-16 19:13 UTC by Roman Kuznetsov
Modified: 2016-10-25 19:17 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot with different color of icons (26.74 KB, image/png)
2015-12-16 19:13 UTC, Roman Kuznetsov
Details
screenshot with normal color of icons (26.25 KB, image/png)
2015-12-16 19:14 UTC, Roman Kuznetsov
Details
Impress. SideBar. Section Slide Transition. Different color (18.23 KB, image/png)
2016-01-08 14:42 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2015-12-16 19:13:47 UTC
Created attachment 121353 [details]
screenshot with different color of icons

Version: 5.1.0.1
ID build: bcace328aabc4c8c10b56daa87da0a2ee6579b5a
Threads 2; Ver: Windows 6.1; Render: default; 

Locale: ru-RU (ru_RU)

subj. in attach screenshot with illustrations of this bug
Comment 1 Roman Kuznetsov 2015-12-16 19:14:51 UTC
Created attachment 121354 [details]
screenshot with normal color of icons

if OpenGL rendering is disabled, then color is OK
Comment 2 V Stuart Foote 2015-12-16 19:43:26 UTC
Confirming...

On Windows 8.1 Enterprise 64-bit en-US with
Version: 5.1.0.1 (x64)
Build ID: bcace328aabc4c8c10b56daa87da0a2ee6579b5a
Threads 8; Ver: Windows 6.29; Render: default; 

Locale: en-US (en_US)

Here are a bit better STR

1. Open Writer
2. Insert -> Shape -> Basic --or Symbol--
3. split menu listing will show mix of brown and blue icons adjacent to shapes
4. disable OpenGL rendering--Tolls -> Options -> View
5. restart
6. open writer
7. Insert -> Shape -> Basic --or Symbol--
8. split menu listing will show all blue icons adjacent to shapes
Comment 3 V Stuart Foote 2015-12-17 00:48:31 UTC
Adjusting version to 5.1.0.1

Norepro Windows 8.1 with current master
Version: 5.2.0.0.alpha0+ (x64)
Build ID: cfe08df695c046371c4361a434176e6381e3e064
CPU Threads: 8; OS Version: Windows 6.29; UI Render: GL; 
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-12-15_13:10:55
Locale: en-US (en_US)
Comment 4 Michael Meeks 2016-01-08 14:18:30 UTC
Ooh - that is interesting; I suspect those PNGs are different in some way - quite possibly they have a much reduced palette, or some different bit-depth internally that is causing this.

And - looking at this now - I too can reproduce this myself on the -5-1 branch - how interesting.

Thanks !
Comment 5 Roman Kuznetsov 2016-01-08 14:42:21 UTC
Created attachment 121794 [details]
Impress. SideBar. Section Slide Transition. Different color

https://bugs.documentfoundation.org/show_bug.cgi?id=90897 
This bug does not look like?
Comment 6 Michael Meeks 2016-01-09 12:07:14 UTC
For 5-1:

https://gerrit.libreoffice.org/21289 tdf#96657 - vcl opengl: implement invert: Track Frame.

For master:

https://gerrit.libreoffice.org/21290 tdf#96657 - vcldemo - implement invert: Track Frame rendering test.
https://gerrit.libreoffice.org/21291 tdf#96657 - vcl opengl: implement invert: Track Frame.

Review for -5-1 appreciated - Tor ?
Comment 7 Michael Meeks 2016-01-09 12:07:55 UTC
Drat - wrong bug =) re-opening this one.
Comment 8 Michael Meeks 2016-01-09 12:09:59 UTC
The interesting thing about this bug is that it works fine on master =) though since there are no really obvious differences between the vcl/opengl code paths - I imagine it is caused by changes in the icons themselves (?)
Comment 9 Michael Meeks 2016-01-09 20:57:25 UTC
It appears to be the icons with an 8-bit colormap, rather than RGBA (which work fine) that are rendered incorrectly; presumably palletized images. And there are identical icons on master which render fine; I see this only on the -5-1 branch on windows.
Comment 10 Michael Meeks 2016-01-09 21:01:59 UTC
Interestingly; loading the same image to embed it in the document gives a nice, blue result ;-)
Comment 11 Michael Meeks 2016-01-09 21:17:03 UTC
Fixed in master, patch for review for -5-1 here:

https://gerrit.libreoffice.org/21295

Review appreciated Tor =)
Comment 12 Commit Notification 2016-01-09 21:17:11 UTC
Michael Meeks committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=33208c347182d8fe80bfbe34fe3e0b4b21a0a7a2

tdf#96550 - vcl opengl - fix BGR/RGB swap for some 8-bit icons.

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2016-01-11 10:09:20 UTC
Michael Meeks committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c332ed4794dc0ae818416b36aa5295a9dd34c9c6&h=libreoffice-5-1

tdf#96550 - vcl opengl - fix BGR/RGB swap for some 8-bit icons.

It will be available in 5.1.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Roman Kuznetsov 2016-01-12 14:14:13 UTC
Version: 5.1.0.1.0+
ID build: e9e641b39a98df8c6aef8d2f12f4a589ed887612
CPU Threads: 4; OS Version: Windows 6.1; UI Render: GL; 
TinderBox: Win-x86@62-merge-TDF, Branch:libreoffice-5-1, Time: 2016-01-12_11:37:42
Locale: ru-RU (ru_RU)

bug is not reproduced. fixed!