Bug 96835 - The main LibreOffice icon could use redesign -- not distinctive enough in some Desktop environments
Summary: The main LibreOffice icon could use redesign -- not distinctive enough in som...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.4.7.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 97286 106851 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-12-30 19:18 UTC by Elliotte Rusty Harold
Modified: 2019-01-06 07:44 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot with icons. (63.38 KB, image/png)
2016-01-02 01:48 UTC, m.a.riosv
Details
zip archive containing icon suggestions by Chen ZeeYuen (1.85 MB, application/zip)
2016-01-02 15:11 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Elliotte Rusty Harold 2015-12-30 19:18:41 UTC
The application icon shown on Mac OS X, i.e. that appears in the dock, is confusingly close to the page with folded corner that the Mac has used (with slight variations) for a document of unknown type for the last several decades. 

In fact, it was only this morning that I looked closely enough at the LO icon to realize it really is something different. Until then, I thought LO just had a mucked up install with corrupted icons (happens sometimes on Mac).

Not critical by any means but it is really confusing to longtime Mac users. I suggest a complete redesign of the icon.
Comment 1 Alex Thurgood 2015-12-31 13:52:25 UTC
Similar, true, but nonetheless different. Let's hand this over to UX to decide.
Comment 2 V Stuart Foote 2015-12-31 14:45:29 UTC
Screen clips would be helpful as most do not have access to an OS X system.

Comments of similar ilk regards the "generic" LibreOffice icon over on the Design ML  http://nabble.documentfoundation.org/The-LibreOffice-Suite-Desktop-Icon-tc4166063.html

Recently Paulo José Amaro has rejoined design effort with a proposed replacement set for the Mime icons. Some recent Design ML activity:

http://nabble.documentfoundation.org/Mime-Type-Icons-Redesign-Proposal-tc4165489.html

http://nabble.documentfoundation.org/Mime-Type-Icons-Redesign-Proposal-w-links-tc4165551.html

These are Paulo's suggested replacements for the "generic" LibreOffice icon

https://wiki.documentfoundation.org/File:Pj-document-icon-2015-11-13-v2.png
https://wiki.documentfoundation.org/File:Pj-document-icon-2015-11-13-v1.png

A good starting point for what will essentially become a marketing/branding component.
Comment 3 m.a.riosv 2016-01-02 01:48:21 UTC
Created attachment 121676 [details]
Screenshot with icons.

I have done my own desktop icons mainly to differentiate between some of the installed versions, so I don't need to go over the icon and see their pop-up text.

I think a some people has the stable and fresh installed, some way to differentiate it could be nice.
Comment 4 V Stuart Foote 2016-01-02 15:11:39 UTC
Created attachment 121679 [details]
zip archive containing icon suggestions by Chen ZeeYuen

rcvd PM with attached Icon redesign proposal with following note.

From: Chin Zee Yuen <chinzeeyuen@xxxxxx>
Subject: Re: [libreoffice-design] Re: The LibreOffice Suite Desktop Icon
Date: Sat, 2 Jan 2016 18:42:47 +0800

Hey guys,

I had designed new set of icons for LibreOffice main and content apps’s icon, I wanted to contribute to LibreOffice and hope they will use my design or get some inspirations. I have sent them before but didn’t get reply so not sure they seen it, but here’s goes again!
Please checkout my design and let me know what you think, if you have some suggestions please let me know too!

...
Comment 5 V Stuart Foote 2016-01-02 15:50:49 UTC
@Miguelangel, *
(In reply to m.a.riosv from comment #3)
> Created attachment 121676 [details]
> Screenshot with icons.
> 
> I have done my own desktop icons mainly to differentiate between some of the
> installed versions, so I don't need to go over the icon and see their pop-up
> text.
> 
> I think a some people has the stable and fresh installed, some way to
> differentiate it could be nice.

I don't see this a appropriate for the 4.4 releases, although issue of an indistinct application icon is certainly present--it is just too late in that branch release cycle to be changing it.

So, I like the idea of lifting the LibreOffice 5 design layout from the about banner as the core of the primary application icon! No confusion there.

Agree it would be nice if the bit level and the branch could be displayed as you have done. The Yellow for the release and green for bitness reads well. But think the symbology for the 5.x would probably not be needed.

Down side to this is having to generate a release specific icon for each--but once started should be simple enough to maintain.
Comment 6 m.a.riosv 2016-01-02 17:43:15 UTC
(In reply to V Stuart Foote from comment #5)
> @Miguelangel, *
> (In reply to m.a.riosv from comment #3)
> 
> I don't see this a appropriate for the 4.4 releases, although issue of an
> indistinct application icon is certainly present--it is just too late in
> that branch release cycle to be changing it.
> 
> So, I like the idea of lifting the LibreOffice 5 design layout from the
> about banner as the core of the primary application icon! No confusion there.
> 
> Agree it would be nice if the bit level and the branch could be displayed as
> you have done. The Yellow for the release and green for bitness reads well.
> But think the symbology for the 5.x would probably not be needed.

> 
> Down side to this is having to generate a release specific icon for
> each--but once started should be simple enough to maintain.

It`s not a propose, I'm not a designer, only to show what I have done.

But it very well serve me, with more than a dozen of LibreOffice versions installed. The image from welcome screen I think does a very readable icons.

If we can achieve a good mix of design and productivity, would be nice. Many icons on desktop don't allow to know what they are at the first glance, even they are pretty.
Comment 7 V Stuart Foote 2016-01-23 00:10:44 UTC
*** Bug 97286 has been marked as a duplicate of this bug. ***
Comment 8 Robinson Tryon (qubit) 2016-08-25 05:49:22 UTC Comment hidden (obsolete)
Comment 9 eric f 2016-11-22 15:12:52 UTC
The main LibreOffice Logo (the default icon) is not very attractive. It's rather ok for a "flat design" icon in a black and white linux theme, but it's not appealing at all and look rather empty (a white rectangle) for the general user, if we compare it to the OpenOffice logo or microsoft office logo.

The individual icons for every program (writer, calc, draw) are looking good, it's just the main logo which should get more colors and a stronger identity.
Comment 10 Xisco Faulí 2017-03-29 11:17:47 UTC
*** Bug 106851 has been marked as a duplicate of this bug. ***
Comment 11 Heiko Tietze 2017-12-06 20:26:26 UTC
This icon is our branding and identification. We do not plan to change it. If you want more colorful symbols on your desktop/dock you can easily exchange the icon locally - or just place links to the modules there instead of the start center.

https://wiki.documentfoundation.org/Marketing/Branding
https://wiki.documentfoundation.org/Visual_Elements