Bug 96968 - Enhancement Request for a bookmark list in the file menu (Favorite documents)
Summary: Enhancement Request for a bookmark list in the file menu (Favorite documents)
Status: RESOLVED DUPLICATE of bug 38742
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks:
 
Reported: 2016-01-08 20:07 UTC by hans.van.buitenen
Modified: 2020-12-11 10:59 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
video (2.02 MB, video/mp4)
2020-09-26 05:06 UTC, BogdanB
Details

Note You need to log in before you can comment on or make changes to this bug.
Description hans.van.buitenen 2016-01-08 20:07:48 UTC
Hi,
i am frequently opening the same ducuments and find i tiresome to have to browse to it each time. In many cases it has just exceeded the file history list.

Is it possible to add a bookmarks list just below or above the file history list?
Comment 1 Cor Nouws 2016-01-08 23:22:23 UTC
Hi Hans,

Thanks for filing this!
Is this more or less the same as bug 38742 ?
Comment 2 hans.van.buitenen 2016-01-09 16:18:19 UTC
Bug 96968 (pushpins) is another solution to the same issue.
I would prefer a bookmark list since it is cleared and is separates the dynamic from the static, but i guess you would not offer both. While Mozilla does seems to offer both, for a word processor that might be considered overdone.
Comment 3 hans.van.buitenen 2016-01-09 16:23:58 UTC
Correction: "bug 96968 (pushpins)" should be "bug 38742 (pushpins)"
Comment 4 Cor Nouws 2016-01-10 15:12:58 UTC
Hi Hans,

Understand your point.
Setting this to new too.

Let see what comes out (also wrt start center.)
Cheers - Cor
Comment 5 BogdanB 2020-09-26 05:06:39 UTC Comment hidden (obsolete)
Comment 6 V Stuart Foote 2020-09-26 12:41:29 UTC
(In reply to BogdanB from comment #5)
> We have 2 places where you can acces the bookmarks:
> - status bar - just right click in the left corner and acces your bookmark
> - Navigator  - Bookmarks - just click and acces your bookmark

wrong "bookmark" concept. OP and duplicate bug 38742, deal with notating a "favorite" file.  Bookmark concept as from Web page for Web browsers.

Most likely location in the UI would be the document history in user profile as manifested to the Recent Files menu and the StartCenter
Comment 7 BogdanB 2020-09-26 15:09:38 UTC
If I understand correct this enhancement is something like marking files as favorite in LibreOffice.

In this case I imagine this like this: in the recent files in Start Center when is a "x" to close the file to be a star or something to mark the file as favorite. The same thing could be done in the recent files inside LibreOffice, when a document is open (File-Recent Documents) to have a star or a pin.

And in order to view them could be a new tab similar to Recent Files (in Start Center) and "Favorite Documents" in File, near Recent Documents.

I would use that. I didn't understand at first, because of the term "bookmark".
Comment 8 Heiko Tietze 2020-12-11 10:59:54 UTC
(In reply to BogdanB from comment #7)
> If I understand correct this enhancement is something like marking files as
> favorite in LibreOffice.

And consequently a duplicate of bug 38742.

*** This bug has been marked as a duplicate of bug 38742 ***