Download it now!
Bug 97124 - Paste not working from external application
Summary: Paste not working from external application
Status: RESOLVED DUPLICATE of bug 62196
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.7.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Paste
  Show dependency treegraph
 
Reported: 2016-01-14 08:59 UTC by Franco
Modified: 2018-10-18 15:05 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Video showing the issue (8.69 MB, video/x-ms-asf)
2016-01-14 16:34 UTC, Franco
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Franco 2016-01-14 08:59:58 UTC
Apply all versions 4.x and the new 5.x too, in my experience Writer and Chart for sure.
Paste does not work from a cut/copy made from an external application if a previuosly cut/copy and paste was made inside Libreoffice applications.
More details: When you open first Libreoffice, cut/copy and paste from an external application it is ok whenever you want, but if you cut/copy and paste inside Libreoffice applications it is not possible to paste from an external application anymore. The clipboard retains only the data cut/copied of the Libreoffice application.
In this case the only solution is to restart Libreoffice.
I am not sure but the issue did not affects version 3.x.
Comment 1 raal 2016-01-14 13:23:13 UTC
Hello,
which external application? No problem with copy from firefox.
Comment 2 Franco 2016-01-14 16:34:03 UTC
Created attachment 121944 [details]
Video showing the issue

Let's see what happend with copy and paste in Writer (.wmv file)
Comment 3 Franco 2016-01-14 16:37:10 UTC
Hello raal,
the problem is with any application. I attached a video (.wmv) where you can see a copy/paste simply from notepad.
Thanks and regards.
Comment 4 Buovjaga 2016-01-19 18:59:42 UTC
This annoyance is familiar to me, but now I can't reproduce.

Win 7 Pro 64-bit, Version: 5.0.4.2 (x64)
Build ID: 2b9802c1994aa0b7dc6079e128979269cf95bc78
Locale: fi-FI (fi_FI)
Comment 5 Aron Budea 2016-05-31 04:35:17 UTC
Franco, are you still encountering this issue in a recent version of LibreOffice?
I couldn't reproduce this either.

Something weird I noticed when I was trying to test this in LO 5.1.3.2/Windows 7 was that sometimes Edit -> Paste menu item got disabled, when there was text on the clipboard (Ctrl-C was working fine, too). Unfortunately it happened rarely, and I couldn't reliably reproduce it.
Comment 6 Franco 2016-05-31 10:07:56 UTC
(In reply to Aron Budea from comment #5)
> Franco, are you still encountering this issue in a recent version of
> LibreOffice?
> I couldn't reproduce this either.
> 
> Something weird I noticed when I was trying to test this in LO
> 5.1.3.2/Windows 7 was that sometimes Edit -> Paste menu item got disabled,
> when there was text on the clipboard (Ctrl-C was working fine, too).
> Unfortunately it happened rarely, and I couldn't reliably reproduce it.

Hello Aron Budea,

the problem persisted for months, recently I have upgrade my computer to WinX and reinstall Libreoffice and the problem has disappeared!! The version is and was the same (5.1.2.2).

So I don't know if the issue can be still considered unconfirmed or resolved!

Thanks and regards.
Comment 7 Buovjaga 2016-05-31 10:16:44 UTC
Thanks. I'll call it WFM.
Comment 8 Paul Hutchinson 2018-10-18 13:11:58 UTC
This is still happening on LibreOffice Writer Version 6.1.0.3.  I have also had it happen over several years now so it's not just 6.1.x

Whatever the problem is it has been in many versions.

I installed a clip board monitor program (Free Clipboard Viewer 3.0) and it shows the Windows clip board changing from external programs (without leaving any LibreOffice stuff behind) but LO continues to paste the old content.
Comment 9 Buovjaga 2018-10-18 13:23:50 UTC
(In reply to Paul Hutchinson from comment #8)
> This is still happening on LibreOffice Writer Version 6.1.0.3.  I have also
> had it happen over several years now so it's not just 6.1.x
> 
> Whatever the problem is it has been in many versions.
> 
> I installed a clip board monitor program (Free Clipboard Viewer 3.0) and it
> shows the Windows clip board changing from external programs (without
> leaving any LibreOffice stuff behind) but LO continues to paste the old
> content.

What are the applications you are pasting from? There is bug 101257 for Edge browser.

Let's set to NEW for now anyway.
Comment 10 Aron Budea 2018-10-18 14:57:08 UTC
Isn't this and bug 62196 the same?
Comment 11 Buovjaga 2018-10-18 15:05:28 UTC
(In reply to Aron Budea from comment #10)
> Isn't this and bug 62196 the same?

Uh, yeah, I did not check why it was WFM. Set it back to NEW now.

*** This bug has been marked as a duplicate of bug 62196 ***