Bug 97249 - Text with "MS Sans Serif" font is not properly rendered/displayed
Summary: Text with "MS Sans Serif" font is not properly rendered/displayed
Status: RESOLVED DUPLICATE of bug 98989
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: x86 (IA32) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard: target:5.1.4
Keywords: bibisectRequest, regression
: 97590 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-01-19 11:32 UTC by Michael Velten
Modified: 2016-10-25 19:17 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Working with LibreOffice_4.2.8.2 (58.08 KB, image/jpeg)
2016-01-19 11:32 UTC, Michael Velten
Details
Not working with any Version later LibreOffice_4.2.8.2 (47.82 KB, image/jpeg)
2016-01-19 11:33 UTC, Michael Velten
Details
The problem document (16.00 KB, application/msword)
2016-01-19 11:33 UTC, Michael Velten
Details
Using a converting table works than (37.11 KB, image/jpeg)
2016-01-20 10:09 UTC, Michael Velten
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Velten 2016-01-19 11:32:04 UTC
User-Agent:       Mozilla/5.0 (Windows NT 10.0; rv:43.0) Gecko/20100101 Firefox/43.0
Build Identifier: LibreOffice 5.0.4.2

A whole line is missing. See screenshots and the problem word document.

Reproducible: Always

Steps to Reproduce:
1. Open the attached file with any version after LibreOffice_4.2.8.2

Actual Results:  
The second line is missing


[Information automatically included from LibreOffice]
Locale: de
Module: TextDocument
[Information guessed from browser]
OS: Windows (All)
OS is 64bit: no


Reset User Profile?Yes
Comment 1 Michael Velten 2016-01-19 11:32:38 UTC
Created attachment 122078 [details]
Working with LibreOffice_4.2.8.2
Comment 2 Michael Velten 2016-01-19 11:33:09 UTC
Created attachment 122079 [details]
Not working with any Version later LibreOffice_4.2.8.2
Comment 3 Michael Velten 2016-01-19 11:33:35 UTC
Created attachment 122080 [details]
The problem document
Comment 4 Cor Nouws 2016-01-19 11:56:15 UTC
Hi Michael,

Thanks for filing and the clear screen shots.

On Ubuntu 32 bits I cannot reproduce the bug with 4.4.0rc2, 5.1.0 (build 2016-01-12) nor with a recent daily (2016-01-12).
So possibly a windows specific problem?

Cheers,
Cor
Comment 5 Joel Madero 2016-01-19 16:24:48 UTC
Please test with a currently supported version of LibreOffice (5.x). Marking as NEEDINFO. If you can confirm with 5.x series mark as UNCONFIRMED. Thanks
Comment 6 Michael Velten 2016-01-19 16:38:36 UTC
An other Windows PC the same problem with the last version 4.4.7 and 5.0.4  - not working - the second line is missing.
Comment 7 Jean-Baptiste Faure 2016-01-19 21:54:35 UTC
Not reproducible for me with LO 5.0.5.0.0+ and 5.1.1.0.0+ on Ubuntu 15.10 x86-64.

I guess th problem is related to W10. Please, could you try with another version of MS-Windows, like 7 or 8 ?

Best regards. JBF
Comment 8 Michael Velten 2016-01-20 05:45:31 UTC
Windows 7 Professional - 32bit - 5 Computer - Libo 4 + 5 , same Problem.
Comment 9 Michael Velten 2016-01-20 05:50:40 UTC
All versions LibreOffice > 4.2.8.2 did not work
All version before LibreOffice =< 4.2.8.2 are working, also the whole 3.x Serie
Comment 10 Jean-Baptiste Faure 2016-01-20 08:29:50 UTC
Not sure if it was already the case with LO 4.3 but since LO 4.4 you can use OpenGL for all rendering. Please could you check if this option is activated or not.
It is set in menu Tools > Options > LibreOffice > View.

Best regards. JBF
Comment 11 Michael Velten 2016-01-20 09:21:34 UTC
I found out that the problem is the Font "MS Sans Serif" which is not displayed with Versions >= 4.2.8.2 

The Font is on the Computer installed. If I change the Font to Arial or any other, save it with < 4.2.8.2, than open it with >= 4.2.8.2 than the Text is visible again.
Comment 12 Michael Velten 2016-01-20 10:02:54 UTC
Ok to explain it better. The attached Word Document above has a Font "MS Sans Serif" in the second header line. It will be shown in the Font Dropdown Box as "MS Sans Serif" too.  

The newer versions did not have this font in the Dropdown Box, its called there "Microsoft Sans Serif" there is no "MS Sans Serif".

Possible there is the Problem ?
Comment 13 Michael Velten 2016-01-20 10:09:39 UTC
Created attachment 122110 [details]
Using a converting table works than

If I enter the problem Fonts in a converting table, than it works with >= 4.2.8.2 . But that is a problem, I do not know that a Font is missing or wrong inside a Document I received, because I see not the chars and even I do not know which Fonts I must convert. So there is bug in >= 4.2.8.2
Comment 14 Urmas 2016-01-20 13:00:43 UTC
OpenGL is not related.
The invisible line cannot be navigated with cursor keys.
Comment 15 Jean-Baptiste Faure 2016-01-20 13:10:14 UTC
Strange, on my Ubuntu 15.10 the font MS Sans Serif is not installed (its name is written in italic in the dropdown font list in the sidebar) however the text is displayed with a replacement font.

Best regards. JBF
Comment 16 Michael Velten 2016-02-05 13:29:28 UTC
I have another problem but it is the same problem with missing fonts, did not noticed it before that the Font make the graphical chars.

https://bugs.documentfoundation.org/show_bug.cgi?id=97590
Comment 17 Cor Nouws 2016-02-05 14:11:56 UTC
display in 4.2.8.2 is OK, so is a more recent problem
Comment 18 Cor Nouws 2016-02-05 14:12:25 UTC
*** Bug 97590 has been marked as a duplicate of this bug. ***
Comment 19 Michael Stahl (CIB) 2016-05-11 18:48:47 UTC
"MS Serif" and "MS Sans Serif" are Windows 3.0 .fon non-scalable fonts
which are not supported and must be substituted automatically by VCL

-> duplicate to the notorious Windows "Courier" bug

*** This bug has been marked as a duplicate of bug 98989 ***
Comment 20 Commit Notification 2016-05-16 14:50:41 UTC
Tor Lillqvist committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=081b0f19b4f665a30e2209e805aebd2f25345d70&h=libreoffice-5-1

tdf#97249: Don't crash if BindFont fails

It will be available in 5.1.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.