Bug Hunting Session
Bug 97431 - Shlomo font not accessible
Summary: Shlomo font not accessible
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.4.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: RTL-Hebrew Font-List
  Show dependency treegraph
 
Reported: 2016-01-29 12:37 UTC by Axel Niedenhoff
Modified: 2018-01-30 23:39 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Shlomo font selected by typing, it was not in the font list (5.71 KB, image/png)
2018-01-30 23:11 UTC, Shai Berger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Axel Niedenhoff 2016-01-29 12:37:26 UTC
On my Linux box (RHEL 6.7) I have installed the Shlomo font from here: https://sites.google.com/site/orlaeinayim/download

The font is not displayed in the various font selection lists in LibreOffice. All other fonts in my .fonts folder are displayed without problems. That includes, for example, the Ezra SIL font, upon which Shlomo is based. So it looks as if some slight change in Shlomo compared to Ezra SIL prevents the font from being picked up by LO.

Other applications (LuaTeX, GEdit, for example) work fine with Shlomo.

I made sure that the Shlomo font has the same permissions as the other fonts and also ran fc-cache to update the font cache. Logging out and back in again does not fix the problem.

The same behavior occurs for Ubuntu 15.10 in the LO version shipped with the OS.
Comment 1 Julien Nabet 2016-01-31 11:14:28 UTC
First link https://sites.google.com/site/orlaeinayim/Shlomo.ttf?attredirects=0 provides Shlomo.ttf but installing it shows Ezra SIL in font list of Writer.
Here's what I get when I list fonts:
julien@julienPC:~/.fonts$ fc-list|grep -i ezra
/home/julien/.fonts/Shlomo.ttf: Shlomo,Ezra SIL SR:style=Regular
Comment 2 Julien Nabet 2016-01-31 11:17:04 UTC
Chris: knowing your refactoring work about fonts, thought it might interest you.
I wonder if there might be some process which would "clean" the font name, in this case, only keep the part which is after the comma.
Comment 3 Axel Niedenhoff 2016-01-31 13:00:50 UTC
I think the correct part would be the one before the comma, not after. The font should be loaded as Shlomo.
Comment 4 Aron Budea 2016-05-09 02:59:06 UTC
Can't reproduce with Ubuntu 15.10, LO 5.0.5.2, shows Shlomo in font list.
Axel, can you check with a newer version?
Comment 5 Axel Niedenhoff 2016-05-10 07:09:20 UTC
LO 5.1.2.2 on Ubuntu 16.04 still has the problem. The same is true for RHEL 6.7.
Comment 6 Aron Budea 2016-05-10 08:21:53 UTC
Oh well, back to UNCONFIRMED status we go.
Comment 7 Aron Budea 2016-05-10 20:49:31 UTC
Tried with a 32-bit Ubuntu 14.04 system, LO versions 4.2.8.2 and 5.1.2.2, and still couldn't reproduce it. I installed both Shlomo and Ezra SIL, too.
The issue must depend on something else as well.
Comment 8 Timur 2017-07-21 09:45:58 UTC
Axel, please test to see if the bug is still present on a current prerelease 5.4.0 from  https://www.libreoffice.org/download/. And also with http://dev-builds.libreoffice.org/daily/master/. 

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior. And some specifics, to find out why Aron couldn't reproduce. 
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System.

Please search for other similar bugs with fonts.
Comment 9 QA Administrators 2018-01-29 10:27:11 UTC Comment hidden (obsolete)
Comment 10 Axel Niedenhoff 2018-01-30 10:36:30 UTC
Here is what I find with LibreOffice 5.4.4.2 (the current version): On Windows, the Shlomo font gets correctly listed as Shlomo. On Linux (RHEL 6), the same TTF file lists as Ezra SIL SR in LO. For both tests, the real Ezra fonts were not present on the system.
Comment 11 Yousuf Philips (jay) (retired) 2018-01-30 22:24:55 UTC
Shlomo appears fine in the font list for me in Linux Mint 18 (ubuntu 16.04 base).

Version: 6.1.0.0.alpha0+
Build ID: ea89dabf8b6363972190a6b50c527c418d51c2c7
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: group threaded
Comment 12 Shai Berger 2018-01-30 23:11:15 UTC
Created attachment 139452 [details]
Shlomo font selected by typing, it was not in the font list

LO 5.4.4.2 on Debian Testing, Ezra SIL installed in the system.

Shlomo is not displayed in the font list, however, if I type in its name, I do get it (I can tell because the text looks like Ezra SIL).

fc-list output is as in Comment 1.
Comment 13 Khaled Hosny 2018-01-30 23:39:14 UTC
The font is simply broken; its “name” table has entries specifying the font as Shlomo and other entries specifying it as Ezra SIL SR (as reported by FontConfig), which if these entries ends up being used is system-dependent and outside of LibreOffice control.

The font needs to be fixed and provide consistent name table. Please report this to the font developer.