Download it now!
Bug 97475 - Display Issues: Start Center invisible buttons, Non updated screen
Summary: Display Issues: Start Center invisible buttons, Non updated screen
Status: RESOLVED DUPLICATE of bug 96546
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: All Windows (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: VCL-OpenGL
  Show dependency treegraph
 
Reported: 2016-02-01 08:59 UTC by pierre-yves samyn
Modified: 2016-02-11 17:54 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot: start center behing Tools Options LibreOffice View (17.21 KB, image/png)
2016-02-01 08:59 UTC, pierre-yves samyn
Details
OpenGL conf (181.91 KB, application/xml)
2016-02-10 17:23 UTC, pierre-yves samyn
Details
opengl_device.log (312 bytes, text/plain)
2016-02-11 17:07 UTC, pierre-yves samyn
Details
sal-log.txt (1.42 MB, text/plain)
2016-02-11 17:09 UTC, pierre-yves samyn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pierre-yves samyn 2016-02-01 08:59:37 UTC
Created attachment 122311 [details]
Screenshot: start center behing Tools Options LibreOffice View

Hi

Platform: Windows 7/64
Registry cleaned & New user profile for each test

Version: 5.1.0.3 (x64)
Build ID: 5e3e00a007d9b3b6efb6797a8b8e57b51ab1f737
CPU Threads: 2; OS Version: Windows 6.1; UI Render: GL;
Locale : fr-FR (fr_FR) 

I can not use the 32 and 64 bit versions in my environment.
Start center buttons are not displayed (but work if you click "at random").

Difficult to test other display options than the default (e.g. opengl) because
Dialog is not displayed.

The title bar in the attached screenshot shows after Click Options> LibreOffice> View: 
- start center buttons not dispaye
- entry in the treeview is not highlighted, 
- dialog remains on the User identity data,
- only the title is correct.

This bug is *NOT* reproduced (fr-QA testers) on:
-Windows 7 Home (Server Install GUI for 32bit version, direct install for x64
-Windows 7/32 (with or withour OpenGl) 

Regards
Comment 1 Buovjaga 2016-02-09 11:57:35 UTC
If you are having trouble disabling OpenGL, use regedit and imitate these: https://bug-attachments.documentfoundation.org/attachment.cgi?id=118060

Could you get us your gfx info with: http://www.realtech-vr.com/glview/download.php
https://wiki.documentfoundation.org/OpenGL#Windows

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided more information.
Comment 2 pierre-yves samyn 2016-02-10 17:17:53 UTC
Hi

(In reply to Beluga from comment #1)
> If you are having trouble disabling OpenGL, use regedit and imitate these:
> https://bug-attachments.documentfoundation.org/attachment.cgi?id=118060

Thank you, this solves the problem ... but IMHO this is *absolutely not* accessible to the end user. So I set status to UNCONFIRMED


> Could you get us your gfx info with:
> http://www.realtech-vr.com/glview/download.php
> https://wiki.documentfoundation.org/OpenGL#Windows
Comment 3 pierre-yves samyn 2016-02-10 17:22:42 UTC
(In reply to pierre-yves samyn from comment #2)

Continued from comment 2 (sorry bad keystroke)

I said I do not set status to RESOLVED because I think the workaround is just... a workaround and not an end-user one.

I attached my config (XML file)

Best Regards
Pierre-Yves
Comment 4 pierre-yves samyn 2016-02-10 17:23:27 UTC
Created attachment 122506 [details]
OpenGL conf
Comment 5 Michael Meeks 2016-02-11 14:30:35 UTC
Can you also get us the driver info from the opengl_device.log in your user-profile cache folder ?

Also - if you could download a dbgutil build and run it from the console, first export SAL_LOG=1 and capture the log output that would be fantastic; I suspect that some shader fails to compile early on & causes these problems - anyhow the debug will help us see what's up there.

Thanks !
Comment 6 Buovjaga 2016-02-11 15:45:01 UTC
Pierre-Yves: you can get a debug enabled build from here: http://dev-builds.libreoffice.org/daily/master/Win-x86@39/current/

Your opengl info log file is exactly in:
C:\Users\user\AppData\Roaming\LibreOffice\4\cache

For the SAL_LOG=1, you would need a cygwin terminal.
https://cygwin.com/install.html

Then you launch the cygwin terminal and:
cd /cygdrive/c/path-to-my-libreoffice/program

and then you can execute it with:
SAL_LOG=1 ./soffice.exe 2>&1 | tee sal-log.txt

It will create a log file sal-log.txt in the launching folder.
Comment 7 pierre-yves samyn 2016-02-11 17:07:49 UTC
Created attachment 122542 [details]
opengl_device.log
Comment 8 pierre-yves samyn 2016-02-11 17:09:07 UTC
Created attachment 122543 [details]
sal-log.txt
Comment 9 pierre-yves samyn 2016-02-11 17:12:09 UTC
Michael & Beluga

Many thanks.  I tried to follow the instructions. I hope the attached files are what you expect...

Best regards
Pierre-Yves
Comment 10 Michael Meeks 2016-02-11 17:54:37 UTC
Looks like another black-listing failure: the GL driver is:

DriverVersion: 8.16.11.8950
AdapterVendorID: 0x10de

which to humans means:

        DECLARE_VENDOR_ID(wgl::VendorNVIDIA, "0x10de");

NVIDIA - and the driver version is as above -but- our blacklist contains:

        <entry os="all" vendor="nvidia" compare="less" version="10.18.13.5362"> <!-- 353.62 -->
            <device id="all"/>
        </entry>

Which should mean that all devices with less than that version are black-listed on all OS' so ...

Tomaz is working on a unit test for the black-listing logic right now.

*** This bug has been marked as a duplicate of bug 96546 ***