Download it now!
Bug 97541 - INSERT: Part of SVG shape not rendered
Summary: INSERT: Part of SVG shape not rendered
Status: RESOLVED DUPLICATE of bug 97581
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:svg, regression
Depends on:
Blocks: SVG-Import
  Show dependency treegraph
 
Reported: 2016-02-03 21:05 UTC by Yousuf Philips (jay) (retired)
Modified: 2016-08-31 09:06 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
LibreOffice vs Inkscape (31.99 KB, image/png)
2016-02-03 21:05 UTC, Yousuf Philips (jay) (retired)
Details
screenshot (19.10 KB, image/png)
2016-02-10 16:58 UTC, Yousuf Philips (jay) (retired)
Details
unkown lines (1.30 KB, image/png)
2016-08-30 22:14 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2016-02-03 21:05:02 UTC
Created attachment 122364 [details]
LibreOffice vs Inkscape

Steps:
1) Open Writer
2) Insert https://dev.w3.org/SVG/tools/svgweb/samples/svg-files/dh.svg
3) Increase the size of the image so it equals to the width of the page
4) Notice that the top right corner of the light blue shape isnt being rendered

Regression as this doesnt happen in 4.0.6.2. Randomly at some zoom levels, the missing corner did appear.

Version: 5.2.0.0.alpha0+
Build ID: 513d5c5781ec14f8512432f31290a3d54c8d57df
CPU Threads: 2; OS Version: Linux 4.2; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-02-01_10:25:20
Locale: en-US (en_US.UTF-8)
Comment 1 raal 2016-02-04 08:29:25 UTC
I can confirm with Version: 5.2.0.0.alpha0+
Comment 2 Yousuf Philips (jay) (retired) 2016-02-10 16:58:55 UTC
Created attachment 122504 [details]
screenshot

A similar behaviour shows with the below SVG.

https://dev.w3.org/SVG/tools/svgweb/samples/svg-files/wireless.svg
Comment 3 Aron Budea 2016-07-11 01:17:57 UTC
Narrowing range when regression was introduced:
reproduced in 4.2.0.4, not reproduced in 4.1.0.4 (Ubuntu 15.10).

Not reproduced in Windows 7 at all.
Comment 4 Xisco Faulí 2016-08-30 22:14:58 UTC
Created attachment 127085 [details]
unkown lines

Issue introduced in range d9ead65397ea4b6d4bcc66cf304653bb71e14c9c..99fa8338fa3c740e610dc120848d353e5d1c9ef4, where b5c9668d34acdbce500609725760d6578debb95a looks to be the trigger of current behaviour. However, even before this commit, some unknown lines are present as it can be observed in the attached file, so I believe this issue is the same as in bug 97581
Comment 5 Xisco Faulí 2016-08-30 22:16:16 UTC

*** This bug has been marked as a duplicate of bug 97581 ***