Download it now!
Bug 97581 - INSERT: unknown lines appearing in SVG shape
Summary: INSERT: unknown lines appearing in SVG shape
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, filter:svg, regression
: 97541 (view as bug list)
Depends on:
Blocks: SVG-Import
  Show dependency treegraph
 
Reported: 2016-02-04 18:51 UTC by Yousuf Philips (jay) (retired)
Modified: 2016-10-08 23:09 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot (27.18 KB, image/png)
2016-02-04 18:51 UTC, Yousuf Philips (jay) (retired)
Details
screenshot - rfeed.svg (42.16 KB, image/png)
2016-02-09 15:59 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2016-02-04 18:51:15 UTC
Created attachment 122393 [details]
screenshot

Steps:
1) Open Writer
2) Insert https://dev.w3.org/SVG/tools/svgweb/samples/svg-files/feed.svg
3) Increase the size of the image so it equals to the width of the page
4) Notice that there are some orange partial lines in the bottom of the 2 curved lines

Regression as the lines arent there in 4.0.6.

Version: 5.2.0.0.alpha0+
Build ID: 513d5c5781ec14f8512432f31290a3d54c8d57df
CPU Threads: 2; OS Version: Linux 4.2; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-02-01_10:25:20
Locale: en-US (en_US.UTF-8)
Comment 1 raal 2016-02-05 08:44:39 UTC
No repro on windows Version: 5.2.0.0.alpha0+ (12/2015)
Comment 2 Yousuf Philips (jay) (retired) 2016-02-08 20:05:56 UTC
It is possible that this could be a duplicate of bug 97536
Comment 3 Yousuf Philips (jay) (retired) 2016-02-09 15:59:18 UTC
Created attachment 122487 [details]
screenshot - rfeed.svg

Here is another example file, and the lines are more noticeable.

https://dev.w3.org/SVG/tools/svgweb/samples/svg-files/rfeed.svg
Comment 4 raal 2016-02-09 19:14:01 UTC
(In reply to Yousuf (Jay) Philips from comment #3)
> Created attachment 122487 [details]
> screenshot - rfeed.svg
> 
> Here is another example file, and the lines are more noticeable.
> 
> https://dev.w3.org/SVG/tools/svgweb/samples/svg-files/rfeed.svg

I can confirm with Version: 5.2.0.0.alpha0+
Build ID: 91a7580e03d5b47c6e2513afce85ddee45e730b6
CPU Threads: 4; OS Version: Linux 4.2; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-02-04_00:17:43
Comment 5 Aron Budea 2016-07-10 23:42:46 UTC
Those lines are not visible in Windows 7, must be a Linux-only issue.
Not sure what the status was in 4.0.6, but I see the orange lines in 4.0.0.3.
Comment 6 Xisco Faulí 2016-08-30 22:16:16 UTC
*** Bug 97541 has been marked as a duplicate of this bug. ***
Comment 7 Xisco Faulí 2016-10-08 18:08:24 UTC
I can no longer reproduce this problem in

Version: 5.3.0.0.alpha0+
Build ID: ae3ec79354f7b4967e736c6a4cd7c08fc52e2b7d
CPU Threads: 4; OS Version: Linux 4.2; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

thus, closing it as RESOLVED WORKSFORME
Comment 8 Yousuf Philips (jay) (retired) 2016-10-08 23:09:35 UTC
Verified WFM.

Version: 5.3.0.0.alpha0+
Build ID: f309531cfe1d6a1b6ea1306d45ed3e121145bc5f
CPU Threads: 2; OS Version: Linux 3.19; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-10-04_03:52:18
Locale: en-US (en_US.UTF-8); Calc: group

@Xisco: Any idea who/when these fixes have come from.