Download it now!
Bug 97689 - SVG not supporting stroke-dashoffset
Summary: SVG not supporting stroke-dashoffset
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
4.0.6.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:svg
: 98120 112850 (view as bug list)
Depends on:
Blocks: SVG-Import
  Show dependency treegraph
 
Reported: 2016-02-09 14:17 UTC by Yousuf Philips (jay) (retired)
Modified: 2019-06-21 02:52 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
how it looks in Opera (30.49 KB, image/png)
2016-02-09 14:26 UTC, Yousuf Philips (jay) (retired)
Details
how it looks in LO (27.60 KB, image/png)
2016-09-26 21:37 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2016-02-09 14:17:12 UTC
Steps:
1) Open Writer
2) Insert https://dev.w3.org/SVG/tools/svgweb/samples/svg-files/patch.svg
3) Notice the black dashed border around the square has spaces between it.

Relevant SVG code: <path d="M6,35l60-30l30,60l-60,30z" stroke-dashoffset="3"/>

The old SVG implementation code found in 3.6.7 didnt have this problem.

Version: 5.2.0.0.alpha0+
Build ID: 6d68e88a0fc5a54bbb826379163bd0b9c6eae0fb
CPU Threads: 2; OS Version: Linux 4.2; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-02-08_08:05:38
Locale: en-US (en_US.UTF-8)
Comment 1 Yousuf Philips (jay) (retired) 2016-02-09 14:26:53 UTC
Created attachment 122481 [details]
how it looks in Opera
Comment 2 raal 2016-02-09 14:33:01 UTC
I can confirm with Version: 5.2.0.0.alpha0+
Build ID: 91a7580e03d5b47c6e2513afce85ddee45e730b6
CPU Threads: 4; OS Version: Linux 4.2; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-02-04_00:17:43
Comment 3 Xisco Faulí 2016-09-26 11:33:46 UTC
I can't reproduce it with

Version: 5.3.0.0.alpha0+
Build ID: 416eb656da5ecf82e4386bbffc7c843f6d065b3f
CPU Threads: 4; OS Version: Linux 4.2; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

Thus, close it as RESOLVED WORKSFORME
Comment 4 Yousuf Philips (jay) (retired) 2016-09-26 21:33:11 UTC
I still reproduce it.

Version: 5.3.0.0.alpha0+
Build ID: dec8da2a9aadbb6758ee76c30582bd8620a10ecb
CPU Threads: 2; OS Version: Linux 3.19; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-09-21_05:53:33
Locale: en-US (en_US.UTF-8); Calc: group
Comment 5 Yousuf Philips (jay) (retired) 2016-09-26 21:37:16 UTC
Created attachment 127650 [details]
how it looks in LO
Comment 6 Xisco Faulí 2016-09-26 22:18:09 UTC
ok, now I see it! sorry for the noise
Comment 7 Xisco Faulí 2016-09-26 22:18:36 UTC
*** Bug 98120 has been marked as a duplicate of this bug. ***
Comment 8 Armin Le Grand 2016-09-29 08:57:48 UTC
Well, yes, the line patterns are the same, but may be arranged a little bit different. The dash/dot length are correct. There are two lines around the square. Start point for the lines seems to be the left edge. In LO, the 1st line part at the following edge is split around the edge, while Opera seems to start the 2nd edge with repeating the gap.
Not sure what SVG exactly defines, but I am not sure if this an error at all
Comment 9 Yousuf Philips (jay) (retired) 2016-10-04 12:41:42 UTC
(In reply to Armin Le Grand (CIB) from comment #8)
> Not sure what SVG exactly defines, but I am not sure if this an error at all

Tested the svg in inkscape, chromium, gimp, eye of mate, karbon, and firefox and they all show it similar to opera, so LO is the odd one out.
Comment 10 Xisco Faulí 2017-10-04 21:21:44 UTC
*** Bug 112850 has been marked as a duplicate of this bug. ***
Comment 11 Roman Kuznetsov 2018-06-20 12:23:02 UTC
still repro in LO 6.1 beta 2
Comment 12 QA Administrators 2019-06-21 02:52:33 UTC
Dear Yousuf Philips (jay) (retired),

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug