Bug 97725 - inconsistent saving after clicking the save icon
Summary: inconsistent saving after clicking the save icon
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
(earliest affected) release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
Depends on:
Reported: 2016-02-10 20:34 UTC by Ralph Carr
Modified: 2016-03-16 14:01 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Note You need to log in before you can comment on or make changes to this bug.
Description Ralph Carr 2016-02-10 20:34:29 UTC
I installed the latest version, 5.1.0 today and found that the save button does not work properly.  In previous versions there were two save buttons, I guess one was for "Save As".  In previous versions when you clicked the Save button it greyed out to verify that your work was saved.  This version only has one Save button and it does not turn grey when you click it.  Sometimes it saves your work and sometimes it does not.  I found out when I clicked the Save button then attempted to close the application, but I got a message asking if I wanted to save my changes, otherwise they would be lost.  I had to click on Yes.  After this happened I tried repeatedly to save changes, and sometimes they were saved and sometimes they were not.  So I uninstalled the new version and reinstalled the previous version 5.0.4.  I will wait until your next release to upgrade.  Hopefully, you will have worked out this bug.  Another unusual thing happened when I uninstalled the new version.  I got a warning that both versions where installed in the same folder.  Shouldn't the new version over right the old version?  Thank you for a great product and all the work you put into it.

Ralph Carr
Comment 1 Buovjaga 2016-02-12 16:54:52 UTC
Save is now enabled all the time: https://bugs.documentfoundation.org/show_bug.cgi?id=96590#c18

Not sure about your other issue, about it asking to save.. I remember such behavior in Calc over several major versions (not changing anything in spreadsheet and still being asked to save on close).
Comment 2 tommy27 2016-03-16 06:12:57 UTC
please retest with LibO and tell if issue persists

edited summary notes to make it clearer what the report is about
Comment 3 tommy27 2016-03-16 06:19:39 UTC
please take a look at Bug 97878 too and tell if you think it's the same problem
Comment 4 Ralph Carr 2016-03-16 13:54:31 UTC
I looked at bug 97725 from tommy27 and it looks the same, except I was unable to save using File/Save.  The Save button was very inconsistent.  Sometimes it saved the first time, sometimes I had to click it many times.  Also, there was no "green outlined white star", or "a red dot".  After upgrading to version the problem went away.  The save button works every time now, and now there is a "green outlined white star" which disappears upon saving.
Comment 5 Buovjaga 2016-03-16 14:01:34 UTC
Thanks. Setting to WFM.