Bug 97786 - Linked Images keep loading/flickering and freeze
Summary: Linked Images keep loading/flickering and freeze
Status: RESOLVED DUPLICATE of bug 95614
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.4.2 release
Hardware: x86-64 (AMD64) All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: perf
Depends on:
Blocks:
 
Reported: 2016-02-12 07:36 UTC by Jan
Modified: 2016-10-26 06:48 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Freezed Writer during image-loading (297.18 KB, image/png)
2016-02-12 07:36 UTC, Jan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan 2016-02-12 07:36:04 UTC
Created attachment 122561 [details]
Freezed Writer during image-loading

I have a document with over 400 images and +1200 pages. All images are linked to the document. When scrolling through the document, the images are loaded. This works for most images. When 2 or 3 images are on the same page, the Writer starts loading Image 1, then 2, then 3, but shows "read-error" on image 1 and restarts this loop. I have attached a screenshot where 3 pictures are visible (2 pictures are at the top of the page - you can just see the first pixels -  and are just scrolling in). This causes the loop. The Writer takes forever to load them.

Sometimes, the Writer gets it right and after 2 or 3 minutes, the Writer unfreezes and shows the pictures. When I scroll the document one line, the loop restarts.

When I write in my document, the Writer occasionally freezes when I get to a new page. I suppose this could be related with the image-read-error.

I have seen some bugs which are similar, but are fixed/resolved.

I have increased memory for the images, but that didn't help. I even tried a fresh install on a better machine, and the problem occurs there too. 

OOO Writer 5.0.4.2 on Ubuntu 15.10.
Comment 1 Buovjaga 2016-02-15 10:11:10 UTC
This is going to be very hard to reproduce, if we do not get access to your files.
Comment 2 blargh 2016-02-22 12:30:32 UTC
I confirm the "loading/flickering and freeze" behaviour in documents with linked images in Windows.
It is worse if the image files are bigger.
Using Writer with more than a couple of linked images is now just not possible.

The same behaviour has been reported in Draw (Bug 93212: https://bugs.documentfoundation.org/show_bug.cgi?id=93212).
Comment 3 Buovjaga 2016-02-23 19:28:32 UTC
(In reply to blargh from comment #2)
> I confirm the "loading/flickering and freeze" behaviour in documents with
> linked images in Windows.
> It is worse if the image files are bigger.
> Using Writer with more than a couple of linked images is now just not
> possible.

You mentioned Windows, so I am tempted to ask, is this enabled: Tools - Options - LibO - View - Use OpenGL for all rendering
Which exact LibreOffice version are you using?
Comment 4 blargh 2016-02-24 08:31:07 UTC
(in reply to Beluga, comment #3)

 - The option "Use OpenGL for all rendering" is not enabled.
 - I am using LO 5.0.5.2 (at work) and LO 5.1.0.3 (at home). It happens in both versions.

All the best,
pedro
Comment 5 Buovjaga 2016-02-24 09:11:10 UTC
Ok, setting to NEW as the confirmation seems to match original report.
Comment 6 Xisco Faulí 2016-10-26 06:48:10 UTC

*** This bug has been marked as a duplicate of bug 95614 ***