Bug 97809 - Impress: on my Windows 8.1 playing a PPT with animation -> crash
Summary: Impress: on my Windows 8.1 playing a PPT with animation -> crash
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.0.4.2 release
Hardware: x86 (IA32) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2016-02-12 17:41 UTC by Arfy
Modified: 2017-03-30 04:25 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example of a ODP with an animation (ODP saved from a PPT) (34.08 KB, application/vnd.oasis.opendocument.presentation)
2016-02-12 17:41 UTC, Arfy
Details
AccessViolation dialog box (48.58 KB, image/png)
2016-02-15 14:12 UTC, Arfy
Details
Backtrace with WinDbg (20.01 KB, text/plain)
2016-02-16 06:59 UTC, Arfy
Details
A PPT on Windows 10 which crashes during animation... (174.50 KB, application/vnd.ms-powerpoint)
2016-02-27 13:06 UTC, Arfy
Details
Backtrace Version: 5.0.5.2 (x64) (5.83 KB, text/plain)
2016-03-01 15:20 UTC, Arfy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Arfy 2016-02-12 17:41:33 UTC
Created attachment 122587 [details]
Example of a ODP with an animation (ODP saved from a PPT)

Looks like "old" Bug 69139

Crash in avmediawin.dll as soon as an animation starts...

Event viewer logs:
- System 

  - Provider 

   [ Name]  Application Error 
 
  - EventID 1000 

   [ Qualifiers]  0 
 
   Level 2 
 
   Task 100 
 
   Keywords 0x80000000000000 
 
  - TimeCreated 

   [ SystemTime]  2016-02-12T17:26:06.000000000Z 
 
   EventRecordID 192944 
 
   Channel Application 
 
   Computer ARFY-W8 
 
   Security 
 

- EventData 

   soffice.bin 
   5.0.4.2 
   566a5939 
   avmediawin.dll 
   5.0.4.2 
   566a5930 
   c0000005 
   00000000000076ef 
   d70 
   01d165ba303e1437 
   C:\Program Files\LibreOffice 5\program\soffice.bin 
   C:\Program Files\LibreOffice 5\program\avmediawin.dll 
   b1ff5d54-d1ad-11e5-bfba-d850e6508fe1
Comment 1 Buovjaga 2016-02-15 13:34:18 UTC
So the ODP should crash as well?

No crash here.

Win 7 Pro 64-bit, Version: 5.1.0.3 (x64)
Build ID: 5e3e00a007d9b3b6efb6797a8b8e57b51ab1f737
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
Locale: fi-FI (fi_FI)

Version: 5.2.0.0.alpha0+
Build ID: a6f876d45bd4e41a7143594a6cb11b6893a0f620
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-02-11_00:07:38
Locale: fi-FI (fi_FI)
Comment 2 Arfy 2016-02-15 14:12:19 UTC
Created attachment 122661 [details]
AccessViolation dialog box
Comment 3 Arfy 2016-02-15 14:17:51 UTC
Hi, I noticed the problem after my daughter complained she can't open "funny" PPT sent to her.

I have the same problem with the original PPT or the transformed to ODP.

(to know: the OpenGl is desactivated due to print bug)

I did some tests:
- with or without OpenGL: same bug
- with autoplay or not: same crash
- without animations: NO CRASH

I attached also the screenshot of the "Access Violation" Dialog box
Comment 4 Buovjaga 2016-02-15 18:11:10 UTC
You could try getting a backtrace of the crash: https://wiki.documentfoundation.org/How_to_get_a_backtrace_with_WinDbg
Comment 5 Arfy 2016-02-16 06:59:12 UTC
Created attachment 122669 [details]
Backtrace with WinDbg
Comment 6 Arfy 2016-02-16 07:00:30 UTC
Backtrace added.
What's weird, it seems to be in
c:\cygwin64\home\buildslave\source\libo-core\avmedia\source\win\player.cxx @ 222
Comment 7 Arfy 2016-02-27 13:02:55 UTC
For information, I upgraded to Windows 10 and I have the same bug
-> crash as soon as an animation begin

=(
Comment 8 Arfy 2016-02-27 13:06:01 UTC
Created attachment 123034 [details]
A PPT on Windows 10 which crashes during animation...
Comment 9 Arfy 2016-03-01 15:20:55 UTC
Created attachment 123107 [details]
Backtrace Version: 5.0.5.2 (x64)

Version: 5.0.5.2 (x64)
Build ID: 55b006a02d247b5f7215fc6ea0fde844b30035b3
Locale : fr-FR (fr_FR)
Comment 10 ribotb 2016-03-04 15:46:15 UTC
hi,

Under Win7/x86:

The Power of PowerPoint (2016_02_12 18_17_00 UTC).ppt:
- no crash with LO 5.0.4.2
- no crash with LO 5.1.0.3  but "cool!" is not animated

The Power of PowerPoint One Transition).odp:
- no crash with LO 5.0.4.2 and LO 5.1.0.3 but "cool!" is not animated

Under Win10/x64: 

- with LO 5.0.1.2:  crash when closing the two documents : "LibreOffice e cessé de fonctionner..."
- with LO 5.1.0.3: no crash  but "cool!" is not animated (in the two documents).

Bernard
Comment 11 ribotb 2016-03-04 16:26:13 UTC
Under Win10/x64: 

- with LO 5.0.4.2:  crash when closing the two documents : "LibreOffice e cessé de fonctionner..."

Bernard
Comment 12 raal 2016-03-04 19:42:15 UTC
No crash win10 Version: 5.2.0.0.alpha0+
Build ID: 817f6bd75e98a321c238b5906bfcb031908914b2
CPU Threads: 1; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-03-01_01:14:57
Comment 13 Arfy 2016-03-13 18:00:59 UTC
So we will have to wait for version 5.2 for that problem to be corrected ?
Comment 14 Buovjaga 2016-03-13 18:07:12 UTC
(In reply to Arfy from comment #13)
> So we will have to wait for version 5.2 for that problem to be corrected ?

ribotb said there is no crash in 5.1
Comment 15 Formaint'Info 2016-05-05 20:00:27 UTC
Hello,

I confirm that Impress 5.0.5 64 bits crash immediately under Windows 10 (64 bits of course)
But there is no crash :
* with Impress 5.0.5 32 bits under Windows 10 (64 bits)
* under Ubuntu 14.04 64 bits
Comment 16 Carlos 2017-03-29 18:51:04 UTC
No crash in 
Version: 5.3.1.2 (x64)
Build ID: e80a0e0fd1875e1696614d24c32df0f95f03deb2
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; Layout Engine: new; 
Locale: en-US (en_US); Calc: group
Comment 17 Xisco Faulí 2017-03-29 19:06:39 UTC Comment hidden (obsolete)
Comment 18 Arfy 2017-03-29 20:09:34 UTC Comment hidden (obsolete)
Comment 19 Buovjaga 2017-03-30 04:25:01 UTC
(In reply to Arfy from comment #18)
> (but for information, with the PPT I can't activate hardware
> acceleration/OpenGl ... it crashes LibreOffice 5.3 if I try to open it)

As your original problem was different (comment 3), please create a new report for this OpenGL crash bug. Thank you.