Bug 97865 - FILESAVE Text highlighting changes from Yellow 10 to Yellow 2 after saving to DOC
Summary: FILESAVE Text highlighting changes from Yellow 10 to Yellow 2 after saving to...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 96016 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-02-15 08:09 UTC by techobsl
Modified: 2019-07-07 13:56 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
example text backgraund for LO 5 (14.50 KB, application/msword)
2016-02-15 09:33 UTC, techobsl
Details

Note You need to log in before you can comment on or make changes to this bug.
Description techobsl 2016-02-15 08:09:08 UTC
After saving file writer text backgraud changing, example changing from "yellow 10" to "yellow 2", this very is not conveniently.
This bug start with 5 version.

После сохранения файла в Writer с сохраненным фоном "желтый 10", открывается файл с цветом "желтый 2", что очень не удобно.
Comment 1 techobsl 2016-02-15 08:14:17 UTC
(In reply to techobsl from comment #0)
> After saving file writer text backgraud changing, for example changing from
> "yellow 10" to "yellow 2", this very is not conveniently.
> This bug start with 5 version.
> 
> После сохранения файла в Writer с сохраненным фоном "желтый 10", открывается
> файл с цветом "желтый 2", что очень не удобно.
Comment 2 Buovjaga 2016-02-15 08:41:51 UTC
Please attach example document.

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the document.
Comment 3 techobsl 2016-02-15 09:33:31 UTC
Created attachment 122653 [details]
example text backgraund for LO 5
Comment 4 techobsl 2016-02-15 09:35:46 UTC
Add information
Comment 5 Buovjaga 2016-02-15 09:46:58 UTC
Ok so you have a .doc file with some highlighted text.
It seems the *bold* text has had Yellow 2 highlight color and it has changed to Yellow 10.

I tried reproducing from scratch. I typed "test" in two different paragraphs, made one of the tests bold and highlighted both of them with Yellow 2.
I saved first to .odt and reloaded.
Then I saved to .doc and reloaded.
The color stayed as Yellow 2.

Maybe try: https://wiki.documentfoundation.org/UserProfile#Resolving_corruption_in_the_user_profile

Win 7 Pro 64-bit, Version: 5.1.0.3 (x64)
Build ID: 5e3e00a007d9b3b6efb6797a8b8e57b51ab1f737
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
Locale: fi-FI (fi_FI)
Comment 6 techobsl 2016-02-15 12:05:05 UTC
I don't have this bug the program in version 4.4.7.2.
Conversely from Yellow 2 to Yellow 10.
It can help this file .doc created in LibreOffice version 4.

Win 7 Pro 64-bit, Version: 5.1.0.3 (x32)
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
Locale: ru-RU (ru_RU)
Comment 7 Buovjaga 2016-02-15 12:37:57 UTC
Aargh, I misread.. so when highlighting with Yellow 10 and saving to .doc, it changes the highlight to Yellow 2. No matter if the text is bold or not.

I'm setting to NEW, but this might be some compatibility with MS Word thing.

Win 7 Pro 64-bit, Version: 5.1.0.3 (x64)
Build ID: 5e3e00a007d9b3b6efb6797a8b8e57b51ab1f737
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
Locale: fi-FI (fi_FI)
Comment 8 techobsl 2016-02-26 12:37:25 UTC
Also from "blue 10" to "blue 2".
In LibreOffice version 5.1 the bug still exists.
I can not inslall to all users while there is the bug.
Comment 9 Tamás Zolnai 2016-05-20 07:56:14 UTC
Hi,

This thing happens because MS highlighting has only 15 highlighting color and when you save Writer text background \ highlighting to an MS format it is converted to this color palette.
It's the default behavior, but you can change this at Tools -> Option -> Load/Save -> Microsoft Office, to save Writer text background as MS Shading and so colors won't change. Nut in this case when you open that *.doc file in MS Word you could not change the text background with highlighting tool, but with the shading tool:
https://blogs.technet.microsoft.com/hub/2011/04/05/how-to-select-more-highlight-colors-in-word/

Before the 5.0 version sometimes we saved Writer text background as shading (doc, docx), sometimes as highlighting (rtf). From that version an option is added, so the user can select the preferred behavior. Highlighting became the default, because on LO UI text background is called highlighting. This option can be set also via user profile.
https://wiki.documentfoundation.org/ReleaseNotes/5.0
Comment 10 Tamás Zolnai 2016-05-20 08:02:53 UTC
The right link to release notes:
https://wiki.documentfoundation.org/ReleaseNotes/5.0#Word-compatible_text_highlighting(In reply to Zolnai Tamás from comment #9)
Comment 11 Tamás Zolnai 2016-05-20 08:03:33 UTC
The right link to release notes:
https://wiki.documentfoundation.org/ReleaseNotes/5.0#Word-compatible_text_highlighting
Comment 12 Tamás Zolnai 2016-05-20 08:04:42 UTC
*** Bug 96016 has been marked as a duplicate of this bug. ***
Comment 13 QA Administrators 2017-05-22 13:38:36 UTC Comment hidden (obsolete)
Comment 14 Tamás Zolnai 2017-05-22 13:46:51 UTC
See my comment. It's not a bug, changing settings can solve this issue.
Comment 15 Buovjaga 2019-05-14 10:33:55 UTC
*** Bug 125268 has been marked as a duplicate of this bug. ***