Download it now!
Bug 97869 - Border Color pop-up at centre of screen.
Summary: Border Color pop-up at centre of screen.
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
5.1.0.1 rc
Hardware: All Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 98108 (view as bug list)
Depends on:
Blocks: Color-Picker-Widget
  Show dependency treegraph
 
Reported: 2016-02-15 09:58 UTC by Michael Meeks
Modified: 2016-04-23 14:28 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Meeks 2016-02-15 09:58:13 UTC
I launch calc vs. 5.2 - and I click the "border color" drop-down which is next to "Conditional Formatting" I expect the border color palette to be next to the drop-down, but instead it turns up in the center of the screen =)

I imagine some silly here ...
Comment 1 Maxim Monastirsky 2016-02-15 11:21:24 UTC
I assume this is under Windows (as I can't reproduce under Linux)? Try reverting dab2582f05979cd99a5937cb95a387cfed70bb8d - as that's what fixed it previously in Bug 84676.
Comment 2 Michael Meeks 2016-02-15 11:41:16 UTC
Quite right - on windows =)
Comment 3 Buovjaga 2016-02-17 11:15:19 UTC
Indeed.

Win 7 Pro 64-bit Version: 5.2.0.0.alpha0+
Build ID: a6f876d45bd4e41a7143594a6cb11b6893a0f620
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-02-11_00:07:38
Locale: fi-FI (fi_FI)
Comment 4 Maxim Monastirsky 2016-02-23 12:31:13 UTC
*** Bug 98108 has been marked as a duplicate of this bug. ***
Comment 5 V Stuart Foote 2016-04-23 14:28:19 UTC
On Windows 10 Pro 64-bit en-US with
Version: 5.2.0.0.alpha1+
Build ID: 11f13f55b7e76811946979f363638597d882b88b
CPU Threads: 8; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-04-22_01:37:28
Locale: en-US (en_US)

The color picker now opens attached as expected to the toolbar. 

Resolved fixed with

http://cgit.freedesktop.org/libreoffice/core/commit/?id=58bcea744ac4d9f73f055527369ef54cbc8f1a97

We have residual issue of bug 87944 where the "tear away" of moving the color picker incorrectly applies when the window frame is moved/resized underneath it  without the color picker having focus.