Bug 97918 - UNO commands for actions in the Distribution dialog
Summary: UNO commands for actions in the Distribution dialog
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
5.2.0.0.alpha0+
Hardware: All All
: medium enhancement
Assignee: Heiko Tietze
URL:
Whiteboard: target:7.1.0
Keywords: topicUI
: 119521 (view as bug list)
Depends on: 126857 135894
Blocks: UNO-Command-New Draw-UX 136593 136594
  Show dependency treegraph
 
Reported: 2016-02-17 00:55 UTC by Yousuf Philips (jay) (retired)
Modified: 2020-10-03 13:00 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
distribution dialog (21.91 KB, image/png)
2016-02-17 00:55 UTC, Yousuf Philips (jay) (retired)
Details
distribute in inkscape and LibO distribute dialog (112.46 KB, image/png)
2020-08-26 22:16 UTC, andreas_k
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2016-02-17 00:55:16 UTC
Created attachment 122703 [details]
distribution dialog

When 3 or more shapes are selected, the Distribution dialog (.uno:DistributeSelection) is accessible in the toolbar in Impress and Draw, but the action opens a dialog for a user to complete his/her distribution needs. So UNO commands are needed for the various distribution functions, so that they can included in a toolbar split button similar to align (.uno:ObjectAlign) and arrange split (.uno:ObjectPosition). These UNO command will likely also be used in the context menu and in the sidebar.

The most important of these uno commands is to distribute the spacing evenly between objects horizontal and vertically.
Comment 1 Heiko Tietze 2016-02-17 08:17:12 UTC
I would expect a floating widget like for the arrangement. And the toolbar 'Form Design' allows to distribute objects/shapes in this way- but without the spacing option. Sounds like a redundancy.
Comment 2 Yousuf Philips (jay) (retired) 2016-02-17 12:54:07 UTC
(In reply to Heiko Tietze from comment #1)
> I would expect a floating widget like for the arrangement. And the toolbar
> 'Form Design' allows to distribute objects/shapes in this way- but without
> the spacing option. Sounds like a redundancy.

The Form Design toolbar has the align objects split button, which is different than object distribution which is a spacing issue. See attachment 122702 [details].
Comment 3 Heiko Tietze 2016-06-30 08:26:55 UTC
After playing with Draw for a while, the distribution feature is one of my favorites. On the one hand but on the other it is very annoying to always start a modal dialog for object distribution. So the function is highly required.

Maybe getting uno commands is an EASYHACK (NEEDINFO for the codepointers).
Comment 4 Xisco Faulí 2016-09-15 15:26:51 UTC
Removing keyword 'needsDevEval' as this bug is an easyHack
Comment 5 Xisco Faulí 2016-09-27 10:36:07 UTC Comment hidden (obsolete)
Comment 6 jani 2016-10-25 13:46:29 UTC
UNO commands are not an easyhack.
Comment 7 Maxim Monastirsky 2018-08-26 21:54:08 UTC
*** Bug 119521 has been marked as a duplicate of this bug. ***
Comment 8 Xisco Faulí 2020-03-09 13:27:52 UTC
Please add keyword 'needsUXEval' and CC 'libreoffice-ux-advise@lists.freedesktop.org' if input from UX is needed.
Comment 9 andreas_k 2020-08-26 22:13:51 UTC
I would like to use the distribute options in the notebookbar and the sidebar, which is only possible if they are uno commands.

does someone know how to make them as uno commands?
Comment 10 andreas_k 2020-08-26 22:16:30 UTC
Created attachment 164728 [details]
distribute in inkscape and LibO distribute dialog

as you can see in inkscape distribute commands use a huge space in the UI and I use it a lot. compare to inkscape LibO has a realy bad grid align behaviour so it's even more imported to have distribute features available
Comment 11 Heiko Tietze 2020-09-01 08:46:56 UTC
Patch at https://gerrit.libreoffice.org/c/core/+/101828
Comment 12 andreas_k 2020-09-01 08:49:50 UTC
Mega!
Comment 13 Commit Notification 2020-09-17 23:13:08 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/705226338beeabd214f260c00f1a6db2cfb52475

Resolves tdf#97918 - Individual UNO commands for distribution options

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2020-10-03 13:00:09 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/76b5c4d1bdd2a371241a589ef97cf6a0f42947ab

tdf#97918 Associated Help on Distribute objects