Bug 97946 - LibreOffice components should be single apps on macOS
Summary: LibreOffice components should be single apps on macOS
Status: RESOLVED DUPLICATE of bug 50278
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 126372 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-02-17 20:43 UTC by steve -_-
Modified: 2019-09-22 17:01 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description steve -_- 2016-02-17 20:43:53 UTC
On Windows and Linux LibreOffice components like writer or calc are available to be started.

Currently
On OS X there is only a single LibreOffice.app.

Expected
The single components should be available (analogue to Linux / Win).

Briefly looked but couldn't find an existing bug for this, so hope I'm not filing a dupe here.
Comment 1 Yousuf Philips (jay) (retired) 2016-02-17 21:40:37 UTC
Usability-wise, having the entries for each of the modules appearing in the application menu on OS X like it does on other platforms is a win for application discovery and search, so users dont always need to begin at the start center.
Comment 2 steve -_- 2019-07-13 12:15:05 UTC
*** Bug 126372 has been marked as a duplicate of this bug. ***
Comment 3 Heiko Tietze 2019-07-20 12:03:48 UTC
Discussed this in the ESC meeting Jul/18 2019 and there was agreement to modify the installer.

         + only a matter of adding launchers (Christian)
             + provide a template and pull it into your dock easily
             + D&D installer gets you 1 application
             + perhaps a folder with some templates you can drag → launcher
             + no LibO code-change necessary.
         + lets find some volunteer that cares to write it (Michael)
Comment 4 steve -_- 2019-09-22 17:01:21 UTC

*** This bug has been marked as a duplicate of bug 50278 ***