Bug 126372 - App splitting on macOS
Summary: App splitting on macOS
Status: RESOLVED DUPLICATE of bug 97946
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.2.5.2 release
Hardware: Other Mac OS X (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 126373 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-07-13 07:54 UTC by Janek
Modified: 2019-07-13 12:15 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Janek 2019-07-13 07:54:41 UTC
Description:
Hi. I would like to request 2 new features to libreoffice

1) I would like to ask you to make LibreOffice support mac function called fullscreen.  It would be way easier to work in it like this.


2) On Pc libreoffice is split into different apps which I can access individually, without activating the LibreOffice app (the grey app). Can you please bring this to the Mac as well?

Thank you.
Janek Kubiak

Steps to Reproduce:
1. Open libreoffice... writer for instance and click on the green dot in the top left of the window
2.
3.

Actual Results:
The app stretches across the whole dispaly

Expected Results:
I would request to make this button cause the app to go „fullscreen” like all other apps.
Note:
Stretching across the whole display and going fullscreen are two DIFFERENT things on macOS.


Reproducible: Always


User Profile Reset: No



Additional Info:
Also I would like to request that libreoffice had its separate apps displayed in the apps folder in macOS instead just the LibreOffice general app (the grey app)
Comment 1 Buovjaga 2019-07-13 08:09:28 UTC
Fullscreen is already supported, with caveats: https://bugs.documentfoundation.org/show_bug.cgi?id=39983#c56
Comment 2 Buovjaga 2019-07-13 08:09:40 UTC
*** Bug 126373 has been marked as a duplicate of this bug. ***
Comment 3 steve -_- 2019-07-13 12:15:05 UTC

*** This bug has been marked as a duplicate of bug 97946 ***