Bug 98043 - alt-key shortcut not working for File-Exit Libreoffice
Summary: alt-key shortcut not working for File-Exit Libreoffice
Status: RESOLVED DUPLICATE of bug 92516
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-02-21 01:20 UTC by Mike B
Modified: 2016-02-23 19:24 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike B 2016-02-21 01:20:26 UTC
In Calc only (works in Writer), if I open a document, make changes, then try to exit, the alt-F-X key combination doesn't work. alt-F brings up the File menu, but X (the underlined character in "Exit LibreOffice") simply closes the menu. Using the mouse to choose that option works, as does the Ctrl-Q combination. Usually (but not always) it misbehaves even if I open a new blank spreadsheet then try to alt-F-x to exit it. Other alt-key combinations that I've tried work noramlly.

This may be a regression of some kind. It worked correctly in all previous release versions that I have used.
Comment 1 m.a.riosv 2016-02-21 01:35:34 UTC
Hi Mike, I can't reproduce.
Win10x64
Version: 5.1.1.1 (x64)
Build ID: c43cb650e9c145b181321ea547d38296db70f36e
CPU Threads: 4; OS Version: Windows 6.19; UI Render: GL; 

Does it happen with a clean profile?
Comment 2 Mike B 2016-02-21 07:28:32 UTC
Thanks for looking. In my Win10 laptop, using a clean profile (renamed old user folder to user.old, restarting LibreOffice) seems to have worked - after one glitch where I had to try twice, alt-f-x works in Calc and all other components. However, it still didn't work in Windows 7 Pro SP1 (all patches except Win10-related are applied). In fact, it spread to the other components too. So I uninstalled it (again) and am downloading fresh copies to try again after deleting the old Application Data folder entirely. Will try the older (5.0.5) first to verify that, as I recall, all worked correctly there, then will try 5.1 again. More information tomorrow.
Comment 3 Mike B 2016-02-21 07:58:04 UTC
Didn't take as long as I expected. I did the following:

Uninstalled LO 5.1 completely, and deleted the LO folder in AppData. I am running as a limited user, by the way.

Downloaded the current 5.0.5 and 5.1.0 releases from the web site.

Installed 5.0.5.2 (x64). alt-f-x works correctly without hesitation or any other issue in all components including Calc.

Uninstalled 5.0.5 and deleted the LO folder in AppData.

Installed 5.1.0.4 (x64). alt-f-x did not work initially in any component after starting a new file from the LO menu application, but started working in all components if I hit it 3 times in quick succession; after which it appeared to work normally. However, if I load a preexisting .ods file, then try to exit, Calc responded after 3 tries once, and now does not respond to alt-f-x at all.

The computer with the reproducible problem is an older desktop. Gigabyte motherboard, Intel Core2Extreme x9650, 6GB RAM, ample hard disk space, nVidia 750ti video. Windows 7 Pro SP1, all security patches. All normal system tests (POST, memory, disk, etc.) are nominal. Avast antivirus and Windows Defender issue no warnings. Java is up to date. The laptop is a ASUS U52F, Gen 1 i5, 4GB RAM, ample hard disk space, Intel built-in video, Windows 10 1511 fully patched. Neither computer has ever had Microsoft Office installed.

For now, as a workaround, I will roll back to 5.0.5 on both computers; it works correctly all the time. As an intermittent problem, I expect that this will be hard to find.
Comment 4 Mike B 2016-02-21 16:11:28 UTC
One other possibility occurred to me, based on one last test on the Win10 laptop. There might just be a long delay going on. The laptop does respond to alt-f-x, but it waits a significant moment, whereas the alternatives (click on menu, Ctrl-Q) just do it. If for some reason it was waiting a really long time in the old desktop, it would give the appearance of not working at all.

As noted, have now rolled back to 5.0.5.
Comment 5 Buovjaga 2016-02-21 17:11:54 UTC
Could you try with the latest dev build: http://dev-builds.libreoffice.org/daily/master/Win-x86@39/current/
It installs separately and uninstalls separately, so will not mess with your stable version.
Comment 6 raal 2016-02-21 17:24:04 UTC
Duplicate of bug 92516?
Comment 7 Mike B 2016-02-21 21:43:28 UTC
> Duplicate of bug 92516?

Very similar. In my case, all normal methods of exiting LibreOffice work EXCEPT alt-f-x. And I didn't check the system center (LO startup) menu - it turned up first in Calc in 5.1.0.3 release then appeared in other components when I tried them. It's intermittent, and once it starts working it continues to work for the duration of that WINDOWS user session (at least it seems that way - need to check again perhaps though I'm satisfied as a user for now using the rolled-back 5.0.5 where everything works).

> Try latest build...

Downloading it now. Will try it and report.

BTW, my installation explicitly does not include non-North American languages (does include French & Spanish dictionaries), nor does it include the Quickstarter. Starts up quick enough without the Quickstarter, and I try to minimize what runs at startup.
Comment 8 Mike B 2016-02-21 21:57:14 UTC
Installed the 5.2 alpha build. Now no combination (alt keys or mouse or alt-f then arrow down to Exit LibreOffice and hit Enter) of File-Exit LibreOffice works in the starter menu, and the alt-key only worked once (then stopped working) in Calc. However, the red X button on the window works, as does Ctrl-Q and Alt-F4. So now it does very closely resemble bug 92516.

All other alt-F menu options seem to work (Save, Save As, etc.) with an empty, new file open in Calc.

Opening an existing file with data works correctly, until attempting to Exit, then same behavior as above. alt-f-c to close the file (back to the starter window) does work correctly, asking to save the file (which has external links that are updated so it changed; did not save to preserve data).
Comment 9 Mike B 2016-02-21 22:03:55 UTC
And just for completeness, I checked the other components (Writer, Impress, etc.) - same behavior (ignores the Exit Libreoffice menu choice using alt-key or any other access, including F10). All do exit to the starter menu correctly on alt-f-c (Close).
Comment 10 Buovjaga 2016-02-23 19:24:09 UTC
Ok, I guess we can set as dupe.

*** This bug has been marked as a duplicate of bug 92516 ***