Bug 92516 - "x" accelerator and mouse click not exiting StartCenter in "File -> Exit LibreOfficeDev" menu
Summary: "x" accelerator and mouse click not exiting StartCenter in "File -> Exit Libr...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.1.0.0.alpha0+ Master
Hardware: Other Windows (All)
: highest minor
Assignee: Caolán McNamara
URL:
Whiteboard: target:5.3.0 target:5.2.1 target:5.1.6
Keywords: bibisected, bisected, regression
: 96832 97209 97761 97888 97911 98043 98578 98597 98708 98901 99406 99819 100102 100293 (view as bug list)
Depends on:
Blocks: Start-Center Shortcuts-Accelerators
  Show dependency treegraph
 
Reported: 2015-07-03 03:04 UTC by V Stuart Foote
Modified: 2016-08-04 14:39 UTC (History)
23 users (show)

See Also:
Crash report or crash signature:


Attachments
Error message with ALT+X (5.45 KB, image/png)
2016-06-27 07:26 UTC, ThierryT
Details

Note You need to log in before you can comment on or make changes to this bug.
Description V Stuart Foote 2015-07-03 03:04:02 UTC
On Windows 8.1 64-bit and Windows 7sp1 64-bit, en-US
Version: 5.1.0.0.alpha1+ (x64)
Build ID: c18f11587d37f285a95447dd8996c8b605732e00
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-07-01_21:36:15
Locale: en-US (en_US)

Getting weird behavior on the File -> Exit action on the StartCenter

Thought it was a sticky mouse button on the first system, but happening on a second.

The -x- accelerator, and the mouse click on Exit button are sometimes not closing LibreOffice.  Can not consistently cause it to happen, but opening/closing the Help -> About and the Help -> LibreOffice Help dialogs seems to trigger it as often as not.

When "stuck", a <Ctrl>+Q or <Alt>+F4 does close--just not the button click or the -x- or <Alt>+x
Comment 1 tommy27 2015-07-03 05:27:42 UTC
tested under Win8.1 x64 using LibO 5.1.0.0.alpha1+ (x64)
Build ID: 8b788891796ff0571f779cdbe8ce809c35c42754
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-07-02_23:09:27
Locale: en-US (it_IT)

1- closing the start center clicking on the "red X" button on the right upper corner works for me

2- Ctrl+Q closes immediately LibO

3- if I click "File/Exit LibreOfficeDev" menu item from the start center menu I have to click it twice to see LibO close. the first click doesn't do anything.

4- if I click the "File" start center menu and then digit the "x" accelerator nothing happens

so I confirm the bug.

I think the main reason is that all "menu" accelerator do not work in the start screen (maybe a focus problem)

try hitting "f" or "t" or "h" and you'll see that the "File", "Tools" and "Help" menus won't open

accelerators in the left application bar do work instead (try hitting "d" and it will open Writer, "s" will open Calc etc.
Comment 2 tommy27 2015-07-03 05:31:16 UTC
(In reply to tommy27 from comment #1)
> ...
>
> 3- if I click "File/Exit LibreOfficeDev" menu item from the start center
> menu I have to click it twice to see LibO close. the first click doesn't do
> anything.
> 
> ...

this double click to activate issue looks quite specific to the "Exit LibreOfficeDev" menu item...

all other items from the "File", "Tools" and "Help" menu can be clicked just one (as it should be) to activate.
Comment 3 V Stuart Foote 2015-07-03 12:28:04 UTC
(In reply to tommy27 from comment #1)

> I think the main reason is that all "menu" accelerator do not work in the
> start screen (maybe a focus problem)
> 
> try hitting "f" or "t" or "h" and you'll see that the "File", "Tools" and
> "Help" menus won't open

No, believe movement of focus to the Main menu bar out of the SC has always required an <Alt>+F, <Alt>+T, <Alt>+H because they are formally "short cuts" and not just "accelerators".  And then there are the <F10> and <F6> focus movements, which are not affected.  But once focus is moved onto the Main menu bar, the "f", "t" or "h" as accelerators correctly switch between top level menus. 

That seems correct.
Comment 4 tommy27 2015-07-04 08:44:30 UTC
(In reply to V Stuart Foote from comment #3)
> (In reply to tommy27 from comment #1)
> 
> > I think the main reason is that all "menu" accelerator do not work in the
> > start screen (maybe a focus problem)
> > 
> > try hitting "f" or "t" or "h" and you'll see that the "File", "Tools" and
> > "Help" menus won't open
> 
> No, believe movement of focus to the Main menu bar out of the SC has always
> required an <Alt>+F, <Alt>+T, <Alt>+H because they are formally "short cuts"
> and not just "accelerators".  
> ...

you are right: <Alt>+F, <Alt>+T, <Alt>+H do work, anyway I think that the undelining of the "F", "T" and "H" is misleading since it makes you think that they are single letter accelerators and there's no hint that you effectively have to add the Alt key in order to make them work.
I'll probably file a new bug report about this aspect.

regarding the issue of the "x" accelerator in "File/Exit LibO Dev" I add "regression" and "bibisectRequest" to the bug informations since it doesn't happen in LibO 4.4.x (I haven't tested in 5.0.x though...)
Comment 5 Terrence Enger 2015-07-16 02:51:30 UTC
I see very similar behaviour in LibreOffice ...
    Version: 5.1.0.0.alpha1+
    Build ID: d3b6f3790953bdfeaeebcd3ba9ec370d94ca4ebf
    TinderBox: Win-x86@39, Branch:master, Time: 2015-07-09_00:11:56
    Locale: en-CA (en_CA)
but not in ...
    Version: 5.1.0.0.alpha1+
    Build ID: 89b5967658392d27fb3147e85abb2b5c1c34b101
    TinderBox: Win-x86@39, Branch:master, Time: 2015-06-24_04:10:17
    Locale: en-CA (en_CA)
so I am setting keyword regression.

However, questions and comments arising ...

(1) I do not see the problem on Linux in the daily dbgutil bibisect
    repository version 2015-07-15, and I do not see mention of Linux
    in the comments above.  Is it right that the bug report has O/S
    All?

(2) I also see the (intermittent) failure of File > Exit in Writer,
    Calc, and Base; I have not tried other applications.  The
    reference to StartCenter in the summary may not be helpful.

HTH,
Terry.
Comment 6 tommy27 2015-07-19 06:57:31 UTC
retested under Win8.1 with LibO 5.1.0.0.alpha1+ (x64)
Build ID: 5a61d7f049a81d6e747d9d097f364ae45f58697b
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-07-16_01:06:26
Locale: en-US (it_IT)

seems things changed a little bit.

File (mouse click) -> Exit (mouse click) -> WORKS
File (mouse click) -> Exit (X or Alt+X or Ctrl+Q) -> DOESN'T WORK
File (Alt+F) -> Exit (X or Alt+X) -> WORKS
File (Alt+F) -> Exit Ctrl+Q -> DOESN'T WORK

tried other combinations:

File (mouse click) -> Open (mouse click) -> WORKS
File (mouse click) -> Open (O or Ctrl+O) -> DOESN'T WORK 
File (Alt+F) -> Open (O or Ctrl+O) -> WORKS

and:

Tools(mouse click) -> Options (mouse click) -> WORKS
Tools(mouse click) -> Options (O or Alt+O) -> DOESN'T WORK 
Tools(Alt+T))-> Options (O or Alt+O) -> WORKS

can you confirm my findings?
Comment 7 Luke 2015-07-25 04:49:04 UTC
Marked as not bibisectable since this appears to be a Windows only bug.
Comment 8 V Stuart Foote 2015-07-25 12:47:15 UTC
(In reply to Luke from comment #7)
> Marked as not bibisectable since this appears to be a Windows only bug.

Not so sure about that, I think bug 92866 -- Keyboard command shortcuts don't work in start centre-- is somehow also in the mix.
Comment 9 V Stuart Foote 2015-07-25 13:05:03 UTC
Sometime between 2015-06-24 and 2015-07-01
http://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=89b5967658392d27fb3147e85abb2b5c1c34b101..c18f11587d37f285a95447dd8996c8b605732e00

Seem to recall that was in a stretch when the TBs were not rolling Windows builds, at least I don't have any builds within that range.

Anyone?

@Robinson, do you know if the Windows bibisect repo builds master, or just 5.0?
Comment 10 tommy27 2015-07-26 13:24:04 UTC
*** Bug 92866 has been marked as a duplicate of this bug. ***
Comment 11 raal 2015-10-19 11:04:44 UTC
bibisecting: File (mouse click) -> Exit Alt+X 

This seems to have begun at the below commit.
Adding Cc: to simon@raspberrypi.org ; Could you possibly take a look at this one? Thanks

ca38e903b89635d06e61ef907e796827091d55ad is the first bad commit
commit ca38e903b89635d06e61ef907e796827091d55ad
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Sun Jul 26 21:04:31 2015 -0700

    source sha:74407aef94b6d8dfdd69891c4a6e578587ef3e71

    source sha:74407aef94b6d8dfdd69891c4a6e578587ef3e71

author	Simon Long <simon@raspberrypi.org>	2015-07-08 17:02:50 (GMT)
committer	Caolán McNamara <caolanm@redhat.com>	2015-07-09 15:07:24 (GMT)
commit	74407aef94b6d8dfdd69891c4a6e578587ef3e71 (patch)	
	
bibisect-win32-5.1
$ git bisect log
# bad: [d07ec272f151832493f57ce3fde37a429eaf6014] source sha:233b9b0ec95069b5ce98aab942304459ca7344a8
# good: [c1efd324c6ad448ac9edb030dc9738b9e6899e4d] source sha:ab465b90f6c6da5595393a0ba73f33a1e71a2b65
git bisect start 'd07ec272f151832493f57ce3fde37a429eaf6014' 'c1efd324c6ad448ac9edb030dc9738b9e6899e4d'
# bad: [75b0ef076d724d10ed74681ba542db53f088b4ca] source sha:6dddd1aaf5dd3c54aaf87222712c9147466056f6
git bisect bad 75b0ef076d724d10ed74681ba542db53f088b4ca
# good: [7f6e13f8050660b9e6ff832b34e0a3f5c1f1a38d] source sha:b998be6e42eeb57abf5131adc06aa45588542f62
git bisect good 7f6e13f8050660b9e6ff832b34e0a3f5c1f1a38d
# good: [d60e95b8d09e8dc5acdeda70881a99686f298112] source sha:9d7727737b067c5228f129737046f718d5965659
git bisect good d60e95b8d09e8dc5acdeda70881a99686f298112
# bad: [b5a9081c8b2712dc0e1fcde1c7b4b6467a063a2c] source sha:05748c000fcbd40bb2f9623e6ec1ff232bb1a7a5
git bisect bad b5a9081c8b2712dc0e1fcde1c7b4b6467a063a2c
# bad: [1471d214655e71f1bc894f31915004564b5bed41] source sha:72c11ce76abebdbe88a7be793dbf690c54b30500
git bisect bad 1471d214655e71f1bc894f31915004564b5bed41
# good: [16d1b3f85fb08ed49251cc30a84ee270beffb84b] source sha:81275d4725236b0c7fe9e724299dd67eeb203c99
git bisect good 16d1b3f85fb08ed49251cc30a84ee270beffb84b
# bad: [ddafcc6939ff857833db3c5b5e570e34a0b2540e] source sha:588f07068dc572ea0abd55678fd00f79ff34ddce
git bisect bad ddafcc6939ff857833db3c5b5e570e34a0b2540e
# good: [2d02297da6862afe41943b7096c4d40c40d573be] source sha:96b264edf2765e9d1893757d1f1f7c718b1df36d
git bisect good 2d02297da6862afe41943b7096c4d40c40d573be
# good: [c3b1131fbfa8d597dffafb649b4a1b891c70e1de] source sha:570852376464f238d7c3c0b58b37250ac5944a1c
git bisect good c3b1131fbfa8d597dffafb649b4a1b891c70e1de
# good: [4a0b70cd60a6775d84919d7b44ad7d2e56431552] source sha:24c50b6029791ed9fd14ed2c75351acd6c55e895
git bisect good 4a0b70cd60a6775d84919d7b44ad7d2e56431552
# good: [d02651f9320435a7e9421fefa3fc8bac9926c466] source sha:40ade8d04380083e383d6a6e50e5c254fcde2b2f
git bisect good d02651f9320435a7e9421fefa3fc8bac9926c466
# bad: [2eaf5b6a4715d4c5ff8399e74fd8f74c4a81c260] source sha:b54f22302731784d7bd462bf2cef0621eea8b22a
git bisect bad 2eaf5b6a4715d4c5ff8399e74fd8f74c4a81c260
# bad: [ca38e903b89635d06e61ef907e796827091d55ad] source sha:74407aef94b6d8dfdd69891c4a6e578587ef3e71
git bisect bad ca38e903b89635d06e61ef907e796827091d55ad
# first bad commit: [ca38e903b89635d06e61ef907e796827091d55ad] source sha:74407aef94b6d8dfdd69891c4a6e578587ef3e71
Comment 12 Simon Long 2015-10-19 11:09:34 UTC
Menus and accelerators in Start Centre are fundamentally broken - try using Alt-H to open the help menu; what happens is a button click on the Help button at the bottom of the screen.

See also https://bugs.documentfoundation.org/show_bug.cgi?id=92866 which describes another symptom of the same problem.

The whole menu and key accelerator handling in Start Centre needs to be investigated and fixed so it uses the same mechanism as used everywhere else in LibreOffice; I don't understand why it seems to work completely differently.
Comment 13 V Stuart Foote 2015-10-19 12:56:36 UTC
@Simon,
(In reply to Simon Long from comment #12)
> Menus and accelerators in Start Centre are fundamentally broken - try using
> Alt-H to open the help menu; what happens is a button click on the Help
> button at the bottom of the screen.
>
No this was taken care of a while back in bug 80477. They were duplicated but the Help menu gets the <Alt>+H "short cut", the Help button widget was reassigned a .UI GTK accelerator of "l", i.e. He_lp rather the the ~Help assigned to the main menu.

> See also https://bugs.documentfoundation.org/show_bug.cgi?id=92866 which
> describes another symptom of the same problem.
> 
> The whole menu and key accelerator handling in Start Centre needs to be
> investigated and fixed so it uses the same mechanism as used everywhere else
> in LibreOffice; I don't understand why it seems to work completely
> differently.

Actually it has gotten worse of late--on current master the Start Center focus indicator is being suppressed (or is not tracking), so no visual indicator of which button has focus from keyboard navigation.
Comment 14 V Stuart Foote 2015-10-19 13:50:59 UTC
(In reply to V Stuart Foote from comment #13)
> Actually it has gotten worse of late--on current master the Start Center
> focus indicator is being suppressed (or is not tracking), so no visual
> indicator of which button has focus from keyboard navigation.

Scratch that--I was poking at a hardware acceleration/OpenGL issue in rendering a complex SVG in Impress with current TB39 build, this particular Start Center paint glitch resolved with a profile reset.
Comment 15 Robinson Tryon (qubit) 2015-12-13 11:13:01 UTC Comment hidden (obsolete)
Comment 16 V Stuart Foote 2015-12-30 20:06:43 UTC
*** Bug 96832 has been marked as a duplicate of this bug. ***
Comment 17 ThierryT 2016-01-17 10:23:35 UTC
I tested today 

Version: 5.1.0.2 (x64)
Build ID: ecd3574d51754b043f865cf5bafee286d24db7cc
CPU Threads: 4; OS Version: Windows 6.29; UI Render: GL; 
Locale : fr-FR (fr_FR)

No possibility to exit LO when using :
File (mouse click) -> Exit (mouse click)
File (mouse click) -> Exit (X or Alt+X or Ctrl+Q)
File (Alt+F) -> Exit (X or Alt+X)
File (Alt+F) -> Exit Ctrl+Q
Comment 18 V Stuart Foote 2016-01-17 14:11:46 UTC
*** Bug 97209 has been marked as a duplicate of this bug. ***
Comment 19 jlerner10 2016-01-29 21:33:31 UTC
Still unable to Exit LO using File - Exit.

I can Exit using Ctrl Q - click the "x" but no other way.

Version: 5.1.0.3
Build ID: 5e3e00a007d9b3b6efb6797a8b8e57b51ab1f737
CPU Threads: 2; OS Version: Windows 6.1; UI Render: default; 
Locale: en-US (en_US)
Comment 20 ThierryT 2016-01-30 13:03:22 UTC
No problem to exit LO with File - Exit Menu and the X system menu.

Still unable to exit with the CTRL+Q option.

Version: 5.1.0.3 (x64)
Build ID: 5e3e00a007d9b3b6efb6797a8b8e57b51ab1f737
CPU Threads: 4; OS Version: Windows 6.29; UI Render: GL; 
Locale : fr-FR (fr_FR)
Comment 21 Buovjaga 2016-02-23 19:23:49 UTC
*** Bug 97761 has been marked as a duplicate of this bug. ***
Comment 22 Buovjaga 2016-02-23 19:24:09 UTC
*** Bug 98043 has been marked as a duplicate of this bug. ***
Comment 23 Mike B 2016-03-01 17:19:00 UTC
I might note that this behavior started at 5.1. 5.0 and earlier worked correctly. Just in case something changed ...
Comment 24 V Stuart Foote 2016-03-10 14:00:06 UTC
*** Bug 98578 has been marked as a duplicate of this bug. ***
Comment 25 V Stuart Foote 2016-03-11 14:20:14 UTC
*** Bug 98597 has been marked as a duplicate of this bug. ***
Comment 26 V Stuart Foote 2016-03-11 14:58:55 UTC
*** Bug 97911 has been marked as a duplicate of this bug. ***
Comment 27 V Stuart Foote 2016-03-11 14:59:02 UTC
*** Bug 97888 has been marked as a duplicate of this bug. ***
Comment 28 V Stuart Foote 2016-03-16 17:13:00 UTC
*** Bug 98708 has been marked as a duplicate of this bug. ***
Comment 29 Bud 2016-03-25 14:33:19 UTC
Even though you can exit LibreOffice with a work around - Clicking the X, or Ctrl+Q, this issue should be considered a fairly high priority.  People tend to judge by fairly shallow criteria whether or not software is well written - and if an bug like this is so obvious, they would probably be concerned what other issues are waiting just under the surface.....
Comment 30 V Stuart Foote 2016-03-26 12:28:09 UTC
*** Bug 98901 has been marked as a duplicate of this bug. ***
Comment 31 ThierryT 2016-03-26 15:18:00 UTC
Version: 5.1.2.1 (x64)
Build ID: 2603b69c5ec5981bb5f053f8ebfd1f3de00a4c29
Threads CPU : 4; Version de l'OS :Windows 6.29; UI Render : GL; 
Locale : fr-FR (fr_FR)

I've installed this version today and it is still the same problem than on comment 17.
Regression than with comment 20 with this new version.
Comment 32 Urmas 2016-04-20 03:03:29 UTC
*** Bug 99406 has been marked as a duplicate of this bug. ***
Comment 33 jlerner10 2016-05-13 10:24:02 UTC Comment hidden (me-too)
Comment 34 tommy27 2016-05-14 04:52:45 UTC
*** Bug 99819 has been marked as a duplicate of this bug. ***
Comment 35 Adolfo Jayme 2016-05-28 13:06:18 UTC
*** Bug 100102 has been marked as a duplicate of this bug. ***
Comment 36 V Stuart Foote 2016-06-09 16:18:12 UTC
*** Bug 100293 has been marked as a duplicate of this bug. ***
Comment 37 Bud 2016-06-26 17:55:56 UTC
I just tried to replicate the issue in version 5.1.4.2 and it looks like the problem might be solved.  Would be interested if people can still replicate the issue in this version.
Comment 38 jlerner10 2016-06-26 18:02:30 UTC
Just installed LO 5.2.0.1 and it too seems to be fixed.

Thanks to those who fixed this bug (problem).
Comment 39 ThierryT 2016-06-27 07:26:31 UTC
Created attachment 125936 [details]
Error message with ALT+X
Comment 40 ThierryT 2016-06-27 07:37:53 UTC
I just tried with version :
Version: 5.1.4.2 (x64)
Build ID: f99d75f39f1c57ebdd7ffc5f42867c12031db97a
Threads CPU : 4; Version de l'OS :Windows 6.29; UI Render : par défaut; 
Locale : fr-FR (fr_FR)

With a file opened (in Calc) :
File (mouse click) -> Exit (mouse click) => WORKS
File (mouse click) -> Exit (X : mouse click) => WORKS
File (mouse click) -> Exit (Alt+X or Ctrl+Q) => DOESN'T WORKS : nothing done the Menu "File" still displayed
File (Alt+F) -> Exit (X : mouse click) => WORKS
File (Alt+F) -> Exit(Alt+X) => DOESN'T WORK : see file attached before
File (Alt+F) -> Exit (Ctrl+Q) => WORK

In the main window (no file opened) :
File (mouse click) -> Exit (mouse click) => WORKS
File (mouse click) -> Exit (X : mouse click) => WORKS
File (mouse click) -> Exit (Alt+X or Ctrl+Q) => DOESN'T WORKS : nothing done the Menu "File" still displayed
File (Alt+F) => DOESN'T WORKS : the Menu File never appears
Comment 41 ThierryT 2016-06-27 13:29:14 UTC
I just tried with version :
Version: 5.2.0.1 (x64)
Build ID: fcbcb4963bda8633ba72bd2108ca1e802aad557d
Threads CPU : 4; Version de l'OS :Windows 6.29; UI Render : par défaut; 
Locale : fr-FR (fr_FR)

With a file opened (in Calc without macros) :
File (mouse click) -> Exit (mouse click) => WORKS
File (mouse click) -> Exit (X : mouse click) => WORKS
File (mouse click) -> Exit (Ctrl+Q) => WORKS
File (mouse click) -> Exit (Alt+X) => DOESN'T WORKS
File (Alt+F) -> Exit (mouse click) => WORKS
File (Alt+F) -> Exit (X : mouse click) => WORKS
File (Alt+F) -> Exit(Alt+X) => DOESN'T WORK
File (Alt+F) -> Exit (Ctrl+Q) => WORKS

With a file opened (in Calc with macros) :
File (mouse click) -> Exit (mouse click) => WORKS
File (mouse click) -> Exit (X : mouse click) => WORKS
File (mouse click) -> Exit (Ctrl+Q) => DOESN'T WORKS
File (mouse click) -> Exit (Alt+X) => DOESN'T WORKS
File (Alt+F) => DOESN'T WORKS : if no cells selected inside a sheet, no menus appears
File (Alt+F) -> Exit (mouse click) => WORKS
File (Alt+F) -> Exit (X : mouse click) => WORKS
File (Alt+F) -> Exit(Alt+X) => DOESN'T WORK : see file enclosed before (same message)
File (Alt+F) -> Exit (Ctrl+Q) => WORKS

In the main window (no file opened) :
File (mouse click) -> Exit (mouse click) => WORKS
File (mouse click) -> Exit (X : mouse click) => WORKS
File (mouse click) -> Exit (Alt+X or Ctrl+Q) => DOESN'T WORKS : nothing done the Menu "File" still displayed
File (Alt+F) => Exit (mouse click) => WORKS
File (Alt+F) -> Exit (X : mouse click) => WORKS
File (Alt+F) -> Exit(Alt+X) => DOESN'T WORK : see file enclosed before (same message)
File (Alt+F) -> Exit (Ctrl+Q) => DOESN'T WORKS
Comment 42 Commit Notification 2016-08-02 12:18:26 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f6d0d92a5e249413df99a7f3677a28efe6d45426

Related: tdf#92516 make menu accelerators always work even if...

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 43 Caolán McNamara 2016-08-02 14:46:17 UTC
I can reproduce some of this under the gen plugin. There may be more than one bug here, and ThierryT's warning dialog may be a dbgutil only warning which breaks the menu grab under windows and might not affect normal builds.

When a menu is active and there is an "E_xit (Ctrl+Q)" entry then pressing x, or alt+x, or ctrl+x should all be the same as pressing x. And should active the Exit.

Pressing q, or alt+q or ctrl+q when the menu is active, I think should only active something which has the q underlined in its name. So not the "E_xit (Ctrl+Q)" entry. This is how I believe we worked historically and its what I see.

Taking ThierryT's tests we have...

In the main window (no file opened) :
File (mouse click) -> Exit (mouse click) => WORKS
File (mouse click) -> Exit (X : mouse click) => WORKS
File (mouse click) -> Exit (Alt+X or Ctrl+Q) => DOESN'T WORKS : nothing done the Menu "File" still displayed
^^^this it the one I have fixed here^^^ Where starting with the mouse and then using the keyboard x to active E_xit didn't work. Ctrl+Q doesn't work, but that's expected.
File (Alt+F) => Exit (mouse click) => WORKS
File (Alt+F) -> Exit (X : mouse click) => WORKS
File (Alt+F) -> Exit(Alt+X) => DOESN'T WORK : see file enclosed before (same message)
^^^this works for me, I wonder if this is a dbgutil-only windows problem^^^
File (Alt+F) -> Exit (Ctrl+Q) => DOESN'T WORKS
^^^that's expected IMO^^^

With a file opened (in Calc without macros) :
File (mouse click) -> Exit (mouse click) => WORKS
File (mouse click) -> Exit (X : mouse click) => WORKS
File (mouse click) -> Exit (Ctrl+Q) => WORKS
^^^that's actually strange to me^^^
File (mouse click) -> Exit (Alt+X) => DOESN'T WORKS
^^^I believe this is the one I've fixed^^^
File (Alt+F) -> Exit (mouse click) => WORKS
File (Alt+F) -> Exit (X : mouse click) => WORKS
File (Alt+F) -> Exit(Alt+X) => DOESN'T WORK
^^^this works for me, I wonder if this is a dbgutil-only windows problem^^^
File (Alt+F) -> Exit (Ctrl+Q) => WORKS

With a file opened (in Calc with macros) :
File (mouse click) -> Exit (mouse click) => WORKS
File (mouse click) -> Exit (X : mouse click) => WORKS
File (mouse click) -> Exit (Ctrl+Q) => DOESN'T WORKS
File (mouse click) -> Exit (Alt+X) => DOESN'T WORKS
^^^I believe this is the one I've fixed^^^
File (Alt+F) => DOESN'T WORKS : if no cells selected inside a sheet, no menus appears
^^^This I can't reproduce and must be some other problem^^^
File (Alt+F) -> Exit (mouse click) => WORKS
File (Alt+F) -> Exit (X : mouse click) => WORKS
File (Alt+F) -> Exit(Alt+X) => DOESN'T WORK : see file enclosed before (same message)
^^^this works for me, I wonder if this is a dbgutil-only windows problem^^^
File (Alt+F) -> Exit (Ctrl+Q) => WORKS
^^^a surprise, not reproducible by me other Linux and gen vclplug^^^

So, if we put aside the surprising report that using ctrl+q in the file menu in calc works we have...

a) The case that clicking on the file menu, then using x (with or without mods) didn't work. That should now be fixed. With backports for 5-2 and 5-1 in gerrit.
b) That using alt+x in the file menu gives an error dialog under windows, probably only with a dbgutil build.
c) That the file menu in calc under windows doesn't appear unless you select some cells (or click in the main panel to initially focus it maybe ?)

I'm going to take this for the purpose of a) and ask for retests for b and c in the next master that has this fix. If "b" and "c" persist while "a" remains fixed then please file some new bugs about those, and don't reopen this one because this one is now an unwieldy 40+ comment catch-all bug.
Comment 44 Commit Notification 2016-08-02 15:14:48 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d013a5a38c6460a22434c6ba637c63d2118f12dc&h=libreoffice-5-2

Related: tdf#92516 make menu accelerators always work even if...

It will be available in 5.2.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 45 Commit Notification 2016-08-04 14:39:00 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1288a0682ab4c960915722d2bb52a200e75580a3&h=libreoffice-5-1

Related: tdf#92516 make menu accelerators always work even if...

It will be available in 5.1.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.