Download it now!
Bug 98183 - Export PDF via command line: formula in text tables result in ** Expression is faulty **
Summary: Export PDF via command line: formula in text tables result in ** Expression i...
Status: RESOLVED DUPLICATE of bug 63570
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
3.6.7.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:pdf
Depends on:
Blocks: PDF-Export
  Show dependency treegraph
 
Reported: 2016-02-25 14:03 UTC by domingo.sacristan
Modified: 2018-12-07 16:19 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Text Document (8.64 KB, application/vnd.oasis.opendocument.text)
2016-02-25 14:03 UTC, domingo.sacristan
Details
pdf result document (11.36 KB, application/pdf)
2016-02-25 14:04 UTC, domingo.sacristan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description domingo.sacristan 2016-02-25 14:03:20 UTC
Created attachment 122990 [details]
Text Document

Result of formel on Texttable are not printed when document printed over the command line:

windows:
C:\sgv\LibreOffice\program\soffice.exe --writer --convert-to pdf:writer_pdf_Export test_print.odt --headless

linux:
soffice --writer --convert-to pdf:writer_pdf_Export test_print.odt --headless

Formel Result: ** Expression is faulty **
Comment 1 domingo.sacristan 2016-02-25 14:04:20 UTC
Created attachment 122991 [details]
pdf result document
Comment 2 Buovjaga 2016-03-14 14:50:10 UTC
Repro.

Win 7 Pro 64-bit, Version: 5.1.1.3 (x64)
Build ID: 89f508ef3ecebd2cfb8e1def0f0ba9a803b88a6d
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
Locale: fi-FI (fi_FI)
Comment 3 Cor Nouws 2016-09-10 15:39:52 UTC
still a problem?
Comment 4 Buovjaga 2016-09-14 17:43:10 UTC
(In reply to Cor Nouws from comment #3)
> still a problem?

Yep. Note: let's keep NEEDINFO for bugs with incomplete information.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.3.0.0.alpha0+
Build ID: 798d55fcd8efc10fcef6b8ac3fa5abdbc82501ec
CPU Threads: 8; OS Version: Linux 4.7; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on September 13th 2016

Arch Linux 64-bit
Version 3.6.7.2 (Build ID: e183d5b)
Comment 5 QA Administrators 2017-10-30 08:29:44 UTC Comment hidden (obsolete)
Comment 6 H.C Hsu 2018-11-29 09:40:13 UTC
Bug not reproducible in version 6.3.0.0.
In this version can print the result for the formel.

Version: 6.3.0.0.alpha0+ (x64)
Build ID: 0f25a3c36f27fd51453b9a9115f236b83c143684
CPU threads: 8; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-11-27_20:06:55
Locale: zh-TW (zh_TW); UI-Language: en-US
Calc: threaded
Comment 7 Buovjaga 2018-11-30 19:08:31 UTC
(In reply to H.C Hsu from comment #6)
> Bug not reproducible in version 6.3.0.0.
> In this version can print the result for the formel.
> 
> Version: 6.3.0.0.alpha0+ (x64)
> Build ID: 0f25a3c36f27fd51453b9a9115f236b83c143684
> CPU threads: 8; OS: Windows 10.0; UI render: GL; VCL: win; 
> TinderBox: Win-x86_64@42, Branch:master, Time: 2018-11-27_20:06:55
> Locale: zh-TW (zh_TW); UI-Language: en-US
> Calc: threaded

I doubt this result as I can still repro with
Version: 6.2.0.0.beta1 (x64)
Build ID: d1b41307be3f8c19fe6f1938cf056e7ff1eb1d18
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: fi-FI (fi_FI); UI-Language: en-US
Calc: threaded

And it is not very old yet (a bit over a week)
Comment 8 Xavier Van Wijmeersch 2018-12-01 15:38:23 UTC
Can reproduce the error message

Version: 6.2.0.0.beta1+
Build ID: 4e9258e033d17b9f05df36026ca573aa6b229823
CPU threads: 8; OS: Linux 4.19; UI render: default; VCL: kde4; 
Locale: nl-BE (en_US.UTF-8); UI-Language: en-US
Calc: threaded

Version: 6.3.0.0.alpha0+
Build ID: 6408dbf268fc8cc72fa741197e38b07619f0e96a
CPU threads: 8; OS: Linux 4.19; UI render: default; VCL: kde4; 
Locale: nl-BE (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 9 Franklin Weng 2018-12-06 13:48:22 UTC
(In reply to Buovjaga from comment #7)
> (In reply to H.C Hsu from comment #6)
> > Bug not reproducible in version 6.3.0.0.
> > In this version can print the result for the formel.
> > 
> > Version: 6.3.0.0.alpha0+ (x64)
> > Build ID: 0f25a3c36f27fd51453b9a9115f236b83c143684
> > CPU threads: 8; OS: Windows 10.0; UI render: GL; VCL: win; 
> > TinderBox: Win-x86_64@42, Branch:master, Time: 2018-11-27_20:06:55
> > Locale: zh-TW (zh_TW); UI-Language: en-US
> > Calc: threaded
> 
> I doubt this result as I can still repro with
> Version: 6.2.0.0.beta1 (x64)
> Build ID: d1b41307be3f8c19fe6f1938cf056e7ff1eb1d18
> CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
> Locale: fi-FI (fi_FI); UI-Language: en-US
> Calc: threaded
> 
> And it is not very old yet (a bit over a week)

Confirmed reproducible with version

版本:6.3.0.0.alpha0+
組建 ID:e4c2d0bb57ab8ea8f5c400d103d01376b8140f22
CPU 執行緒:4; OS:Linux 4.15; UI 算繪:GL; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-11-30_21:37:10
語言地區:zh-TW (zh_TW.UTF-8); UI-Language: zh-TW
Calc: threaded
Comment 10 Timur 2018-12-07 16:19:29 UTC
Looks like a duplicate of Bug 63570. 
If you disagree, please explain, test with lastest LO and sent back New.
If you agree and think some info may be useful, please write to 63570.

*** This bug has been marked as a duplicate of bug 63570 ***