Bug 98239 - Add means to delete a row in the standard filter dialog
Summary: Add means to delete a row in the standard filter dialog
Status: RESOLVED DUPLICATE of bug 76898
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevEval, topicUI
Depends on:
Blocks: Data-Filter 98207
  Show dependency treegraph
 
Reported: 2016-02-27 19:14 UTC by Heiko Tietze
Modified: 2021-02-02 07:15 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Heiko Tietze 2016-02-27 19:14:00 UTC
Access to the "standard filter" (which is rather an overview of the current setup) is possible from the autofilter overlay widget or via menu: data > more filters > standard filter.

Issue:

The dialog has no means to remove rows. So when you want to configure the filter it cannot be done here (although it is possible to add more filters). Likely the row is not applied when field name is "-none-". I suggest to add buttons to add new and delete exisiting filters.
Comment 1 raal 2016-02-27 20:37:10 UTC
confirm.
Comment 2 Yousuf Philips (jay) (retired) 2016-02-28 01:38:27 UTC
Adding delete buttons at the end of each row should be straight forward and having the clicking of the delete button simply move the content in the below entries up 1 row should also be simple.

The glade UI file is here is at core/sc/uiconfig/scalc/ui/standardfilterdialog.ui and i think the code to run it is in core/sc/source/ui/dbgui/filtdlg.cxx
Comment 3 m.a.riosv 2016-02-28 04:04:54 UTC
The way to clear any filter row with the rows below, is selecting -none- for field in the row.

Selecting -none- for the first clear the whole filter.

But it's really an obscure way, and not possible to delete only one filter in middle.

What could be helpful:
+ / - to insert / delete a filter row
˄ / ˅ to move up / down
Comment 4 Heiko Tietze 2016-02-28 09:47:22 UTC
It's always bad usability to include "none" into lists.
Moving items would be relevant only for OR combinations (which IMHO should be killed with fire). It clutters too much.

I would do it like this (pipe is a splitter, value column client aligned):

[Op] [Field] | [Value]
     Foo     | 1       [-]
AND  Bar     | 2       [-]
                       [+]
Comment 5 Gabor Kelemen (allotropia) 2021-02-02 07:14:32 UTC
This seems to have been fixed in 7.1 since:

https://git.libreoffice.org/core/+/937b780e3f696552fc686bf0c80c3050443b111a

author	Martin van Zijl <martin.vanzijl@gmail.com>	Wed May 27 08:21:39 2020 +1200
committer	Heiko Tietze <heiko.tietze@documentfoundation.org>	Tue Sep 15 08:40:04 2020 +0200

tdf#76898 standard filter: add buttons to remove conditions

*** This bug has been marked as a duplicate of bug 76898 ***