Bug 98414 - Writer 5.0: Crash on exit in mergedlo.dll if document has headers/footers (with debug, no file or steps)
Summary: Writer 5.0: Crash on exit in mergedlo.dll if document has headers/footers (wi...
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2016-03-04 14:20 UTC by Timur
Modified: 2016-09-07 18:57 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Crash on exit - backtrace (687.57 KB, text/plain)
2016-03-04 14:20 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Timur 2016-03-04 14:20:14 UTC
Created attachment 123230 [details]
Crash on exit - backtrace

Working on a long time ago created ODT, I printed it and closed it and had a crash. That doesn't happen normally, so it's not reproducible. 
Since I had WinDbg on and I got backtrace, I still open new bug.
Bug 90482 and Bug 91770 may be related, but I cannot confirm.
Comment 1 Timur 2016-03-04 14:21:25 UTC
If the backtrace is of any use, please confirm. Otherwise, please close.
Comment 2 Robinson Tryon (qubit) 2016-03-06 06:51:26 UTC
(In reply to Timur from comment #0)
> Working on a long time ago created ODT, I printed it and closed it and had a
> crash. That doesn't happen normally, so it's not reproducible. 

Hmm...could be tough to repro

> Since I had WinDbg on and I got backtrace, I still open new bug.

Without the suspect ODT file, it'd be pretty tough for QA to determine whats going wrong and get a repro. I'm going to toss this into INSUFFICIENTDATA for now; the backtrace might be useful if we find similar behavior in the future.
Comment 3 Timur 2016-03-07 12:19:18 UTC
Michael, related to other Crash on Exit bugs, please comment whether attached backtrace is of any use.
Comment 4 Michael Meeks 2016-03-07 15:20:35 UTC
Looks like a different bug to me; perhaps a memory corruption (?) it doesn't look like the issue I just poked at (related to analytics saving).
Comment 5 Volko Neitmann 2016-07-11 16:46:03 UTC
I can confirm the bug having happened on my PC (Win 7 Professional x64, LO 5.1.3.2 and LO 5.1.4.2, German localization) twice exactly the same way like initially reported by Timur.
As on my system the bug also has happened only very occasionally I currently cannot provide steps to reproduce it.
Interestingly on my machine I can only see that the bug happened by checking the windows event log, there were no visible error messages popping up the two times the crash has appeared so far.
Comment 6 Caolán McNamara 2016-07-13 08:36:16 UTC
The original backtrace contains DelHFFormat. From checking locally it appears that DelHFFormat can only get called if the document has headers/footers. So that suggests that this can only be triggered by exiting while a document has headers/footers in it.
Comment 7 Timur 2016-07-13 10:23:35 UTC
Volko, Reopen is where fix doesn't work. This one is simple New because it's confirmed. But, I don't know whether it should stay open if it's not reproducible, and whether backtrace is of any use.
Caolán, please add appropriate crash signature.
Comment 8 Caolán McNamara 2016-07-13 11:29:25 UTC
"Caolán, please add appropriate crash signature." I'm just reading the backtrace in comment #1 so we don't have a crash signature for the crash-reporter tie-in.

Do you still have that document ? If you do and can attach it, or send it to me, while it might not be 100% reproducible in normal use maybe something might be visible under valgrind.
Comment 9 Volko Neitmann 2016-07-13 16:06:03 UTC
Timur, thank you for setting the correct bug-status and explaining the difference between NEW and REOPEN.

I would suggest to leave the bug open even if it is currently not reproducible for the reason that at least on my system the only evidence of the bug is the event log entry. Therefore it is very likely that other users are also affected by the crash but without noticing it.

I still have several older ODT-documents on my HDD so I will be able to do some testing trying to reproduce the crash as soon as I find the time.

Both times LO crashed on exiting on my PC I had done the following actions before:
1. run LO
2. open ODT-document
3. print ODT-document (setting document status to altered)
4. save ODT-document
5. exit LO (using the red X in the upper right corner of the window, however, I cannot remember if I closed the document separately before exiting LO)
Comment 10 Michael Stahl (CIB) 2016-09-07 18:57:45 UTC
Caolan said he did try to reproduce it and couldn't

can't find the root cause from the back trace -> closing