Bug 98479 - Exported PDF Form Text box containing punctuation / diacritic not displaying/printing some characters in some PDF viewers
Summary: Exported PDF Form Text box containing punctuation / diacritic not displaying/...
Status: RESOLVED DUPLICATE of bug 84963
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:pdf
Depends on:
Blocks: PDF-Export
  Show dependency treegraph
 
Reported: 2016-03-06 22:45 UTC by Vlado Koval
Modified: 2021-04-21 14:05 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Test case (36.90 KB, application/x-zip-compressed)
2016-03-06 22:45 UTC, Vlado Koval
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vlado Koval 2016-03-06 22:45:36 UTC
Created attachment 123357 [details]
Test case

In Writer I inserted Text boxes.
Saved as "*.odt".
Then exported the "*.odt" as "PDF Form":
---
menu->Export as PDF...->Create PDF Form; Submit format: FDF
---
I created "*.FDF" file; Please see the attachement.
The "*.FDF" file contains "field values" as "hex UNICODE 16BE - big endian" character streams. It contains diacritic / punctuation characters.
---
I tried to open the "*.fdf" with "Adobe reader" version 9.5.0 or 11.0.12.
I tried windows XP and windows 10.
I tried: LibreOffice 4.4.2.2 and LibreOffice 5.1.0.3.
---
If I use the "*.fdf" with some other "PDF generated by Adobe Distiller", the PDF created by government organization, all is displaying OK.
---
The problem is that some diacritic characters in the "PDF form text box" are not displayed when the cursor focus is not on the "text box". The characters are also not printed. Please, use the "Tab keyboard key" to skip with cursor from one text box to another to see the problem of the text box that some diacritic characters are being hidden if the cursor focus is not on the text box. When I write anything into the text box the hidden diacritic characters will correctly appear even if the cursor focus is not on the text box.
---
Please, see the attachement:
---
test1-bug.odt
test1-bug.pdf - PDF generated by LibreOffice
test1-bug.fdf - FDF created manually without LibreOffice
test1-bug-OK.png - correctly displayed in PDF adobe reader
test1-bug-Wrong.png - wrongly displayed in PDF adobe reader
---
Comment 1 raal 2016-03-22 08:09:11 UTC
I can confirm with Version: 5.2.0.0.alpha0+ and  4.0.0.3
Comment 2 Xisco Faulí 2016-10-10 15:00:06 UTC
Reproduced in 

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 3 QA Administrators 2017-10-30 08:30:40 UTC Comment hidden (obsolete)
Comment 4 Andreas Gruenbacher 2018-01-02 21:05:43 UTC
This bug still reproduces with LibreOffice 5.4.4.  Bug 108222 seems to be about the same problem.
Comment 5 QA Administrators 2019-01-03 03:36:50 UTC Comment hidden (obsolete)
Comment 6 QA Administrators 2021-01-03 03:37:46 UTC Comment hidden (obsolete)
Comment 7 Timur 2021-04-21 13:59:59 UTC
Report was that PDF is not correct in Adobe Reader until click in. 
Yes, but it is correct in X-change Viewer or Editor. 

As for Linux, it was already Ok in Master PDF Editor, but not in Xpdf or Xreader, which similarly required click in. 
This was somewhat improved in Lo 7.1 with 6294.. fix in bug 50879, more is shown good but not all with those. 

Finally, not sure if this is Lo bug or not (unlike bug 108222).
Comment 8 Timur 2021-04-21 14:05:39 UTC
Duplicate.

*** This bug has been marked as a duplicate of bug 84963 ***