Bug 98479 - Exported PDF Form Text box containing punctuation / diacritic not displaying/printing some characters
Summary: Exported PDF Form Text box containing punctuation / diacritic not displaying/...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
Keywords: filter:pdf
Depends on:
Blocks: PDF-Export 108222
  Show dependency treegraph
Reported: 2016-03-06 22:45 UTC by Vlado Koval
Modified: 2019-01-03 03:36 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:

Test case (36.90 KB, application/x-zip-compressed)
2016-03-06 22:45 UTC, Vlado Koval

Note You need to log in before you can comment on or make changes to this bug.
Description Vlado Koval 2016-03-06 22:45:36 UTC
Created attachment 123357 [details]
Test case

In Writer I inserted Text boxes.
Saved as "*.odt".
Then exported the "*.odt" as "PDF Form":
menu->Export as PDF...->Create PDF Form; Submit format: FDF
I created "*.FDF" file; Please see the attachement.
The "*.FDF" file contains "field values" as "hex UNICODE 16BE - big endian" character streams. It contains diacritic / punctuation characters.
I tried to open the "*.fdf" with "Adobe reader" version 9.5.0 or 11.0.12.
I tried windows XP and windows 10.
I tried: LibreOffice and LibreOffice
If I use the "*.fdf" with some other "PDF generated by Adobe Distiller", the PDF created by government organization, all is displaying OK.
The problem is that some diacritic characters in the "PDF form text box" are not displayed when the cursor focus is not on the "text box". The characters are also not printed. Please, use the "Tab keyboard key" to skip with cursor from one text box to another to see the problem of the text box that some diacritic characters are being hidden if the cursor focus is not on the text box. When I write anything into the text box the hidden diacritic characters will correctly appear even if the cursor focus is not on the text box.
Please, see the attachement:
test1-bug.pdf - PDF generated by LibreOffice
test1-bug.fdf - FDF created manually without LibreOffice
test1-bug-OK.png - correctly displayed in PDF adobe reader
test1-bug-Wrong.png - wrongly displayed in PDF adobe reader
Comment 1 raal 2016-03-22 08:09:11 UTC
I can confirm with Version: and
Comment 2 Xisco Faulí 2016-10-10 15:00:06 UTC
Reproduced in 

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-
Comment 3 QA Administrators 2017-10-30 08:30:40 UTC Comment hidden (obsolete)
Comment 4 Andreas Gruenbacher 2018-01-02 21:05:43 UTC
This bug still reproduces with LibreOffice 5.4.4.  Bug 108222 seems to be about the same problem.
Comment 5 QA Administrators 2019-01-03 03:36:50 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)

If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword

Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team