Download it now!
Bug 98497 - FILESAVE: Fonts settings inside Charts lost on DOCX export
Summary: FILESAVE: Fonts settings inside Charts lost on DOCX export
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: OOXML-Chart
  Show dependency treegraph
 
Reported: 2016-03-07 13:09 UTC by John Lane
Modified: 2018-09-10 00:04 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
example showing customised chart (26.63 KB, application/vnd.oasis.opendocument.text)
2016-03-07 13:09 UTC, John Lane
Details
docx format without customisations (5.31 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2016-03-07 13:10 UTC, John Lane
Details

Note You need to log in before you can comment on or make changes to this bug.
Description John Lane 2016-03-07 13:09:20 UTC
Created attachment 123379 [details]
example showing customised chart

I have a bar chart in calc that I have customised so the the bar colours aren't all the same and the label fonts are larger and bold.

I copy and paste it into writer. It looks good. I save it as ".docx", close it and re-open and the customisations have disappeared. 

Saving as odt seems to be ok but as does ".doc". I have opened the docx on a Mac 2011 version of MSO. I have not (but will) check these on a Windows version of ms-office too.

Two attachments:

(a) odt example showing customised chart
(b) .docx example created by using "save as" on (a). Customisations absent.
Comment 1 John Lane 2016-03-07 13:10:03 UTC
Created attachment 123380 [details]
docx format without customisations
Comment 2 John Lane 2016-03-07 19:18:46 UTC
Futher tests performed this afternoon. Saving to a ".doc" format works insofar as the file renders correctly in LibreOffice.

However, I have tried on MS Word for Mac (Office 2011) and the .doc opens but most of the formatting and all embedded charts are missing.

I also tried the ".docx" on MS Word for Mac (Office 2011) which opens and faithfully reproduces the layout of the same file on LibreOffice (i.e it also renders on the Mac with the chart customisations missing).

I am going to try on Windows but I need to find our license key. I shall report back once I have tested there too.
Comment 3 John Lane 2016-03-12 20:48:37 UTC
Just an update to say I've tested with a PC Windows copy of Office 2016. I can open ODT file in Word and save it as a .docx without any problems. I can take this .docx file and open it in Mac Word (Office 2011) without any problems.
Comment 4 Buovjaga 2016-03-13 16:15:53 UTC
Reproduced.

64-bit, KDE Plasma 5
Build ID: 5.1.1.3 Arch Linux build-1
CPU Threads: 8; OS Version: Linux 4.4; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)

Arch Linux 64-bit, KDE Plasma 5
Version: 5.2.0.0.alpha0+
Build ID: 235411c9d47ecba88e46d859ea93bcecefb0c46e
CPU Threads: 8; OS Version: Linux 4.4; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)
Built on March 11th 2016
Comment 5 Buovjaga 2016-03-13 16:17:17 UTC Comment hidden (obsolete)
Comment 6 Buovjaga 2016-03-13 16:20:14 UTC
..Or we could turn this into being about only the label font style change? I did not find a duplicate for it.
Comment 7 QA Administrators 2018-06-26 02:44:01 UTC Comment hidden (obsolete)
Comment 8 Luke 2018-09-10 00:04:52 UTC
Seems this bug was fixed recently. Works for me in Version: 6.2.0.0.alpha0+ (x64)
Build ID: dff829e863fd05bedd5bcb713cd80c10fa582932