Download it now!
Bug 98575 - Impress: Hard to select a hyperlink with the mouse
Summary: Impress: Hard to select a hyperlink with the mouse
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Samuel Mehrbrodt (CIB)
URL:
Whiteboard: target:6.4.0
Keywords:
Depends on:
Blocks: Hyperlink
  Show dependency treegraph
 
Reported: 2016-03-10 09:20 UTC by Stephan Bergmann
Modified: 2019-08-07 16:15 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stephan Bergmann 2016-03-10 09:20:45 UTC
When a text in Impress contains a hyperlink, it is hard to select it with the mouse:

If you try to position the mouse close to the start or end of the hyperlink and then click and drag, you initiate either a move operation or opening the link in the browser.

If you try to position the mouse close somewhere in the middle of the hyperlink and then click (or double click), either nothing happens or you initiate opening the link in the browser.

I assume this is an issue with the underlying editeng, so probably also affects Calc etc.  Does not affect Writer.
Comment 1 raal 2016-03-10 14:29:11 UTC
see bug 98388
but I agree it's not intuitive.
Comment 2 QA Administrators 2017-05-22 13:19:59 UTC Comment hidden (obsolete)
Comment 3 Samuel Mehrbrodt (CIB) 2019-07-03 14:59:46 UTC
The problem is that a URL in editeng is a field - so it's treated not as a piece of text where you can navigate through with the cursor, but as a single character.
Investigating how to improve things here anyway...
Comment 4 Samuel Mehrbrodt (CIB) 2019-07-04 13:49:04 UTC
(In reply to Samuel Mehrbrodt (CIB) from comment #3)
> Investigating how to improve things here anyway...

The solution would probably be to enable some sort of inline-field-editing like we have in writer for certain types of fields.
Comment 5 Commit Notification 2019-07-05 13:26:32 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/e553b3698f6d8f4f606ebe21ed9857ee09f0c057%5E%21

Related tdf#98575 Add "Edit Hyperlink" to context menu in sd

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2019-07-08 08:29:22 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/1c6218df32838dc77da8e15dc5ce47eadad1a13f%5E%21

Related tdf#98575 Allow editing link even when URL field is not selected

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2019-07-11 06:34:29 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/f998fc0d66c8f79f417e13e2b1103efae7a95719%5E%21

tdf#98575 Go into text edit mode when clicking on a hyperlink

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Samuel Mehrbrodt (CIB) 2019-07-11 13:13:44 UTC
I think this bug can be considered fixed. I did some improvements to make selecting and editing a link with the mouse easier.

To have the same experience as in Writer, we need some sort of inline editing for fields like this. That request is handled in bug 126329.
Comment 9 Buovjaga 2019-07-11 16:14:07 UTC
Verified

Arch Linux 64-bit
Version: 6.4.0.0.alpha0+
Build ID: 29400185a003bfe9cdbc6e744c4a0d0e40005b03
CPU threads: 8; OS: Linux 5.2; UI render: default; VCL: x11; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 11 July 2019

(Note: with gtk3, URL editing is currently broken due to bug 126202)