Bug 98601 - can't convert large .XLS to .PDF using a macro or toolbar export button
Summary: can't convert large .XLS to .PDF using a macro or toolbar export button
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:pdf, perf
Depends on:
Blocks: PDF-Export
  Show dependency treegraph
 
Reported: 2016-03-11 12:28 UTC by Heena Sananse
Modified: 2018-06-17 02:44 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Excel File (4.46 MB, application/vnd.ms-excel)
2016-03-11 12:28 UTC, Heena Sananse
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Heena Sananse 2016-03-11 12:28:46 UTC
Created attachment 123498 [details]
Excel File

Hi,

I am using Libraoffice Portable in one of my project to convert the office doc to pdf. For the same, I have Created Macro to convert the Excel file into pdf. pls see the following function. 

Sub ConvertExcelToPDF( cSourceFile , cDestinationFile) cURL = ConvertToURL( cSourceFile ) ' Open the document. ' Just blindly assume that the document ' is of a type that OOo will ' correctly recognize and open -- ' without specifying an import filter.

oDoc = StarDesktop.loadComponentFromURL( cURL, "_blank", 0, _ Array(MakePropertyValue( "Hidden", True ),) )

cURL = ConvertToURL( cDestinationFile ) On Error GoTo ErrorHandler ' Save the document using a filter. 
oDoc.storeToURL( cURL, _ Array(MakePropertyValue( "FilterName", "calc_pdf_Export" ),)

oDoc.close( True )

I have one excel file which have more formatting stuff. File size is 4.45 MB. I am not able to convert it. I am getting error. 

Even I am open that file in LibraOffice and than try to Export as PDF it is taking too much time. (Pls find the attached document for your reference)

Please look into this issue and provide me solution. 

Thanks & Regards
Heena Sananse
Comment 1 tommy27 2016-03-12 07:11:43 UTC
please give more informations like your operating system (O/S) and the exact LibreOffice version you are using.

consider also upgrading to latest stable release which is 5.0.5.2 or latest fresh LibO 5.1.1.3 release in case you are already working with the 5.1.x branch

P.S. the correct name is LibreOffice, not LibraOffice
Comment 2 tommy27 2016-03-12 07:24:01 UTC
had not time to test the macro, but I can tell that the PDF export from the toolbar button hangs LibO... I killed it after 6 minutes.

tested under Win8.1 x64 using LibO 5.0.4.2 and a recent 5.2.0.0 alpha daily build.

I have a fast machine with SSD disk so it's not an hardware issue.
looks like a software performance issue.
Comment 3 Heena Sananse 2016-03-14 05:03:23 UTC
Hello tommy,

I am using windows 7, 64 bit and Libra Office  Portable File version 4.4.4.0.

Thanks 
Heena Sananse
Comment 4 tommy27 2016-03-14 06:28:44 UTC
thanks for telling the exact LibreOffice version you are using (again, it's not called Libra Office) which is however an obsolete version.

the bug is still present in 5.0.x and 5.1.x LibO release but I suggest you should upgrade to current stable LibO 5.0.5.2 release which solves hundred of bugs in respect to the 4.4.4 release.
Comment 5 Heena Sananse 2016-03-17 07:12:23 UTC
Hello,

I upgrade the version of Libra office Portable to 5.1.1 and tried to export the pdf but its taking to much time and still not converted. 


Thanks & Regards
Heena Sananse
Comment 6 tommy27 2016-03-18 00:50:43 UTC
(In reply to Heena Sananse from comment #5)
> .... Libra office Portable 

please, call it LibreOffice.
Libra Office does not exist
Comment 7 Heena Sananse 2016-03-18 13:42:19 UTC
(In reply to tommy27 from comment #6)
> (In reply to Heena Sananse from comment #5)
> > .... Libra office Portable 
> 
> please, call it LibreOffice.
> Libra Office does not exist

Ok. Will take care of it.
Comment 8 Heena Sananse 2016-04-14 08:00:00 UTC
Hello,

Any update on issue?

Thanks & Regards
Heena Sananse
Comment 9 QA Administrators 2018-06-17 02:44:20 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug