Bug 98644 - REMOTE FILE: "The specified device is invalid." error dialog appears when wrong password entered
Summary: REMOTE FILE: "The specified device is invalid." error dialog appears when wro...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: All All
: low trivial
Assignee: Not Assigned
URL:
Whiteboard: target:5.2.0
Keywords: needUITest
Depends on:
Blocks: CMIS
  Show dependency treegraph
 
Reported: 2016-03-14 12:23 UTC by Yousuf Philips (jay) (retired)
Modified: 2019-12-03 14:59 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2016-03-14 12:23:37 UTC
Steps:
1) Open a release version of LO, which has google drive access
2) File > Open Remote File
3) Click 'Add Service' button
4) Fill in Google Drive details along with a wrong password
5) When pressing OK you get a 'The specified device is invalid.' error dialog.

This has been mentioned and confirmed in bug 98416.

Version: 5.1.1.3
Build ID: 89f508ef3ecebd2cfb8e1def0f0ba9a803b88a6d
CPU Threads: 2; OS Version: Linux 4.2; UI Render: default; 
Locale: en-US (en_US.UTF-8)
Comment 1 Buovjaga 2016-03-21 11:28:06 UTC
Yep, so let's set to NEW.
Comment 2 Commit Notification 2016-05-02 21:26:17 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f88554edd46d2dc8d6c8eaba74c89ccd3e537104

Related tdf#98644: In login dialog, give a hint that the password was wrong

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Commit Notification 2016-05-03 12:01:58 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f23c32e4bf42a80455ebae10d830b7ffded4fa9f

tdf#98644 : better error message when wrong password entered

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Xisco Faulí 2016-09-15 22:36:03 UTC
Hello,
Is this bug fixed?
If so, could you please close it as RESOLVED FIXED?
Comment 5 ribotb 2016-09-21 07:58:09 UTC
Hi,

In :
Version: 5.3.0.0.alpha0+
Build ID: dec8da2a9aadbb6758ee76c30582bd8620a10ecb
CPU Threads: 2; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-09-21_04:46:24
Locale: fr-FR (fr_FR); Calc: group

We no longer find 'Google drive' in the type list when trying to 'Add service' ?

Bernard
Comment 6 QA Administrators 2017-10-23 14:04:50 UTC Comment hidden (obsolete)
Comment 7 QA Administrators 2019-12-03 14:59:04 UTC
Dear Yousuf Philips (jay),

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug