Download it now!
Bug 98667 - Inline formulas are sometimes not shown
Summary: Inline formulas are sometimes not shown
Status: RESOLVED DUPLICATE of bug 98622
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.1.3 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2016-03-14 22:47 UTC by Ben
Modified: 2016-03-18 12:34 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Formulas not rendered (129.17 KB, image/png)
2016-03-16 15:24 UTC, Ben
Details
Blanked out formulas on Windows 10 - 64 bit (161.05 KB, application/vnd.oasis.opendocument.text)
2016-03-17 14:25 UTC, Ben
Details
Blanked out Formulas - test 2.png (139.34 KB, image/png)
2016-03-17 16:53 UTC, Ben
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ben 2016-03-14 22:47:58 UTC
Inline formulas are sometimes indicated as a box without content while other formulas around it are shown correctly with content in their box.
Comment 1 Usama 2016-03-15 11:24:40 UTC
Hello Ben,

Thank you for reporting the bug. Please add the following information as this makes it easier for us to verify the bug: 

1. Clearer step by step way to reproduce the problem: like 1. do this 2. do that etc...
2. A sample file to start testing with


I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested info is provided.
(Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)
Comment 2 Ben 2016-03-16 15:24:22 UTC
Created attachment 123628 [details]
Formulas not rendered

See screenshot which shows various cases of rendered and not rendered formulas.
Comment 3 Ben 2016-03-16 19:22:36 UTC
After clicking within the box where the formula resides, and clicking outside the formula box, the formula becomes visible.
Comment 4 raal 2016-03-17 14:07:04 UTC
Could you attach sample writer file with formulas?
Comment 5 Ben 2016-03-17 14:24:13 UTC
.odt attachment added with blanked out formulas
Comment 6 Ben 2016-03-17 14:25:17 UTC
Created attachment 123660 [details]
Blanked out formulas on Windows 10 - 64 bit
Comment 7 raal 2016-03-17 15:52:58 UTC
Hello Ben, thanks for document. Tested with win10 / I can reproduce the bug with 5.1.0.3 (x64), but not with Version: 5.2.0.0.alpha0+ (x64)
Build ID: 042f16a19e3d5f884759dae71264433b988df0e6
CPU Threads: 1; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2016-03-16_10:03:38

Seems to be fixed in dev version. Please could you test with dev version?
http://dev-builds.libreoffice.org/daily/master/
Thank you
Comment 8 Ben 2016-03-17 16:53:02 UTC
Created attachment 123668 [details]
Blanked out Formulas - test 2.png
Comment 9 raal 2016-03-17 18:23:01 UTC
(In reply to Ben from comment #8)
> Created attachment 123668 [details]
> Blanked out Formulas - test 2.png

Please try with developer version. Your printscreen show standard version. Thank you
Comment 10 Ben 2016-03-17 18:32:12 UTC
Is that: http://dev-builds.libreoffice.org/daily/master/Win-x86_64@62-TDF/
--> http://dev-builds.libreoffice.org/daily/master/Win-x86_64@62-TDF/2016-03-16_10.03.38/
--> master~2016-03-16_10.03.38_LibreOfficeDev_5.2.0.0.alpha0_Win_x64_en-US_de_ar_ja_ru_qtz.msi

I'm asking, because I'm not familiar with the directory structure.
Comment 11 raal 2016-03-17 18:54:43 UTC
(In reply to Ben from comment #10)
> Is that: http://dev-builds.libreoffice.org/daily/master/Win-x86_64@62-TDF/
> -->
> http://dev-builds.libreoffice.org/daily/master/Win-x86_64@62-TDF/2016-03-
> 16_10.03.38/
> -->
> master~2016-03-16_10.03.38_LibreOfficeDev_5.2.0.0.alpha0_Win_x64_en-
> US_de_ar_ja_ru_qtz.msi
> 
> I'm asking, because I'm not familiar with the directory structure.

Yes, it's correct>
64-bit
http://dev-builds.libreoffice.org/daily/master/Win-x86_64@62-TDF/current/
32-bit
http://dev-builds.libreoffice.org/daily/master/win-x86@39/current/
Comment 12 Ben 2016-03-17 21:55:55 UTC
Installed master~2016-03-16_10.03.38_LibreOfficeDev_5.2.0.0.alpha0_Win_x64_en-US_de_ar_ja_ru_qtz.msi 

Still the same blanking issue is present. However, when I click on the blanked formulas, then outside the formulas, save the file, terminate Writer and restart, the formula boxes are filled in properly.

I have tested this several times for a set of blanked formulas and it worked every time so far. However, I will have to traverse the whole document to check and follow the same procedure.
Comment 13 Pierre C 2016-03-18 06:52:15 UTC
I can reproduce the bug with :

libreoffice-5-1~2016-03-16_01.45.52_LibreOfficeDev_5.1.3.0.0_Win_x64_en-US_de_ar_ja_ru_qtz

All is fine with LO 4.4.7

=> NEW

=> Regression
Comment 14 raal 2016-03-18 10:43:51 UTC
This seems to have begun at the below commit.
Adding Cc: to Noel Grandin; Could you possibly take a look at this one? Thanks

86334d4aee98252413f81e7fe4e2e0fbd01346de is the first bad commit
commit 86334d4aee98252413f81e7fe4e2e0fbd01346de
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Thu Nov 12 10:00:12 2015 -0800

    source sha:db17d3c17c40d6b0e92392cf3c6e343d1d17b771

    source sha:db17d3c17c40d6b0e92392cf3c6e343d1d17b771

author	Noel Grandin <noel@peralex.com>	2015-11-10 11:36:34 (GMT)
committer	Noel Grandin <noelgrandin@gmail.com>	2015-11-11 07:16:20 (GMT)
commit	db17d3c17c40d6b0e92392cf3c6e343d1d17b771 (patch)
tree	9d562fcf764e7717df9585ef0e735a12ea4aaa16
parent	2ce9e4be4a438203382cb9cca824ce3e90647f3a (diff)
new loplugin: memoryvar
Comment 15 Noel Grandin 2016-03-18 12:34:39 UTC

*** This bug has been marked as a duplicate of bug 98622 ***