Bug 98622 - Formula (Math object) is not shown
Summary: Formula (Math object) is not shown
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
5.1.0.0.beta1
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.2.0 target:5.1.3
Keywords: bibisected, bisected, regression
: 98136 98600 98667 98729 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-03-12 17:51 UTC by Stanislav Horacek
Modified: 2016-10-25 19:02 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
sheet_with_not_shown_formula (17.17 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-03-12 17:51 UTC, Stanislav Horacek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stanislav Horacek 2016-03-12 17:51:48 UTC
Created attachment 123526 [details]
sheet_with_not_shown_formula

Open the attached file in Calc.

Observed: There is one empty sheet in the opened file.
Expected: There is a formula object in the opened file showing "Vmax,hod = 3,6 * Qins / H * u".

Tested and observed in 5.1.0 beta2 (btw. missing in the list of versions) and 5.1.1. Not present in 5.0.5 -> marking as regression. (OS: Kubuntu 15.10)
Comment 1 MM 2016-03-12 21:22:21 UTC
Unconfirmed with v5.0.5.2 under ubuntu 14.04 x64.
Confirmed with v5.1.1.3 under ubuntu 14.04 x64.
Comment 2 raal 2016-03-14 08:20:49 UTC
This seems to have begun at the below commit.
Adding Cc: to Noel Grandin; Could you possibly take a look at this one? Thanks

bibisected on windows, where this file crashes with "bad allocation":

86334d4aee98252413f81e7fe4e2e0fbd01346de is the first bad commit
commit 86334d4aee98252413f81e7fe4e2e0fbd01346de
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Thu Nov 12 10:00:12 2015 -0800

    source sha:db17d3c17c40d6b0e92392cf3c6e343d1d17b771

    source sha:db17d3c17c40d6b0e92392cf3c6e343d1d17b771
	
	author	Noel Grandin <noel@peralex.com>	2015-11-10 11:36:34 (GMT)
committer	Noel Grandin <noelgrandin@gmail.com>	2015-11-11 07:16:20 (GMT)
commit	db17d3c17c40d6b0e92392cf3c6e343d1d17b771 (patch)
tree	9d562fcf764e7717df9585ef0e735a12ea4aaa16
parent	2ce9e4be4a438203382cb9cca824ce3e90647f3a (diff)
new loplugin: memoryvar
Comment 3 Commit Notification 2016-03-15 09:10:08 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c5bee7b8c1055e5052a261c8755bdb150fb27494

tdf#98600 and tdf#98622 fix metafile parsing

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Armin Le Grand 2016-03-17 17:19:38 UTC
*** Bug 98600 has been marked as a duplicate of this bug. ***
Comment 5 V Stuart Foote 2016-03-17 17:44:28 UTC
*** Bug 98136 has been marked as a duplicate of this bug. ***
Comment 6 Noel Grandin 2016-03-18 12:34:39 UTC
*** Bug 98667 has been marked as a duplicate of this bug. ***
Comment 7 Markus Mohrhard 2016-03-22 18:43:12 UTC
@Noel: Can we close the bug?
Comment 8 Commit Notification 2016-03-23 08:48:25 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d4163c17ef47fdbc7d45adc5803b9844739b3324

tdf#98600 and tdf#98622 fix metafile parsing (part2)

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Noel Grandin 2016-03-23 08:53:55 UTC
@moggi, yes, I think we can do so now
Comment 10 Stanislav Horacek 2016-03-23 12:14:26 UTC
Thanks for the fix! Could it be backported to 5.1?
Comment 11 Commit Notification 2016-03-24 10:28:12 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ceedd3c624873cd5dbdd76456a1540560a128a01&h=libreoffice-5-1

tdf#98600 and tdf#98622 fix metafile parsing

It will be available in 5.1.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2016-03-24 10:28:18 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e3d06146f648faf35b475d536f3a9c6fd55ea188&h=libreoffice-5-1

tdf#98600 and tdf#98622 fix metafile parsing (part2)

It will be available in 5.1.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Stanislav 2016-04-06 15:29:02 UTC
No bug in LibreOfficeDev 5.1.3.0.0 on Debian GNU/Linux x86-64 (2016-03-31_08.31.30).

Is it possible to port back this bug fix to 5.1.2 release?
Comment 14 raal 2016-04-06 16:00:09 UTC
(In reply to Stanislav from comment #13)
> No bug in LibreOfficeDev 5.1.3.0.0 on Debian GNU/Linux x86-64
> (2016-03-31_08.31.30).
> 
> Is it possible to port back this bug fix to 5.1.2 release?

No, see release plan
https://wiki.documentfoundation.org/ReleasePlan/5.1

5.1.3 will be available in May.
Comment 15 Stanislav 2016-04-06 17:19:24 UTC
Thank you very much for your work.
Comment 16 Michael Stahl (CIB) 2016-05-09 16:29:52 UTC
*** Bug 98729 has been marked as a duplicate of this bug. ***