Bug 98896 - White Line in single monitor slide show mode, LibreOffice Impress
Summary: White Line in single monitor slide show mode, LibreOffice Impress
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.1.1.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Mike Kaganski
URL:
Whiteboard: target:6.3.0
Keywords:
Depends on:
Blocks: Slide-Show
  Show dependency treegraph
 
Reported: 2016-03-25 22:11 UTC by Stefan Stojanovic
Modified: 2020-06-26 14:03 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Here is a picture from my Desktop PC (787.33 KB, image/jpeg)
2016-03-26 00:31 UTC, Stefan Stojanovic
Details
A picture from laptop screen showing the white line (424.19 KB, image/jpeg)
2016-03-26 00:33 UTC, Stefan Stojanovic
Details
LibreOffice Impress file (13.70 KB, application/vnd.oasis.opendocument.presentation)
2016-03-26 00:34 UTC, Stefan Stojanovic
Details
sample presentation to test each of the 3 rendering modes, CPU only-OpenGL-Hardware Acellerated (38.59 KB, application/vnd.oasis.opendocument.presentation)
2017-10-23 14:35 UTC, V Stuart Foote
Details
Cropped screenshot from Impress 5.4.3.2 (13.02 KB, image/jpeg)
2017-12-04 16:02 UTC, Sveinn í Felli
Details
A white line on the right side of a presentation is really notable (132.50 KB, image/jpeg)
2018-08-31 08:12 UTC, asaushkin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Stojanovic 2016-03-25 22:11:00 UTC
In LibreOffice Impress there is a white line on the right  and bottom when I go into slide mode on windows, but does not happen when I try it on Linux.

LibreOffice Version : 5.1.1.3 also tested on older versions, same behavior.

Tested on 3 machines, 2 of them run Windows 7 and the 3rd one runs Windows 8, same behavior.

Only version of LibreOffice that does not do this is 3.x series, this led me to test OpenOffice and it does not occur there either.

I believe this is a bug that started on the 4.x series of LibreOffice to the current series.
Comment 1 V Stuart Foote 2016-03-25 22:42:58 UTC
Thanks for filing.

So we have a little better chance of identifying issue, could you please attach a screen clip showing the issue on a slide as presented.  And also would be helpful if you could attach an .ODP document that has the issue when opened on Windows build of LibreOffice.  Thanks!
Comment 2 Stefan Stojanovic 2016-03-26 00:31:18 UTC
Created attachment 123863 [details]
Here is a picture from my Desktop PC
Comment 3 Stefan Stojanovic 2016-03-26 00:33:03 UTC
Created attachment 123864 [details]
A picture from laptop screen showing the white line
Comment 4 Stefan Stojanovic 2016-03-26 00:34:42 UTC
Created attachment 123865 [details]
LibreOffice Impress file
Comment 5 Stefan Stojanovic 2016-03-26 00:44:25 UTC
(In reply to V Stuart Foote from comment #1)
> Thanks for filing.
> 
> So we have a little better chance of identifying issue, could you please
> attach a screen clip showing the issue on a slide as presented.  And also
> would be helpful if you could attach an .ODP document that has the issue
> when opened on Windows build of LibreOffice.  Thanks!

The file I sent you was from the desktop PC picture, the only thing I did was change the theme for the laptop picture in Impress, to see if there would be any change on a different computer, but it still shows the white line as I expected.
Comment 6 V Stuart Foote 2016-03-26 03:03:44 UTC
Confirming on Windows 10 Pro 64-bit en-US with
Version: 5.1.1.3 (x64)
Build ID: 89f508ef3ecebd2cfb8e1def0f0ba9a803b88a6d
CPU Threads: 8; OS Version: Windows 6.19; UI Render: GL; 
Locale: en-US (en_US)

The slide in presentation mode for a single monitor system renders with a 1px white band on the right edge and the bottom edge. 

The band is not present in presentation mode on a multiple monitor session.

Disabling OpenGL rendering does not affect the presence of the band. It is present on single monitor presentation mode.
Comment 7 V Stuart Foote 2016-03-26 03:05:08 UTC
1px band on right edge and bottom edge also visible on current builds of master.

Version: 5.2.0.0.alpha0+
Build ID: 5a8cd51780eaf362536284ee8bd388916a172690
CPU Threads: 8; OS Version: Windows 6.19; UI Render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-03-24_06:51:09
Locale: en-US (en_US)
Comment 8 Stefan Stojanovic 2016-03-26 21:39:30 UTC
Tested several Linux Distributions including those not based on Ubuntu and the band does not appear.
Comment 9 Stefan Stojanovic 2016-10-20 06:43:03 UTC
Just to update, the band still occurs on the latest windows 10 build 14951 with all my monitors and laptops, but not on Linux. However I recently bought a TV (as a monitor) and it does not show the band on Windows using the latest version of LibreOffice Impress. The model is VIZIO D32x-D1, but I am not sure if all the Vizio models of the D-series do this, although it seems to be working with Impress correctly. I guess you have to be lucky with what brand you buy for Impress not to show the band on Windows until this bug gets fixed.
Comment 10 QA Administrators 2017-10-23 14:05:41 UTC Comment hidden (obsolete)
Comment 11 V Stuart Foote 2017-10-23 14:31:43 UTC
Without using OpenGL or HA, so using just CPU for rendering there is a 1px edge around all four edges of the presentation canvas.  And with CPU only LibreOffice's Windows application frame will also show the 1px edge during presentation.

With OpenGL and Hardware Accelerated (HA) rendering presentation canvas extends to the entire width of the display as set--no 1px border.

3 slide test presentation attached.

=-Testing-=
Windows 10 Home (ver 1709) 64-bit en-US
Version: 5.4.3.1 (x64)
Build ID: 32c8895c6cae21571f364dbb059f419a743ee44d
CPU threads: 4; OS: Windows 6.19; UI render: default; 
Locale: en-US (en_US); Calc: group
Comment 12 V Stuart Foote 2017-10-23 14:35:36 UTC
Created attachment 137233 [details]
sample presentation to test each of the 3 rendering modes, CPU only-OpenGL-Hardware Acellerated
Comment 13 Sveinn í Felli 2017-12-04 16:00:14 UTC
I can confirm similar behaviour in LO 5.4.3.2 on LinuxMint 18.2, only the difference is that the 1px lines right and bottom are black.
There are others confirming the same (Mint and Win8.1) at <https://ask.libreoffice.org/en/question/47374/how-do-i-remove-the-1px-border-from-impress-in-full-screen-mode/>
Comment 14 Sveinn í Felli 2017-12-04 16:02:38 UTC
Created attachment 138215 [details]
Cropped screenshot from Impress 5.4.3.2
Comment 15 Stefan 2018-02-07 19:30:51 UTC
This problem still occurs on Libreoffice 6.0.0 with Win 7.


It occurs similar on a new Lenovo Ideapad with Win 10 Home and Libreoffice 6.0.0, but not as white lines.

The white lines are not visible with Debian 8.
Comment 16 asaushkin 2018-08-31 08:01:52 UTC
This is an annoying bug for me too. When I record the screen of my laptop with software like OBS and then compose it with camera's video (like a "picture in picture" effect) then a white line on the right side of the presentation video stream is really noticeable. 

This behavior is especially notable when aspect ration of a presentation and screen differ.
Comment 17 asaushkin 2018-08-31 08:12:13 UTC
Created attachment 144570 [details]
A white line on the right side of a presentation is really notable

A white line on the right side of a presentation is really notable when an aspect ratio of a presentation and a laptop screen differ.
Comment 18 fmgtack+libreoffice 2018-09-24 08:46:34 UTC
I confirm this issue on LibreOffice Impress 6.0.3.2 Build ID: 1:6.0.3-0ubuntu1 (the version that comes with Ubuntu 18.04.

Slide with black or dark background exhibits white one pixel line to the right when in slide show mode. Picture stretched over the right border of the slide will "cover" that line.

This is an issue with significant importance because it affects the core functionality of the program with wide visibility: giving presentations.
Comment 19 nash 2019-02-17 12:47:05 UTC
I can confirm that this bug still exists in 6.2. This is a visual bug in software who's entire point is to create a visual output!

Screenshots showing the bug, and one magnified view.

https://imgur.com/a/jFkQu7s
Comment 20 Mike Kaganski 2019-02-17 13:43:53 UTC
https://gerrit.libreoffice.org/67941
Comment 21 Mike Kaganski 2019-02-18 08:28:58 UTC
Please test this when dailies with the fix are available.
Comment 22 Commit Notification 2019-02-18 08:29:22 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/dd199ccb46c036713c704a23e137d04623936e47%5E%21

tdf#98896: GetWidth/GetHeight vs getWidth/getHeight strikes back!

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 23 nash 2019-02-20 16:14:06 UTC
(In reply to Commit Notification from comment #22)
> Mike Kaganski committed a patch related to this issue.
> It has been pushed to "master":
> 
> https://git.libreoffice.org/core/+/
> dd199ccb46c036713c704a23e137d04623936e47%5E%21
> 
> tdf#98896: GetWidth/GetHeight vs getWidth/getHeight strikes back!
> 
> It will be available in 6.3.0.
> 
> The patch should be included in the daily builds available at
> https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
> information about daily builds can be found at:
> https://wiki.documentfoundation.org/Testing_Daily_Builds
> 
> Affected users are encouraged to test the fix and report feedback.

Tested on:
Version: 6.2.2.0.0+ (x64)
Build ID: 20efd8050649c0b2f90233efa2c177b256d51f11
CPU threads: 8; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:libreoffice-6-2, Time: 2019-02-20_11:06:01
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded

The problem is only partially fixed. Now the 1 pixel area is no longer transparent (it's black), but it is still clickable. Clicking in that region brings forward whatever windows/desktop is behind the presentation view.
Comment 24 V Stuart Foote 2019-02-20 16:19:30 UTC
Note the target is 6.3.0 so test on TB daily of master, not a 6.2 build which won't contain the patch.
Comment 25 V Stuart Foote 2019-02-20 16:52:41 UTC
On Windows 10 Ent 64-bit en-US with nVidia Quadro K2000 (23.21.13.9133)
Version: 6.3.0.0.alpha0+ (x64)
Build ID: 2f1b939aeebf871a64fb587c078f87a5a0a9b137
CPU threads: 8; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-02-20_13:57:59
Locale: en-US (en_US); UI-Language: en-US
Calc: CL

@Mike, * 

The off-by-1 seems solved.  No black lines, nor white lines on just two edges. Presentation is centered in its frame.

Unfortunately, presenting on a single display with default rendering mode, using CPU or Hardware Acceleration, with this nVidia GPU all four edges of the slide show a 1 px boundry. But the 1px edging is not present when slides are shown with OpenGL rendering.

And the 1px edges do not show with a multi-head system, with either Default rendering or with OpenGL rendering.

The visible edge now on all four sides is equally annoying.  New bug? Or just residual of calculating the frame size (and some additional padding is needed)?