Download it now!
Bug 134318 - Line artifact shown in text box after animation
Summary: Line artifact shown in text box after animation
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: x86-64 (AMD64) Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
: 133416 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-06-26 14:03 UTC by Buovjaga
Modified: 2020-06-28 14:50 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (10.00 KB, image/png)
2020-06-26 14:03 UTC, Buovjaga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Buovjaga 2020-06-26 14:03:20 UTC
Created attachment 162426 [details]
Screenshot

1. Open attachment 161306 [details] from bug 133416
2. Play slideshow

After the animation you will see a yellow line appear. Only on Windows.

Bibisected with win 6.3 repo to https://git.libreoffice.org/core/+/dd199ccb46c036713c704a23e137d04623936e47%5E!/
tdf#98896: GetWidth/GetHeight vs getWidth/getHeight strikes back!

Adding Cc: to Mike Kaganski
Comment 1 Mike Kaganski 2020-06-26 14:42:26 UTC
I can reproduce with Version: 7.1.0.0.alpha0+ (x64)
Build ID: 1428b06e1f77ee6a190a263468358b31fd0b229d
CPU threads: 12; OS: Windows 10.0 Build 18363; UI render: default; VCL: win
Locale: ru-RU (ru_RU); UI: en-US
Calc: CL

*if* I use hardware acceleration (with or without anti-aliasing), *and* I set my screen display from standard 1920x1080 to 1776x1000 (didn't test other resolutions - but obviously it depends on some rounding).

I don't repro without HW acceleration; nor with Skia/Raster (I can't test Vulkan).

I haven't tested OpenGL.
Comment 2 Buovjaga 2020-06-28 14:48:01 UTC
Now we got a screenshot from the reporter of bug 133416, taken under FreeBSD: attachment 162468 [details]
Comment 3 Buovjaga 2020-06-28 14:50:10 UTC
*** Bug 133416 has been marked as a duplicate of this bug. ***