Bug 98980 - UI: Slide layout selection from menu or toolbar out of sync with sidebar content panel
Summary: UI: Slide layout selection from menu or toolbar out of sync with sidebar cont...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.2.0.0.alpha0+
Hardware: All All
: medium minor
Assignee: Serge Krot (CIB)
URL:
Whiteboard: target:6.0.0
Keywords:
: 107365 109252 (view as bug list)
Depends on:
Blocks: Sidebar-Properties
  Show dependency treegraph
 
Reported: 2016-03-30 12:49 UTC by Katarina Behrens (CIB)
Modified: 2018-01-10 08:47 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Katarina Behrens (CIB) 2016-03-30 12:49:24 UTC
1. Open Impress (new document, but not necessarily). 

2. Make sure sidebar is visible and no object on the slide is selected, so that slide layout sidebar panel is shown
  
  => notice the layout of the current slide is highlighted/selected in the sidebar panel

3. Now go to the new menu Slide > Slide Layout and pick a different layout 

  => notice the slide layout itself changes, but the value selected in the sidebar panel remains the same. I'd expect it to change as well.

  => additionally, given that those slide layouts are mutually exclusive, maybe they could be presented as radio buttons in the menu ... but that's a matter of taste
Comment 1 raal 2016-03-30 17:13:59 UTC
I can confirm with Version: 5.2.0.0.alpha0+
Build ID: ef34535ceb60d7d63b8d8671e4c6e9e43ffbd17d
CPU Threads: 4; OS Version: Linux 4.2; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-03-27_09:53:05
Comment 2 Katarina Behrens (CIB) 2017-05-01 13:24:38 UTC
*** Bug 107365 has been marked as a duplicate of this bug. ***
Comment 3 Xisco Faulí 2017-07-21 09:31:39 UTC
*** Bug 109252 has been marked as a duplicate of this bug. ***
Comment 4 Serge Krot (CIB) 2017-09-19 10:56:55 UTC
Implemented:
- Select item inside control when we receive EventMultiplexerEventId::ShapeXXX events, while in some cases we do not receive EventMultiplexerEventId::CurrentPageChanged event. EventMultiplexerEventId::CurrentPageChanged is received only when current focus is set inside main slide view (but not inside slide selection or any other side bars).
- Do not re-select the same item inside the control "layout of the slide".
Comment 5 Commit Notification 2017-09-20 01:50:54 UTC
Serge Krot committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8abc7ba9784f7898576fbdd7a48f0ff9e4445a68

tdf#98980 Update selection inside control when new slide layout is selected

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Serge Krot (CIB) 2017-09-20 09:45:29 UTC
Added UI unit test:
./sd/qa/uitest/tdf98980/tdf98980.py

But this unit test not finished, while there are difficulties to access control inside panel (to get actually selected layout of the slide).

Katarina Behrens (CIB): This is tough as sidebar panel as implemented in sfx2 has absolutely no knowledge of underlying UI structures. Or at least didn't have, last time I checked.
Comment 7 Xisco Faulí 2017-12-25 14:46:45 UTC
Hi Serge Krot,
Should the summary of this bug be updated to reflect what's missing wrt the original issue?
Comment 8 Serge Krot (CIB) 2018-01-10 08:47:25 UTC
Left to do:
- Add unit test