Download it now!
Bug 99114 - PDF export breaks glyph
Summary: PDF export breaks glyph
Status: RESOLVED DUPLICATE of bug 126242
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
5.1.1.3 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:pdf
Depends on:
Blocks: PDF-Export
  Show dependency treegraph
 
Reported: 2016-04-06 08:48 UTC by sommerluk
Modified: 2019-10-19 13:39 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
sample.odt (9.04 KB, application/vnd.oasis.opendocument.text)
2016-04-06 08:54 UTC, sommerluk
Details
sample_export_pdf.pdf (24.76 KB, application/pdf)
2016-04-06 08:54 UTC, sommerluk
Details
sample_export_pdf_screenshot.png (21.52 KB, image/png)
2016-04-06 08:57 UTC, sommerluk
Details
sample_print_to_virtual_pdf_printer.pdf (3.84 KB, application/pdf)
2016-04-06 08:58 UTC, sommerluk
Details
EBGaramond12-Regular.otf (SIL OPEN FONT LICENSE Version 1.1) (483.69 KB, application/x-font-otf)
2016-04-07 08:04 UTC, sommerluk
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sommerluk 2016-04-06 08:48:28 UTC
PDF export breaks glyph.

When using the font “EB Garamond 12”, the glyph for “m” is broken when using LibreOffice’s PDF export function.

This bug is not specific to Writer, but also occures in Calc.

When printing to a virtual PDF printer, than there is no problem.
Comment 1 sommerluk 2016-04-06 08:54:28 UTC
Created attachment 124119 [details]
sample.odt
Comment 2 sommerluk 2016-04-06 08:54:57 UTC
Created attachment 124120 [details]
sample_export_pdf.pdf
Comment 3 sommerluk 2016-04-06 08:57:47 UTC
Created attachment 124121 [details]
sample_export_pdf_screenshot.png
Comment 4 sommerluk 2016-04-06 08:58:06 UTC
Created attachment 124122 [details]
sample_print_to_virtual_pdf_printer.pdf
Comment 5 V Stuart Foote 2016-04-07 04:52:11 UTC
Confirming the visual glitch in your LibreOffice export to PDF vs. your Ghostscript 9.14 based PDF24 virtual printer.

As you are working on Windows with an 32-bit x86 build of 5.1.1.3, is OpenGL enabled or disabled?  And on what release of Windows?

Helpful if you copy and paste the details from the Help -> About LibreOffice panel.  Also, as "EB Garamond 12" is not a common font on Windows builds, please  embed in your sample ODT (File -> Properties: Font tab) and perhaps bracket the "m" with some other text to make it possible to locate more easily in the PDFs.
Comment 6 sommerluk 2016-04-07 08:04:16 UTC
Created attachment 124148 [details]
EBGaramond12-Regular.otf (SIL OPEN FONT LICENSE Version 1.1)
Comment 7 sommerluk 2016-04-07 08:10:29 UTC
I’ve tried to embed the font as you described. But the resulting .odt file has 11 MB. (Despite that the font file itself has only about 500 kB.) As this exceeds the bugzilla size limit for attachments, I cannot upload the .odt file. Instead, I’ve uploaded the font file directly (only this special font of the font family). I hope this is okay; it is licensed under the SIL Open Font License 1.1. You can get the full package with all fonts of this font family from the author https://bitbucket.org/georgd/eb-garamond/downloads/EBGaramond-0.016.zip
Comment 8 sommerluk 2016-04-07 08:11:21 UTC
Is the enormous file size increase with font embedding a separate bug?
Comment 9 sommerluk 2016-04-07 08:28:58 UTC
Operating system name: Microsoft Windows 10 Home
Version: 10.0.10240 Build 10240

LibreOffice version info:
Version: 5.1.1.3
Build-ID: 89f508ef3ecebd2cfb8e1def0f0ba9a803b88a6d
CPU-Threats: 4; BS-Version: Windows 6.2; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE)

OpenGL: Not sure if this is the information that you want, but glview443.exe says that OpenGL 3.1 is available.
Comment 10 V Stuart Foote 2016-04-07 15:56:16 UTC
(In reply to sommerluk from comment #9)
> Operating system name: Microsoft Windows 10 Home
> Version: 10.0.10240 Build 10240
> 
> LibreOffice version info:
> Version: 5.1.1.3
> Build-ID: 89f508ef3ecebd2cfb8e1def0f0ba9a803b88a6d
> CPU-Threats: 4; BS-Version: Windows 6.2; UI-Render: Standard; 
> Gebietsschema: de-DE (de_DE)
> 
> OpenGL: Not sure if this is the information that you want, but glview443.exe
> says that OpenGL 3.1 is available.

That was exactly what was needed, but it appears OpenGL is not the issue here.

Thanks for posting the EB Garamond 12 font--nice that it is SIL Open Font License

Yes, I can reproduce on Windows 10 Pro 64-bit en-US with
Version: 5.1.2.2 (x64)
Build ID: d3bf12ecb743fc0d20e0be0c58ca359301eb705f
CPU Threads: 8; OS Version: Windows 6.19; UI Render: default; 
Locale: en-US (en_US)

STR

1. install linked EB Garamond 12 font
2. launch Writer  (disable OpenGL rendering and restart if needed)
3. write a couple lines of sample text--I used font name and multiple "m"s, in the default Liberation Serif
4. copy lines, paste
5. change font for pasted selection to EB Garamond 12
6. save to .ODT
7. menu -> Export as PDF
8. in PDF dialog select lossless compression for images, and PDF/A-1a (ISO 19005-1) in general tab
9. export
10. open the resulting PDF in Adobe Acrobat Reader -- zoom resolution > 400%

Visual glitch in forming the right leg of the "m" as in attachment 124121 [details]

Various "print" to PDF methods (Adobe, MS, gs) do not exhibit same issue--so believe issue is in LibreOffice's PDF composition.

Rendering glitch of the font on export to PDF is also present from Draw text box.
Comment 11 QA Administrators 2017-10-30 08:33:00 UTC Comment hidden (obsolete)
Comment 12 V Stuart Foote 2017-10-30 17:10:35 UTC
The visual glitch in export to PDF is still present for this font.

Version: 5.4.3.1 (x64)
Build ID: 32c8895c6cae21571f364dbb059f419a743ee44d
CPU threads: 8; OS: Windows 6.19; UI render: default--or--GL ;
Locale: en-US (en_US); Calc: group

Version: 6.0.0.0.alpha1+ (x64)
Build ID: 141279127b4c9ced4d86af245e1d780c473cd5bb
CPU threads: 8; OS: Windows 10.0; UI render: default--or--GL;
TinderBox: Win-x86_64@42, Branch:master, Time: 2017-10-25_02:50:04
Locale: en-US (en_US); Calc: CL
Comment 13 sommerluk 2017-10-30 17:31:46 UTC
Still the same problem in

Version: 5.4.0.3
Build-ID: 7556cbc6811c9d992f4064ab9287069087d7f62c
CPU-Threads: 4; Betriebssystem:Windows 6.2; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: group
Comment 14 QA Administrators 2018-10-31 03:52:51 UTC Comment hidden (obsolete)
Comment 15 sommerluk 2018-10-31 05:51:20 UTC
Still a confirmed bug in Version: 5.4.0.3
Build-ID: 7556cbc6811c9d992f4064ab9287069087d7f62c
CPU-Threads: 4; Betriebssystem:Windows 6.2; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: group
Comment 16 V Stuart Foote 2019-10-19 13:39:02 UTC

*** This bug has been marked as a duplicate of bug 126242 ***