Bug 99168 - Some PNG printed distorted, displayed correctly
Summary: Some PNG printed distorted, displayed correctly
Status: RESOLVED DUPLICATE of bug 96653
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.5.1 rc
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-04-08 16:38 UTC by Schubert
Modified: 2016-04-12 15:26 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
3 pictures that cannot be printed correctly (1.86 MB, application/vnd.oasis.opendocument.text)
2016-04-08 16:38 UTC, Schubert
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Schubert 2016-04-08 16:38:05 UTC
Created attachment 124191 [details]
3 pictures that cannot be printed correctly

In 5.0.5.1 half of the pictures in a file are printed distorted, but displayed correctly. The rest is printed correctly.
In 4.4.3.2 all are printed correctly. Also from other programs these pictures are printed correctly.
Some of the distorted pictures are attached in the file ErichGerlindetest.odt.
Comment 1 V Stuart Foote 2016-04-09 15:57:53 UTC
Fixed with 
http://cgit.freedesktop.org/libreoffice/core/commit/?id=fdf698bef5bf25c2a10e2b8ddb1955143cd3f227&h=libreoffice-5-1

available with 5.0.5, 5.1.1 and master builds

suggest upgrade to 5.1.2.2 release.

*** This bug has been marked as a duplicate of bug 96653 ***
Comment 2 V Stuart Foote 2016-04-09 16:01:50 UTC
(In reply to V Stuart Foote from comment #1)

> *** This bug has been marked as a duplicate of bug 96653 ***

Apologies! Pasted into the wrong issue -- that Resolved Duplicate was meant for bug 99177. Back to unconfirmed.
Comment 3 V Stuart Foote 2016-04-09 16:14:32 UTC
Can not confirm. All images (1 png, 2 jpg) in document print to ghostscript based pdf, and PCL printers.

What print mechanism in use on your Linux system?

Also, you might be better served with a 5.1.2.2 release.
Comment 4 V Stuart Foote 2016-04-09 20:23:23 UTC
OP replied in PM

Thanks for your fast reaction.

*Conversion to pdf* worked for the two jpgs correctly, but the png was
still distorted but less than when printed on the printer.
If I transform the png to jpg it is also converted correctly and prints
correctly, so there seems to be a problem with png.

*Printing* I print via CUPS with the driver HP Officejet Pro 8000 a809,
hpcups 3.14.6.
Printing from Windows 10 with Writer 4.4.3.2 via the same CUPS on the
same printer works correctly for all 3 pictures.

I cannot upgrade to higher than 5.0.5.1 yet as this is not yet in the
Debian package.

Hope this can help you.
Comment 5 raal 2016-04-10 11:42:53 UTC
Hello, duplicate of bug 96653?
Comment 6 Schubert 2016-04-10 13:44:52 UTC
On my png and on the corrupted jpgs there are also diagonal lines.
Schubert
Comment 7 V Stuart Foote 2016-04-10 14:51:45 UTC
> On my png and on the corrupted jpgs there are also diagonal lines.

With that last bit of detail, seems this is a dupe of bug 96653 and installing the 5.0.5.2 release, a 5.0.6 nightly or the 5.1.2.2 release or a build of 5.2.0 alpha should resolve things.

> I cannot upgrade to higher than 5.0.5.1 yet as this is not yet in the
> Debian package.
> 

OK, when your Linux distro or preferred repository packages the 5.0.5.2 release (or better 5.1.2.2) you should upgrade and retest and see if it resolves your issue--suspect it will.

As an alternative to waiting on your Linux distro, you can obtain current project built .deb packages.

http://downloadarchive.documentfoundation.org/libreoffice/old/5.0.5.2/deb/
http://downloadarchive.documentfoundation.org/libreoffice/old/5.1.2.2/deb/

Installation instruction are here.
https://wiki.documentfoundation.org/Installing_in_parallel/Linux

*** This bug has been marked as a duplicate of bug 96653 ***
Comment 8 Schubert 2016-04-10 15:55:33 UTC
I understand that the bug is fixed for png.
But does this hold true also for jpgs?
They can be printed from other programs and from writer 4.4.3.2, but not from writer 5.0.5.1 via CUPS with the driver HP Officejet Pro 8000 a809,
hpcups 3.14.6.
Comment 9 raal 2016-04-12 07:50:51 UTC
(In reply to Schubert from comment #8)
> I understand that the bug is fixed for png.
> But does this hold true also for jpgs?
> They can be printed from other programs and from writer 4.4.3.2, but not
> from writer 5.0.5.1 via CUPS with the driver HP Officejet Pro 8000 a809,
> hpcups 3.14.6.

Please test it. Dev version you can download here: http://dev-builds.libreoffice.org/daily/master/
Comment 10 Schubert 2016-04-12 15:26:02 UTC
I upgraded to Version: 5.1.2.2.0+; Build-ID: 1:5.1.2-3 and all pictures are printed correctly. The problem is solved. Thank you very much for your fast response.