Download it now!
Bug 99280 - Shift+Space, Ctrl+Space, Ctrl+Shift+Space, and clicking row/column/all headers do not work as expected when inserting into a formula
Summary: Shift+Space, Ctrl+Space, Ctrl+Shift+Space, and clicking row/column/all header...
Status: RESOLVED DUPLICATE of bug 92452
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.1.1.3 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Shortcuts-Accelerators
  Show dependency treegraph
 
Reported: 2016-04-14 00:25 UTC by Jon
Modified: 2016-05-11 11:05 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jon 2016-04-14 00:25:09 UTC
In "normal" mode, selections can be made with the keyboard or mouse in several ways, the most obvious being holding shift while pressing the arrow keys.

When entering a formula, these same functions do not select but enter the would-be selection into a formula as a range.

Except when selecting an entire row or column. Assuming cell B2 is active:

-Shift+space (usually selects the entire row) should insert "2:2" into the formula, but it inserts a space.
-Ctrl+shift+space (usually selects the entire column) should insert "B:B" into the formula, but it makes a "normal" selection.
-Clicking the column or row headers should also insert appropriately into the formula, but do nothing.
Comment 1 Óvári 2016-04-17 21:56:58 UTC
Shift+Space       → Entire row
Ctrl+Space        → Entire column
Ctrl+Shift+Space  → Entire sheet

This bug may relate to:
Bug 92452 - Keyboard to select entire row or column or sheet when in formulae mode 
Bug 92453 - Entire column functionality in formulae keyboard shortcuts
Bug 96981 - All cells selector button not functional when in formula mode

Updated title:
Shift+Space, Ctrl+Space, Ctrl+Shift+Space, and clicking row/column/all headers do not work as expected when inserting into a formula
Comment 2 raal 2016-05-11 11:05:40 UTC

*** This bug has been marked as a duplicate of bug 92452 ***