Download it now!
Bug 99287 - Libre office Calc crashes/freezes when sorting an XLS spreadsheet.(EDITING)
Summary: Libre office Calc crashes/freezes when sorting an XLS spreadsheet.(EDITING)
Status: RESOLVED DUPLICATE of bug 99208
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.0.1.1 rc
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2016-04-14 06:16 UTC by Quinton
Modified: 2016-04-14 09:32 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Sample XLS file that causes the sort bug. (11.00 KB, application/vnd.ms-excel)
2016-04-14 07:33 UTC, Quinton
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Quinton 2016-04-14 06:16:09 UTC
When doing a natural sort that includes headings on an XLS spreadsheet, Libre Calc freezes. This is also affecting the UNO api. This problem happens in version 5.11 and 5.1.2. This does not happen in version 5.0.
Comment 1 raal 2016-04-14 07:21:19 UTC
Hello,

Thank you for filing the bug. Please send us a sample document, as this makes it easier for us to verify the bug. 
I have set the bug's status to 'NEEDINFO', so please do change it back to 'UNCONFIRMED' once you have attached a document.
(Please note that the attachment will be public, remove any sensitive information before attaching it.)
How can I eliminate confidential data from a sample document?
https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F
Thank you
Comment 2 raal 2016-04-14 07:23:45 UTC
Maybe duplicate of bug 99208.


Maybe it's fixed with dev version. Please could you test it with dev version?  You can download it here: http://dev-builds.libreoffice.org/daily/master/
Comment 3 Quinton 2016-04-14 07:33:52 UTC
Created attachment 124317 [details]
Sample XLS file that causes the sort bug.
Comment 4 Quinton 2016-04-14 08:33:21 UTC
Hi Raal,

The sorting works in the 5.2.0.0 dev build.

Thank you,
Comment 5 raal 2016-04-14 09:32:05 UTC
Thanks for testing. Closing the bug.

*** This bug has been marked as a duplicate of bug 99208 ***