Bug 99390 - Non-printing characters not shown in a text box
Summary: Non-printing characters not shown in a text box
Status: RESOLVED DUPLICATE of bug 102249
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86-64 (AMD64) Linux (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-04-19 10:28 UTC by Johnny_M
Modified: 2016-09-22 17:08 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot displaying the issue (43.11 KB, image/png)
2016-04-19 10:28 UTC, Johnny_M
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Johnny_M 2016-04-19 10:28:48 UTC
Created attachment 124494 [details]
Screenshot displaying the issue

The non-printing characters are not shown in a text box when activated.

Test steps:
1. Start LibreOffice and create a new Writer document.
2. Activate display of non-printing characters.
3. Insert a text box and enter some spaces, tabs, line breaks and text into it.

Expected results:
2. The non-printing characters are shown in the main text body.
3. The non-printing characters are shown in the text box.

Actual results:
3. No non-printing characters are shown. (See attached screenshot.)


Linux Mint 17.1 64-bit
LO 5.0.5.2 from ppa:libreoffice/libreoffice-5-0 (Build ID: 1:5.0.5~rc2-0ubuntu1~trusty)
Comment 1 raal 2016-04-19 10:46:55 UTC
confirm Version: 5.2.0.0.alpha0+
Build ID: 0f27cc992a99568e46ffe807ef9dbb5ba0bc601f
CPU Threads: 4; OS Version: Linux 4.2; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-04-12_23:40:16
Comment 2 V Stuart Foote 2016-04-19 14:35:57 UTC
A "Text Box" is a drawing object and comes from the draw/impress modules, and has only in recent builds been directly available along with drawing shape objects in the Writer standard toolbar (long present on the Drawing toolbar).

As drawing objects there are very minimal formatting attributes to be applied to the text annotation, and there are no paragraph object structures in the text.

Showing non-printing characters is simply an attribute that is not implemented for the text annotation contained in a text box--unclear how involved it would be to implement. But question the need for this enhancement.

In any case a dupe of bug 95066

*** This bug has been marked as a duplicate of bug 95066 ***
Comment 3 V Stuart Foote 2016-09-22 17:08:38 UTC

*** This bug has been marked as a duplicate of bug 102249 ***