Bug Hunting Session
Bug 99438 - FILESAVE Can't save a spreadsheet as .xltx (xlsx template)
Summary: FILESAVE Can't save a spreadsheet as .xltx (xlsx template)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: target:6.3.0
Keywords:
: 118462 (view as bug list)
Depends on:
Blocks: Save XLSX
  Show dependency treegraph
 
Reported: 2016-04-21 14:44 UTC by Katarina Behrens (CIB)
Modified: 2019-03-05 07:35 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Katarina Behrens (CIB) 2016-04-21 14:44:43 UTC
As per summary, it seems not to be possible to save a spreadsheet as .xltx ( =  a template file in .xlsx format )

I can open a file saved in Excel with .xltx extension and it'll correctly open as a new, untitled document, it's just saving into this format that is missing.

It works with binary .xlt, as well as native .ots and, as far as I can see, it's always been like that (inherited from OOo)
Comment 1 Cor Nouws 2016-04-21 20:12:32 UTC
confirmed.

The same applies for dotx, dotm and potx, but not for potm :)
Comment 2 Aron Budea 2018-07-02 03:42:56 UTC
*** Bug 118462 has been marked as a duplicate of this bug. ***
Comment 3 flywire 2018-07-02 08:56:21 UTC
If you want to see the trivial code to solve the issue look at bug 118462.
Comment 4 flywire 2018-07-24 03:47:23 UTC
Name: [Content_Types].xml

<?xml version="1.0" encoding="UTF-8" standalone="true"?>
-<Types xmlns="http://schemas.openxmlformats.org/package/2006/content-types">

Test.xlsx\
<Override ContentType="application/vnd.openxmlformats-officedocument.spreadsheetml.sheet.main+xml" PartName="/xl/workbook.xml"/>

Test.xlts\
<Override ContentType="application/vnd.openxmlformats-officedocument.spreadsheetml.template.main+xml" PartName="/xl/workbook.xml"/>


Test.xlsm\
<Override ContentType="application/vnd.ms-excel.sheet.macroEnabled.main+xml" PartName="/xl/workbook.xml"/>

Test.xltm\
<Override ContentType="application/vnd.ms-excel.template.macroEnabled.main+xml" PartName="/xl/workbook.xml"/>
Comment 5 Commit Notification 2018-12-17 14:54:56 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/8cc29e7040ed02afd5f979e23c9ec154c0cb2c83%5E%21

tdf#99438: sc: support for .xltx export

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 flywire 2019-01-02 13:09:37 UTC
Still no Excel 2007-2019 (macro-enabled template)(*.xltm). More than original issue but was marked as duplicate and closed so incorporated into this issue.

Just to be clear - not expecting to write or run code, just save existing code if workbook template changed. One use case might be edit and save existing macro-enabled spreadsheet as macro-enabled template.
Comment 7 flywire 2019-01-02 13:17:26 UTC
Same functionality is appropriate in other modules, especially Writer, and file type description should be exactly consistent across all modules.
Comment 8 Roman Kuznetsov 2019-03-04 07:33:36 UTC
(In reply to flywire0 from comment #6)
> Still no Excel 2007-2019 (macro-enabled template)(*.xltm). More than
> original issue but was marked as duplicate and closed so incorporated into
> this issue.
> 

see at bug 118463

I think this bug need to close as FIXED
Comment 9 flywire 2019-03-04 21:10:37 UTC
Part fix in my opinion since same issue applies to writer and other modules. Do they really have to be listed as individual bugs?
Comment 10 Aron Budea 2019-03-05 04:22:49 UTC
Yes.
Comment 11 Roman Kuznetsov 2019-03-05 06:02:36 UTC
(In reply to flywire from comment #9)
> Part fix in my opinion since same issue applies to writer and other modules.
> Do they really have to be listed as individual bugs?

FYI:
https://gerrit.libreoffice.org/#/c/64947/ sw: support for saving into .dotx file
Comment 12 flywire 2019-03-05 07:35:34 UTC
Thanks. PowerPoint 2007-2019 Template (*.potx) also implemented - I'm sure neither were there when I initially checked.

Suppose Macro-Enabled Template interface could be enabled in response to Bug 118463.