Bug 99599 - File -> Wizards -> Web Page does not work
Summary: File -> Wizards -> Web Page does not work
Status: VERIFIED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.2.0.0.alpha0+
Hardware: x86-64 (AMD64) Windows (All)
: high critical
Assignee: Not Assigned
URL:
Whiteboard: target:5.2.0
Keywords: bibisected, regression
Depends on:
Blocks:
 
Reported: 2016-05-01 04:02 UTC by baffclan
Modified: 2016-10-25 19:01 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
bibisect output, daily Linux dbgutil repository (2.46 KB, text/plain)
2016-05-02 20:40 UTC, Terrence Enger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description baffclan 2016-05-01 04:02:41 UTC
Steps to Reproduce:
1. Start LibreOfficeDev
2. File -> Wizards -> Web Page...

Actual Results:
Nothing happened

Expected Results:
Open a Web Wizard Dialog


Windows 7 Pro(x64)
Version: 5.2.0.0.alpha0+ (x64)
Build ID: e8425c48102321d4f5a8bd687c8ca1ac7bae797e
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2016-04-20_16:47:56
Locale: ja-JP (ja_JP)
Comment 1 Julien Nabet 2016-05-01 09:15:03 UTC
On pc Debian x86-64 with master sources updated today, none of the wizard in File menu work!
Comment 2 Terrence Enger 2016-05-02 20:40:19 UTC
Created attachment 124799 [details]
bibisect output, daily Linux dbgutil repository

Working in the daily Linux dbgutil bibisect repository, I have
narrowed down introduction of the bug ...

         commit  date       s-h
         ------- ---------- -------
    good 8936e6d 2016-03-15 885eb42
    bad  2b807c4 2016-03-16 53f645a

This covers 37 source commits.
Comment 3 Julien Nabet 2016-05-02 21:01:19 UTC
Thank you Terrence for the bibisect!

I noticed that bug only happen with SAL_USE_VCLPLUGIN=gtk3
not with SAL_USE_VCLPLUGIN=gtk or with SAL_USE_VCLPLUGIN=gen

Caolan: I've reverted locally https://cgit.freedesktop.org/libreoffice/core/commit/?id=66db55aa84e8401a9eccedb02c67150833a344ba and I don't reproduce this bug.
Thought you might be interested in this one.
Here are my gtk info:
julien@debian:~/lo/libreoffice/instdir/program$ dpkg -l libgtk* | grep -e '^i' | grep -e 'libgtk-*[0-9]'
ii  libgtk-3-0:amd64             3.18.9-1      amd64        GTK+ graphical user interface library
ii  libgtk-3-bin                 3.18.9-1      amd64        programs for the GTK+ graphical user interface library
ii  libgtk-3-common              3.18.9-1      all          common files for the GTK+ graphical user interface library
ii  libgtk-3-dev:amd64           3.18.9-1      amd64        development files for the GTK+ library
ii  libgtk2-perl                 2:1.2498-1    amd64        Perl interface to the 2.x series of the Gimp Toolkit library
ii  libgtk2.0-0:amd64            2.24.30-1.1   amd64        GTK+ graphical user interface library
ii  libgtk2.0-bin                2.24.30-1.1   amd64        programs for the GTK+ graphical user interface library
ii  libgtk2.0-common             2.24.30-1.1   all          common files for the GTK+ graphical user interface library
ii  libgtk2.0-dev                2.24.30-1.1   amd64        development files for the GTK+ library
Comment 4 Commit Notification 2016-05-06 10:25:52 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=27014f563577c3c5da19e37a57d4e73c0ebae140

Resolves: tdf#92067 and tdf#99599, use a foolproof action naming scheme

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Julien Nabet 2016-05-06 13:40:05 UTC
I tested with the patch included (
27014f563577c3c5da19e37a57d4e73c0ebae140), it's ok now.

Thank you Caolán!
Comment 6 baffclan 2016-05-16 08:36:05 UTC
Reproduce my report problem.

Steps to Reproduce:
1. Start LibreOfficeDev
2. File -> Wizards -> Web Page...

Actual Results:
Nothing happened

Expected Results:
Open a Web Wizard Dialog

Version: 5.2.0.0.alpha1+
Build ID: 145b2c94f245b07ba5079eda111bd9bfb85ee29f
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-05-16_01:02:22
Locale: ja-JP (ja_JP)

-> reopened
Comment 7 Caolán McNamara 2016-05-16 09:57:19 UTC
Comments 1 to 5 are all about the gtk3 backend. Comments 0 and 6 are about windows. So it seems a different bug was detected and fixed in 1-5.

I think these wizards are now in python. Does Tools->Macros->Organize Macros->Python->LibreOfficeDev Macros->HelloWorld->HelloWorldPython->Run work to insert "Hello World" into writer ?
Comment 8 baffclan 2016-05-16 11:34:07 UTC
(In reply to Caolán McNamara from comment #7)
> Comments 1 to 5 are all about the gtk3 backend. Comments 0 and 6 are about
> windows. So it seems a different bug was detected and fixed in 1-5.
I think, comment 1 - 5 is another problem.
I reported the defect has occurred in Windows.

> I think these wizards are now in python. Does Tools->Macros->Organize
> Macros->Python->LibreOfficeDev Macros->HelloWorld->HelloWorldPython->Run
> work to insert "Hello World" into writer ?
Macro write in Writer
> Hello World (in Python)


raal, Beluga
Can you check this?
Comment 9 Julien Nabet 2016-05-17 05:17:46 UTC
At least with master sources updated 2 days ago (49cdc1da7660328d64a964fbc26611bf8ce158aa), I don't reproduce this.
I'll make another try tonight after an update + full rebuild.
Comment 10 Buovjaga 2016-05-17 09:25:47 UTC
I confirm the problem with File -> Wizards -> Web Page on Windows, but not on Linux.

Hello world Python works for me.

Win 7 Pro 64-bit Version: 5.2.0.0.alpha1+
Build ID: 3d27afd26f7b85c46a7c7d08498000b9dbcea1c8
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-05-09_02:42:15
Locale: fi-FI (fi_FI)
Comment 11 baffclan 2016-05-17 13:38:09 UTC
Works wizard:
 Letter
 Fax
 Agenda
 Presentation
 Document Converter
 Euro Converter
 Address Data Source
is appear Wizard window.

No work wizard:
 Web Page
is nothing happened.


Windows 7 Pro(x64)
Version: 5.2.0.0.alpha1+
Build ID: cc1a0ba927ad6f85103059aa8e6108017f436304
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-05-17_02:31:19
Locale: ja-JP (ja_JP)
Comment 12 baffclan 2016-05-19 12:41:47 UTC
Reproduce:
Windows 7 Pro(x64)
Version: 5.2.0.0.alpha1+
Build ID: 389d8db4d90d427f886d06c3f7304ad973f0d39c
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-05-19_00:15:59
Locale: ja-JP (ja_JP)
Comment 13 Buovjaga 2016-05-22 15:33:53 UTC
Just found out about bug 99967
I guess I'll close this as WONTFIX then.
Comment 14 baffclan 2016-05-22 21:12:35 UTC
(In reply to Buovjaga from comment #13)
> Just found out about bug 99967
me too.

> I guess I'll close this as WONTFIX then.
 -> VERIFIED