Download it now!
Bug 99741 - [FORMATTING] Broken handling of column section footnotes
Summary: [FORMATTING] Broken handling of column section footnotes
Status: RESOLVED DUPLICATE of bug 54465
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-05-09 09:09 UTC by Nicolas Mailhot
Modified: 2016-05-14 19:26 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Testcasez (9.26 KB, application/vnd.oasis.opendocument.text)
2016-05-14 08:48 UTC, Nicolas Mailhot
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nicolas Mailhot 2016-05-09 09:09:45 UTC
Writer permits the creation of less-than-full-page sections with a number of columns different from the section before and after. (for example, a quarter-page section with two columns: insert → columns)

However this setup breaks as soon as one adds a footnote to one of the paragraphs inside the column section :

A. the correct handling for an heavily columned document is to add the footnote at the end of the column section, in the last column (even if this end is in the middle of the page). That's what newspapers do

B. the correct handling for a small column section added for effect, is to place the footnote at the end of the page, even if the document continues with the next section before the end of the page

Ideally Writer would propose both options.

However it does neither. Adding a footnote to a column section forces the section to continue till the end of the page. You get the worst of both worlds:

1. the footnote is far removed from the column content, as in B, but there is a lot of ugly whitespace between the end of the section and the footnote. That kills column usefulness as small chapter heading

2. the footnote is contiguous with the column content, as in A, but not formatted column-wise. That kills footnotes in newspaper-like documents. 

Please fix.
Comment 1 Buovjaga 2016-05-13 06:43:30 UTC
(In reply to Nicolas Mailhot from comment #0)
> Writer permits the creation of less-than-full-page sections with a number of
> columns different from the section before and after. (for example, a
> quarter-page section with two columns: insert → columns)

Please give full steps to reproduce.

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the information.
Comment 2 Nicolas Mailhot 2016-05-14 08:48:48 UTC
Created attachment 125043 [details]
Testcasez

Add and remove the footnote in this testcase and watch how writer cheats by moving the section break to end of page
Comment 3 Buovjaga 2016-05-14 19:26:45 UTC

*** This bug has been marked as a duplicate of bug 54465 ***