Bug Hunting Session
Bug 99748 - Upgrade Deleted Font(s)
Summary: Upgrade Deleted Font(s)
Status: RESOLVED DUPLICATE of bug 97982
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-05-09 16:24 UTC by Brian Smither
Modified: 2016-05-16 11:21 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Brian Smither 2016-05-09 16:24:49 UTC
After upgrading from 5.0.4 (Win7x64.msi) to 5.0.5.2, I discovered that Win7 lost reference to the font DejaVu Sans Mono Book. (The three other variants are still available.)

I have not searched for any other missing fonts.

As this upgrade has been the only change to the system in weeks, I can confidently place the blame to LibreIffice's upgrade processing.
Comment 1 Brian Smither 2016-05-09 16:30:21 UTC
To be fair, I have not rebooted the system after the upgrade.
Comment 2 Julien Nabet 2016-05-09 18:54:20 UTC
For the test, could you upgrade to last stable version 5.1.2 + rename your LO directory profile (see https://wiki.documentfoundation.org/UserProfile#Windows) and give a new try?
Comment 3 Brian Smither 2016-05-10 22:28:39 UTC
"Check for Updates" now says 5.0.6 is available. You say 5.1.2. Will I need to cycle through all intermediate versions?
Comment 4 Brian Smither 2016-05-10 22:47:47 UTC
I upgraded to 5.0.6.3. I did not check if the same font when missing.

I then renamed /4/user/ to /4/user.old/ and initiated the upgrade to 5.1.2.2. When it was finished, I rebooted the computer.

The font, DejaVu Sans Mono Book, went missing again.
Comment 5 Brian Smither 2016-05-10 22:49:50 UTC
I would like to fix my spelling mistakes.

I did not check if the same font when missing.
I did not check if the same font went missing.
Comment 6 Julien Nabet 2016-05-10 22:51:00 UTC
Ok then.
Since I don't have other questions, I'll put it back to UNCONFIRMED.
Comment 7 Buovjaga 2016-05-13 07:11:57 UTC
For me DejaVu Sans Mono Book is not a separate font file, but simply the default style of DejaVu Sans Mono.
So are you saying DejaVu Sans Mono is removed from \windows\fonts?

Win 7 Pro 64-bit, Version: 5.1.2.2 (x64)
Build ID: d3bf12ecb743fc0d20e0be0c58ca359301eb705f
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
Locale: fi-FI (fi_FI)
Comment 8 Brian Smither 2016-05-13 14:07:53 UTC
For me, the downloaded DejaVu font set (sourceforge.net) includes, as separate files, a number of font variations, including these (as separate files):
DejavuSansMono.ttf
DejaVuSansMono-Oblique.ttf
DejaVuSansMono-Bold.ttf
DejaVuSansMono-BoldOblique.ttf

(The Font Viewer names the plain variant as 'Book'.)

Win7 lost its association with (enumeration of) that font. (I assume the mechanics of that association involves the registry.) The loss presents itself as:
* no application is able to use the font
* "DejaVu Sans Mono Book" is not present in the Control Panel "Fonts" viewer

From the download package, I install that font, but am advised the font already exists, do I want to overwrite?

Therefore, I believe the font's association is lost, as opposed to the font file actually being deleted.
Comment 9 Buovjaga 2016-05-13 14:42:57 UTC
See comment 16 in bug 76239

*** This bug has been marked as a duplicate of bug 76239 ***
Comment 10 Timur 2016-05-16 11:21:30 UTC
I'd say this is s duplicate of Bug 97982 so I change. 
The only solution I found was manual installation of fonts, or via script.

*** This bug has been marked as a duplicate of bug 97982 ***